Reply
Newbie
jrinco11
Posts: 2
Registered: ‎19-03-2010
0

How to get a wireless router to work behind a BT Home Hub 2

Hi - I recently moved to the UK and am trying to get my Linksys WRT54G-TM (flashed with DD-WRT v24) to work behind the BT HomeHub 2.  Specifically, I am wanting to use the PPTP connection that DD-WRT provides so that I can VPN through my home connection when I am using public wifi connections (when travelling, or just simply away from home).

 

I thought I would just simply be able to connect one of the LAN ports from the homehub to the WAN port of my linksys, and then just open up all traffic from the HomeHub to the homehub lan ip address of the linksys (perhaps by using DMZ?) but my linksys router does not show up as one of the connected devices anywhere in the Home Hub settings.    I can see all my laptops, iphone, PAP2 ATA device, etc -- but not my linksys router, even though it's connected via ethernet. 

 

Is it possible to basically just use the home hub 2.0 as a modem, and pass along all routing/firewall/etc to my linksys router?   Any ideas on how to allow PPTP connections to be forwarded directly to the router when connected to the homehub?

 

thanks for any advice!!

Aspiring Expert
NanoTm
Posts: 720
Registered: ‎30-01-2010
0

Re: How to get a wireless router to work behind a BT Home Hub 2

check the ip addresses of both routers and while your at it i would advise that instead of messing with dmz forwading you invest in a better router that you can actually setup properly.

 

oh and if you didnt already realise the hubs not exactly good at keeping your connection alive, tends to do its own thing in terms of updates, line syncs etc regardless of what your trying to do.

 

and also once you have made sure there both on the same ip range, set the linksys to a static ip arround the top of the available range, then disable the dhcp in the linksys.

Aspiring Expert
Jarviser
Posts: 119
Registered: ‎27-01-2010
0

Re: How to get a wireless router to work behind a BT Home Hub 2

[ Edited ]

 


jrinco11 wrote:my linksys router does not show up as one of the connected devices anywhere in the Home Hub settings.    I can see all my laptops, iphone, PAP2 ATA device, etc -- but not my linksys router, even though it's connected via ethernet. ...

 


 

 

I always found that secondary routers were invisible to the master home hub's device table, particularly as you need to fix the secondary hub's IP in the 192.168.1.xxx range (static IP are often also invisible).

 

  Ignore the devices table in homehubs, just test the connection by connecting a PC to the secondary hub and try to access either the internet or the homehub. Turn off DHCP and firewall in the secondary hub.

_________________________________________


..... Jarviser's Home Hub Index
Newbie
jrinco11
Posts: 2
Registered: ‎19-03-2010
0

Re: How to get a wireless router to work behind a BT Home Hub 2

[ Edited ]

the problem is that my linksys (with ddwrt) needs to be accessible from external IP addresses so i can access it for VPN (pptp) because with the ddwrt firmware it is basically a linux box.  I also would like to just simply have the linksys be the main router, as opposed to the home hub, if at all possible. 

 

Is it possible to get some other DSL modem and use it instead of the home hub (provided I can obtain my BT login credentials for the other dsl modem)? 

 

thanks again for any suggestions

Expert
PheeragHfre
Posts: 806
Registered: ‎01-02-2010
0

Re: How to get a wireless router to work behind a BT Home Hub 2

[ Edited ]

 


jrinco11 wrote:

the problem is that my linksys (with ddwrt) needs to be accessible from external IP addresses so i can access it for VPN (pptp) because with the ddwrt firmware it is basically a linux box.  I also would like to just simply have the linksys be the main router, as opposed to the home hub, if at all possible. 

 

Is it possible to get some other DSL modem and use it instead of the home hub (provided I can obtain my BT login credentials for the other dsl modem)? 

 

thanks again for any suggestions


 

 

 

Perhaps something like this an ADSL modem to connect DSL routers directly to the BT Phone network?

http://www.netgear.co.uk/adsl_ethernet_modem_dm111p.php

"I have this awful feeling someone is watching every move I make (one of my pet hates is router location tagging)." Marvin (A paranoid Android)
Newbie
danieldickinson
Posts: 1
Registered: ‎03-01-2011
0

Re: How to get a wireless router to work behind a BT Home Hub 2

[ Edited ]

Had the same issue that a secondary router would not show up within the DMZ List on the Home Hub,

 

Not sure of cause (suspect something strange with how Hubs Routing Tables are build), but I changed my secondary router to use DHCP on the WAN Interface, once the secondary Hub was using DHCP. It was available within the DMZ List.

 

Applied config and works a treat

Beginner
Assassin8or75
Posts: 8
Registered: ‎09-03-2011
0

Re: How to get a wireless router to work behind a BT Home Hub 2

So have you connected another router to the homehub2 using ethernet and now use the bthomehub as a modem and the new router for all connections? If the router linked to the homehub has dd-wrt would i then be able to remote boot my pc over the internet using WOL?
Newbie
Rusta
Posts: 1
Registered: ‎18-06-2011
0

Re: How to get a wireless router to work behind a BT Home Hub 2

Did you manage to get this solution working? I'm facing similar frustrations with my HH and am looking for a workaround in order to get WOL working from external network
Expert
raymie67
Posts: 1,441
Registered: ‎24-11-2010
0

Re: How to get a wireless router to work behind a BT Home Hub 2

The way I did it with my routers is as follows

 

Main router 192.168.1.1 DHCP on

Second router (WAG354G) 192.168.1.3, DHCP relay mode

 

Never had a moments issue. I think some routers may refer to it as bridge mode rather than DHCP relay

---------------------------------------------------------------------------------------
If my post was helpful then please click on the Ratings star on the left-hand side If the the reply answers your question fully then please select ’Mark as Accepted Solution’