Reply
Contributor
ian01
Posts: 63
Registered: ‎26-04-2010
0
Accepted Solution

SMTP server not sending email

I have read a great deal about 'authentication' and appreciate the reasons for this but still have some questions.

 

Until this weekend my wife has used our BT Home Hub ISP to send and receive email via her two own domain accounts that are not BT accounts - I always use my BT account.

 

Suddenly she cannot send - smtp not recognised

 

I have 'verified' her domain accounts and added to my BT account

 

I do not understand why I should put my account details (username and password) on her outgoing email account details

 

Surely a fundamental principle of wifi connections should be that someone, a casual visitor to my house for example, should not have to change accoutn details - certainly not have access to my username and password details, in order to use my ISP?

 

Or am I missing something?

 

Thanks

 

Ian

Guru
Andy_N
Posts: 3,476
Registered: ‎31-01-2010

Re: SMTP server not sending email


ian01 wrote:

I have read a great deal about 'authentication' and appreciate the reasons for this but still have some questions.

 

Until this weekend my wife has used our BT Home Hub ISP to send and receive email via her two own domain accounts that are not BT accounts - I always use my BT account.

 

Suddenly she cannot send - smtp not recognised

 

I have 'verified' her domain accounts and added to my BT account

 

I do not understand why I should put my account details (username and password) on her outgoing email account details

 

Surely a fundamental principle of wifi connections should be that someone, a casual visitor to my house for example, should not have to change accoutn details - certainly not have access to my username and password details, in order to use my ISP?

 

Or am I missing something?

 

Thanks

 

Ian


Hi Ian.

 

You can set up a BTinternet sub account for your wife, and use those details for verification and then put them into any mail client program.

 

I'm somewhat suprised that she was able to send non BTinternet emails using the BT mail servers without address verification, since this was introduced over 3 years ago! (Though over this time, it has seemed to "catch up with people" ...)

 

Since you are responsible for your connection, any casual visitor needs to either have their own way of sending emails (e.g. via webmail) or they will need to alter their mail client details. This is pretty much the same for all ISPs. Most will not allow emails to be sent from other ISP mail servers. If they use 3rd party mail servers, then this is usually unaffected.

Contributor
ian01
Posts: 63
Registered: ‎26-04-2010
0

Re: SMTP server not sending email

Thank you that explanation is very clear. I agree, no idea why this has suddenly become a problem with BT smtp server after so long.

 

 

 

 

 

Aspiring Expert
G3NDI
Posts: 110
Registered: ‎26-10-2010
0

Re: SMTP server not sending email

Not sure if my situaton is helpful, Ian,  as I am using PegasusMail 4.51.   I have two ISP accounts, one is "xxxxx@btinternet.com" and the other is "xxxxx@12freeukisp.co.uk".    These both go through the BT server Yahoo account  with the POP3 and SMTP servers set as,
mail.btinternet.com
mail.btinternet.com

The other ISP is 12FreeUK and here I have
POP3 server setting as   "mail.12freeukisp.co.uk"
but then under General tab "Settings for Sending Mail" I have
Server Host name   "mail.btinternet.com" as above
but under Security tab,  "SMTP authentication" I have ticked the "Log in to the SMTP server" using the following details
Username   xxxxxx@btinternet.com and my normal Password for BT server.

I think when I first set this up I had to authenticate the e-mail address and then everything works, but you say you are familar with "authentication" -  there is certainly quite a lot the appears under a search using this keyword.

Regarding visitors with a BT internet address using your Home Hub for e-mail internet access,  then as far as I understand the PegasusMail set up, this can be done by inserting their User Name and Password for their BT Internet account.

 

Rodney Fry

 

 

Contributor
ian01
Posts: 63
Registered: ‎26-04-2010
0

Re: SMTP server not sending email

I set up a subaccount and verified two non-BT email accounts

 

I now get the following error cannot connect to mail.btinternet.com

 

The server response was: From address not verified - see http://www.btyahoo.com/verify



Mac OSX Mail client

 

Any further thoughts much appreciated

 

 

Guru
Andy_N
Posts: 3,476
Registered: ‎31-01-2010
0

Re: SMTP server not sending email


ian01 wrote:

I set up a subaccount and verified two non-BT email accounts

 

I now get the following error cannot connect to mail.btinternet.com

 

The server response was: From address not verified - see http://www.btyahoo.com/verify



Mac OSX Mail client

 

Any further thoughts much appreciated

 

 


Hi again.

 

In the mail client, you need to make sure that the smtp settings actually use the new btinternet sub account. Have a look here :-

http://www.its.qmul.ac.uk/mail/smtp/smtpset.html#appmail

 

The outgoing mail server is mail.btinternet.com, and in the SMTP server options you need to enter the btinternet email address/password.

 

(I hope that link is valid for your mail client(.

Contributor
ian01
Posts: 63
Registered: ‎26-04-2010
0

Re: SMTP server not sending email

I have set a new BT internet account as you suggest and authenticated the two non-BT email addresses that I would like to send from.

 

When I attempt to send the BT smtp server is rejected.

 

I have also set up a Gmail account, which is a suggested workaround on another discussion thread here. That will work, but of course the reply to address is not correct.

 

In one of your responses you make the point that BT smtp rejecting unknown email addresses is an attempt to stop a spam problem. I understand that, but when I rent a flat abroad or visit a hotel or coffee shop I simply use the code supplied to access their wifi network and send email using my standard smtp settings. Reply to addresses remain as set.

 

Thanks