cancel
Showing results for 
Search instead for 
Did you mean: 
NRobinson
Newbie
480 Views
Message 1 of 3

New Build Property - cannot get broadband for over a month as BT Openreach refuse to add my address

I have been trying to get a basic broadband package (copper if nothing else!!) for over a month now but am unable to do so as BT Openreach are refusing to add my new build address to their database so that I can place an order, despite the work being finished at the site over a month ago. I have been unable to work from home as I normally would be able to.

I have tried to contact BT Openreach about my new address but their response (below) has been copied and pasted repeatedly (I have no idea what any of this means and it gives me no assurances that BT is actually going to sort it out - no internet provider will allow me to order until my address is updated on the ADSL checker that they use from BT).

Please help.

RESPONSE FROM BT: "I'm emailing in reply to your recent enquiry about an order at a New Housing Development. I've checked the address and we can't find an order for that property. This Team is only able to monitor and update on the progress of live orders within our system. If you think that you have placed an order, it may have been cancelled in error, so you need to contact your Service Provider to discuss.

If your Service Provider tells you they're unable to place an order (usually because they can't match the address), then you need to ask them if they can use the ‘Bronze Address Matching process' to place an order. An address has to be ‘Gold Matched' before an order can be placed by a Service Provider using the standard process. If an address is only at ‘Silver Matched' stage, this means that it doesn't have a surveyed network routing on our systems and that infrastructure is still ongoing to provide network capacity to the development site. The Bronze Address Matching Process allows an order to be forced through to Openreach for an address that can't be located. It is up to Service Providers if they choose to use the ‘Bronze' process or not, if their systems allow and forcing an order through doesn't particularly speed up the provision of a live connection as infrastructure work has to be completed first, but it does mean that your order would be picked up earlier for an installation appointment once all work to service the site is complete.

So, you can either ask your Service Provider if they can use the ‘Bronze Address Matching Process' or ask them to let you know when they are able to use the standard process. Once you've an order in place, if you need to contact us about it at all, then you'll need to re-submit the enquiry form. We'll keep your Service Provider up to date re the progress of any orders placed."

0 Ratings
Reply
2 REPLIES 2
Distinguished Sage
Distinguished Sage
473 Views
Message 2 of 3

Re: New Build Property - cannot get broadband for over a month as BT Openreach refuse to add my addr

Is you address correct on Royal Mail database?

have you placing an order with bt for phone line and initially adsl broadband?  Or you intending on using a different ISP?



If you like a post, or want to say thanks for a helpful answer, please click on the Ratings 'Thumbs up' on left hand side.
If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.
0 Ratings
Reply
iniltous
Recognised Expert
414 Views
Message 3 of 3

Re: New Build Property - cannot get broadband for over a month as BT Openreach refuse to add my addr

It's odd that you refer to Openreach as BT Openreach, is that to justify posting on a BT Consumer forum ?

Is it BT that you want to use at this address, or do you (mistakingly) believe that it's BT's responsibility to update OR , so you can order from someone else ?...if your intention is to use someone else , then that company has exactly the same 'equivalent' access to get the records updated, the email you post suggests you haven't raised an order with BT, if that's the issue ( you want to order from BT but the address issue is stopping you) , have you tried calling them , or just tried to order from BT on line ?

0 Ratings
Reply