Showing results for 
Search instead for 
Did you mean: 
Message 1 of 2

Apple TV 2nd Generation - wont connect to Itunes on Windows 7 Computer, with BT Home Hub 2

So have been searching around all over the Interweb and cant put my finger on an answer.


Apple TV is up to date and so is Itunes. Connecting via wireless.


Apple TV connects to internet fine, and also allows airplay via Ipad. It is reporting the correct router address so I am assuming it is all on the same network and happy that way.


I can see the Apple TV device in Home hub manager.


In Apple TV and Itunes I have turned on Home Sharing. (In fact tried turning off and on a number of times)


Initially I can see in Apple TV the Library I am trying to connect to. So you select and it goes away for a while and comes back with "Cannot connect to Neils Library"...


So I searched around and looked at ports that you maybe should open on the computer to allow other devices to search for Itunes - TCP 3689 and UDP 5353. So I created a new Application Sharing entry in the home hub, and assigned that to my PC only. (maybe I havent done that correctly? Followed a guide on a port forwarding website)


Weirdly then - when I go back to my Apple TV and look at "computers" on the menu, it can no longer see my Itunes library. Before it could see the library, but errored when trying to connect to it. 


Have also tried turning the firewall off.


So I am a bit stuck. Any suggestions or past experience would be gratefully received.


Thank you!



0 Ratings
Message 2 of 2

Re: Apple TV 2nd Generation - wont connect to Itunes on Windows 7 Computer, with BT Home Hub 2

OK - I managed to fix this. Will document for others.


I started to think it was a firewall thing. So I turned off both my Windows 7 firewall and my BT Home hub firewall. It started working!


So turned back on the BT home hub firewall - still working. So it must be a windows 7 firewall. 


Went in and checked that Itunes was there as an exception... Yep. So why still not working. 


Found out that the entry in my Windows 7 firewall said I-Tunes - but when you looked at the details button it wasnt pointing to a program - it was just blank. 


So added a new entry and pointed that at the I-Tunes exe file.


Now all working...




0 Ratings