cancel
Showing results for 
Search instead for 
Did you mean: 
momo313
Beginner
8,169 Views
Message 1 of 9

BT Access Control Enabled, But Not Working

BT Access Control has been enabled in the BT Home Hub settings but it doesn't work. 

 

I've assigned the computer (let's call it, A) correctly to numerous block-times in the router settings page, but it still doesn't block internet access to computer A. I've also reset the router and it still doesn't work. 

 

My BT Home Hub router version is: 

 

Software version 8.1.H.J (Type A)

 

 

Does anyone know what is up with this? 

0 Ratings
8 REPLIES 8
walkerx
Recognised Expert
8,150 Views
Message 2 of 9

Re: BT Access Control Enabled, But Not Working

make sure you use a static ip on the pc in question and not dhcp - i've set this up for one off my computers so it has no access after 8pm and it works fine

0 Ratings
momo313
Beginner
8,147 Views
Message 3 of 9

Re: BT Access Control Enabled, But Not Working

How do I make it so Computer A (has a wireless connection to router) uses a static ip and not dhcp? 

 

I'm pretty sure Computer A uses dhcp, on numourous occasions when troubleshooting internet connection problems I get the suggestion to "Reset the DHCP device", doing so always restores/repairs my internet connection. 

0 Ratings
walkerx
Recognised Expert
8,128 Views
Message 4 of 9

Re: BT Access Control Enabled, But Not Working

right-click the connection on pc, choose properties, select tcip/ip and change settings

 

but it depends if you yse a program supplied by the card manufacturer or windows networking

0 Ratings
momo313
Beginner
8,122 Views
Message 5 of 9

Re: BT Access Control Enabled, But Not Working

Thanks.

But access control is still not working. Here's what I've done:

Like you've suggested, I changed the TCP/IPv4 settings of the wireless connection ("Use the following IP address") to the corresponding fields in the command prompt using the "ipconfig /all" command.

I followed the instructions here:

http://netsecurity.about.com/od/quicktip1/qt/qtwifistaticip.htm

I have also disabled the dhcp server in the bt home hub settings (Advanced Settings > Home Network > IP Addresses).

Yet, under: Advanced Settings > Home Network > Devices > Computer A, it still shows as "DHCP" in the "IP address assignment" field.

0 Ratings
Distinguished Guru
8,111 Views
Message 6 of 9

Re: BT Access Control Enabled, But Not Working

From the Advanced menu go to Home Network and look for Computer A and click on it.

 

From there you will see "Always use this IP address". Is the blue circle shown in "no"?

 

If so change it to yes, click apply and that should sort fixing the IP address.

-+-No longer a forum member-+-
0 Ratings
momo313
Beginner
8,091 Views
Message 7 of 9

Re: BT Access Control Enabled, But Not Working

The "Always use this IP address" is set to "Yes" and always has been.
0 Ratings
Lloydy
Beginner
7,072 Views
Message 8 of 9

Re: BT Access Control Enabled, But Not Working

Has anyone fixed this issue ?  I am experiencing exactly the same issue.   To clarify:

 

- Homehub Software version 4.7.5.1.83.2.11 (Type B)

- Devices have fixed IP addresses  (yes - i've tried various devices)

- BT Access control is enabled

- Router has been reset

 

I am at a loss.  I'm an experienced IT professional, and as far as i can see, the 'BT Access Control' is not working.

 

Has anyone else experienced/fixed this ?

 

 

 

 

0 Ratings
simon_e
Newbie
6,922 Views
Message 9 of 9

Re: BT Access Control Enabled, But Not Working

For me - access control disables internet access at 2300 as configured, but although it's set to come back on at 0700 my daughter complains that she can't do homework in the mornings as it doesn't come back on. It's OK by the time she gets home from school.

The router time is correct
0 Ratings