cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Aspiring Contributor
695 Views
Message 21 of 44

Re: BT Fon connection on Ubuntu

The wireless adapter configuration in Ubuntu works fine if I connect to my own router wirelessly using the WEP security password. Any other connections that are listed call up the WEP password if I try to connect through them.

 

Bt the BTWiFi-with-Fon connection, which does not require WEP or WPA, makes a connection but my browser says there is no connection. I have tried a second browser but with the same result.

 

The problem is exclusive to the BTWiFi-with-Fon connection, and only in Ubuntu. My computer is dual-boot, and in Windows the BTWiFi-with-Fon connection is fine. Also my wired connection is fine in both Windows and Ubuntu. Only the BTWiFi-with-Fon connection is effected, and only in Ubuntu 12.4.

 

The reason I want to get the BTWiFi-with-Fon connection working is to have a fallback if my phone line goes down and my router has no connection.

 

I might also mention that if i use the BTWiFi-with-Fon connection in Windows and open Ubuntu in VirtualBox it also is connected, but obvioulsy through the Windows connection.

 

I remain puzzled that you are the only person using Ubuntu who can connect to BTWiFi-with-Fon. There must be some difference in your in-built wireless that can do this.

0 Ratings
Distinguished Sage
Distinguished Sage
694 Views
Message 22 of 44

Re: BT Fon connection on Ubuntu

Hmm, just had a look at your post on the Ubuntu forum. The connection should definitely NOT be Ad Hoc it should be Infrastructure. Have you manually edited the network configuration?  I would suggest you delete all wireless entries in 'Edit Connections' and then select BT Fon from the available networks. There is no need to edit anything or do any more. If you then run nm-tool in a terminal you should hopefully see Infra and Gateway and DNS addresses for the selected network. If you do, open a browser and hopefully you will be able to connect.

0 Ratings
Aspiring Contributor
686 Views
Message 23 of 44

Re: BT Fon connection on Ubuntu

I am glad you took a look at the Ubuntu forum. I did not change any settings suggested in that discussion because it is only the BTWiFi-with-Fon connection that does not work properly. The other wirless connetions do work properly so long as I have the WEP key for them, which I have for my own router, which conncts wirelessly fine.

 

However, you will see that the readings from terminal are different between my own router wireless connection and the BTWiFi-with-Fon connection. That is what is strange.

0 Ratings
Distinguished Sage
Distinguished Sage
685 Views
Message 24 of 44

Re: BT Fon connection on Ubuntu

On the page I am looking at, there only appears to be the BT Fon network not your own router. I would still try as I described above. Its odd that it is WLAN1 and not WLAN0 Did you manually add the network?

0 Ratings
Recognised Expert
670 Views
Message 25 of 44

Re: BT Fon connection on Ubuntu


@joseph1945 wrote:

 

On the Ubuntu forum I am told it is not possible to connect to BT Fon in Ubunto because a piece of software is needed which is available only in Windows for the BT Fon wireless connection.


That's incorrect, I'm afraid. 

 

I regularly use BT Fon on my Ubuntu netbook, and I don't recall doing anything in particular to make it happen.

0 Ratings
Aspiring Contributor
655 Views
Message 26 of 44

Re: BT Fon connection on Ubuntu

Glad you have it working on Ubuntu. I wonder if you can tell us what wifi hardware you are using? This may be the difference since both of you are using Netbooks.

0 Ratings
Distinguished Sage
Distinguished Sage
652 Views
Message 27 of 44

Re: BT Fon connection on Ubuntu

Did you try my suggestion of deleting all the connections and re-selecting?

0 Ratings
Aspiring Contributor
651 Views
Message 28 of 44

Re: BT Fon connection on Ubuntu

You say there is only one connected details on the Ubunto forum, but I sent two. The first is for the Fon connection and the second is for my normal router wireless connection. The readings are different.

 

I have not made any changes to any setting in Ubuntu. Ubuntu simply picks up any wireless connections nearby and lets me look at the list to choose which to connect to. All I do is sellect one and let it automatically connect.

 

I will look at your suggested setting and see what happens.

 

 

0 Ratings
Distinguished Sage
Distinguished Sage
648 Views
Message 29 of 44

Re: BT Fon connection on Ubuntu

There are 2 seperate posts but both show the BT Fon connection only.

 

 Wireless Access Points (* = current AP)  
     *BT Fon:         Ad-Hoc, DE:FF:53:F7:C3:9F, Freq 2412 MHz, Rate 0 Mb/s, Strength 100  

 

This is what the 3 connections I can see on my netbook currently look like.

 

Edimax AP:       Infra, 80:1F:02:6A:D5:10, Freq 2412 MHz, Rate 54 Mb/s, Strength 22 WPA2

*billion:        Infra, 00:04:ED:E0:A1:26, Freq 2412MHz, Rate 54 Mb/s, Strength 61 WPA2

TALKTALK-B98914: Infra, 84:C9:B2:B9:89:14, Freq 2412 MHz, Rate 54 Mb/s, Strength 0 WPA WPA2

 

The starred connection is the connected network, the edimax is my wireless extender and the TALKTALK my neighbours wireless

0 Ratings
Aspiring Contributor
632 Views
Message 30 of 44

Re: BT Fon connection on Ubuntu

Here is my connections at the present moment after deleting all from Edit Connections. At the moment there is no BT Fon in range, just my own and a neighours Sky connection:

~~~~~~~~~~~~~~~~~


@licquorice wrote:

There are 2 seperate posts but both show the BT Fon connection only.

 

 Wireless Access Points (* = current AP)  
     *BT Fon:         Ad-Hoc, DE:FF:53:F7:C3:9F, Freq 2412 MHz, Rate 0 Mb/s, Strength 100  

 

This is what the 3 connections I can see on my netbook currently look like.

 

Edimax AP:       Infra, 80:1F:02:6A:D5:10, Freq 2412 MHz, Rate 54 Mb/s, Strength 22 WPA2

*billion:        Infra, 00:04:ED:E0:A1:26, Freq 2412MHz, Rate 54 Mb/s, Strength 61 WPA2

TALKTALK-B98914: Infra, 84:C9:B2:B9:89:14, Freq 2412 MHz, Rate 54 Mb/s, Strength 0 WPA WPA2

 

The starred connection is the connected network, the edimax is my wireless extender and the TALKTALK my neighbours wireless


joseph@joseph-System-Product-Name:~$ nm-tool
 
NetworkManager Tool
 
State: connected (global)
 
- Device: wlan1  [ap00300A5C121D] ----------------------------------------------
  Type:              802.11 WiFi
  Driver:            rtl8192cu
  State:             connected
  Default:           yes
  HW Address:        64:66:B3:0A:49:6D
 
  Capabilities:
    Speed:           1 Mb/s
 
  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes
 
  Wireless Access Points (* = current AP)
    SKY8B39D:        Infra, 7C:4C:A5:9D:C8:61, Freq 2412 MHz, Rate 54 Mb/s, Strength 62 WPA2
    *ap00300A5C121D: Infra, 00:22:3F:5C:38:28, Freq 2462 MHz, Rate 54 Mb/s, Strength 76 WEP
 
  IPv4 Settings:
    Address:         192.168.0.4
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.0.1
 
    DNS:             192.168.0.1
 
 
- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            forcedeth
  State:             unavailable
  Default:           no
  HW Address:        48:5B:39:BA:7C:22
 
  Capabilities:
    Carrier Detect:  yes
 
  Wired Properties
    Carrier:         off
 
 
joseph@joseph-System-Product-Name:~$ sudo lshw -C network
[sudo] password for joseph: 
  *-network               
       description: Wireless interface
       physical id: 1
       bus info: usb@1:5
       logical name: wlan1
       serial: 64:66:b3:0a:49:6d
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rtl8192cu driverversion=3.2.0-58-generic-pae firmware=N/A ip=192.168.0.4 link=yes multicast=yes wireless=IEEE 802.11bgn
joseph@joseph-System-Product-Name:~$ 


0 Ratings