Showing results for 
Search instead for 
Did you mean: 
Message 221 of 233

Re: BT HomeHub firmware upgrade broken network connectivity Ubuntu

People Power !!


Thanks Kerry

An MSCE in computing is like having a McDonalds Certification in World Cuisine, pointless.
0 Ratings
Message 222 of 233

Re: BT HomeHub firmware upgrade broken network connectivity Ubuntu

hi Kerry,


thanks link to check the firmware version. Also thanks for the update about the rollout.


best regards


0 Ratings
Message 223 of 233

Re: BT HomeHub firmware upgrade broken network connectivity Ubuntu

Is it too early to be talking about compensation?


Seriously, had I not had my HH2 switched to a HH3 free of charge, I'd have been looking for compensation by now.


BT - Will there be any compensation offered to customers that had this issue?

0 Ratings
Message 224 of 233

Re: BT HomeHub firmware upgrade broken network connectivity Ubuntu

I am also having exactly this issue with my Android tablet, however for me the issue occurs with a Home Hub 3. It used to work absolutely fine and then one day it just went into a constant scanning - connecting - scanning loop and never connects. I have tried some of the various suggestions made previously such as doing a reset on the HH3 etc and although i can get a connection for a short time, on the next reboot of the client device the issue is back.


Could you tell me if there will be a firmware update to rectify the issue on this version of the Home Hub?





0 Ratings
Message 225 of 233

RE: BT HomeHub firmware upgrade broken network connectivity Ubuntu

I'm afraid I far from have the solution. However, I can safely say that the issue is caused by the hub firmware and an incompatibility with the IPv4 DHCP. A new method seems to be implemented within the homehub automatic DHCP which Ubuntu (and it seems some other distro's) do not like much.


I don't know why this is or how to fix it, however I have managed to successfully connect my Ubuntu laptop to the home hub and repeatedly reboot to confirm working.


What you need to do is manually configure a static IP address for the IPv4 connection. I cover briefly below how to do that


Method (This is for Ubuntu 11.10 but should be almost identical on other Ubuntu versions):


1. Attempt to connect to your Homehub connection, this will fail but don't worry.

2. Click the wi-fi symbol and select "Edit Connections..."

3. Click on the "Wireless" tab.

4. Select your Homehub connection from the list and click edit. (Alternatively double click on the connection)

5. Select the "IPv4 Settings" tab.

6. For "Method", Select "Manual" from the drop down box.

7. In the "Addresses" Box, for "Address" enter "192.168.1.xx" Where xx is a number from 64-237. Ideally pick something in the middle to avoid IP address conflicts with other devices. I chose to use 100.

8. For "Netmask" enter 9. For "Gateway" enter "" which should be the IP address on your network of your homehub. (It definitely is for HH2)

10. In the "DNS servers" box enter "" which is again your HH IP.

11. I then deselected "Require IPv4 addressing for... complete".

12. Leave IPv6 on "Automatic" as this does not seem to cause issues for connection.

13. Save the settings and then click the wi-fi icon and try and reconnect to the HH network.


This should now work perfectly for you. Let me know how it's gone for you guys,



p.s, you call yourself a tech company ,BT, but not knowing to suggest manual DHCP is a bit ridiculous, and using "we're not trained to support that" as a guise... I've probably known more about computers than your tech support guys since I was 10..

0 Ratings
Message 226 of 233

Re: Fix, Android

Also guys, this will work for all Android devices, phones, tablets. I haven't however encountered any issues running Gingerbread 2.3.4/5 so this may be an issue restricted to Honeycomb tablets. If you need help then I'm sure I can lend a hand, just let me know.



0 Ratings
Message 227 of 233

Re: BT HomeHub firmware upgrade broken network connectivity Ubuntu

Just checked the home hub and found a firmware update had been applied on 10/9/11.

Tried the old Ubuntu 10.10 Laptop  –  now connecting correctly again.

Thanks BT .....  But it’s taken far too long to correct this problem which was first reported in April.

Maybe you now need to look into an update for your customer care policies, let’s hope that doesn’t take as long.

0 Ratings
Message 228 of 233

Re: RE: BT HomeHub firmware upgrade broken network connectivity Ubuntu

tried this workaround but it didn't work for me - for some reason the save button was disabled 😞 I much prefer Ubuntu over Windows - but don't fancy using BT Fon as I don't feel as secure using it

0 Ratings
Message 229 of 233

Re: BT HomeHub firmware upgrade broken network connectivity Ubuntu

I started having major problems with an Android tablet (Sony) going into the connecting/disconnecting loop with a BT Homehub 3 a few days after I bought the device last minth (hub was installed in April).  I also had the same problem, but much less so, with an SE Xperia Arc S phone and almost never with an HTC Wildfire.  I also had problems with the hub losing connections to two NASs (both Buffalo) connected by ethernet, and to my wireless Sony TV (when used as a renderer).  Only switching the hub on and off fixed the problems; sometimes for a few minutes, sometimes for a few hours.  After reading many posts and trying many fixes unsuccessfully, I re-connected my 5 year old Netgear router and this worked fine for 24 hours (but slow and missing some required features).  As I was not expecting much support from BT after reading the comments, I bought a new Netgear router (faster and dual band) and this has now been stable for 24 hours.  A costly solution, but will save me hours of effort and the BT broadband connection itself is good.

You can draw your own conclusions about the casue of the problem.

And if BT want to replicate the problem, give me a call and they can come round to my house, I'll put the BT hub back on!

0 Ratings
Aspiring Contributor
Message 230 of 233

Re: RE: BT HomeHub firmware upgrade broken network connectivity Ubuntu



I have the same problem with my SAVE button being disabled - did you ever get round this problem?


BTW - even though I worked in the software industry for 25 years, technology is now getting away from me.

All this talk about Ipv4 and IPv6 and DHCP and static IP addresses is beginning to confuse this old fuddy-duddy.

And how do I find out what versions of firmware are in my Router and my HH3?


Been a very interesting series of posts in this subject stream and I too am *very* surprised that BT do not cater for any linux variant - I would have said that there are more Linux machines out there than Mac ones.


0 Ratings