cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
runner_bean
Contributor
482 Views
Message 1 of 2

BT SmartTalk problem

I have previously installed BT SmartTalk on my HTC Desire S and set up the account and my recollection is that it used to work.  But now it doesn't (with no changes I am aware of) with the following symptoms:

 

1.  The handset symbol does not change to unbarred.

2.  If I try to make a call I get a dialogue suggesting I redial or test the connection.

3.  If I redial as suggested the called number rings but there is no ringing tone for me and the caller can neither hear me or me him/her.

4.  If instead I try the connection test it runs for ever and never terminates.

 

I have tried a variety of WiFi connections with no difference, and also uninstalled and reinstalled the app with no change.  My wife's identical phone tied to the same number and account works perfectly.

 

It feels like a BT problem but I don't know how to progress it.  Any help much appreciated!

0 Ratings
1 REPLY 1
runner_bean
Contributor
476 Views
Message 2 of 2

Re: BT SmartTalk problem solved?

Update on the above.  Quite by chance I had an old version of the BT SmartTalk app available to me (1.23.6-HA) and I tried installing this after uninstalling the latest version 2.46.4-ST which I had been using.  It works!!  So the problem seems to be that the latest app version is incompatible with my HTC Desire which uses the 4.0.4 version of Android.  This should not happen as the Google Play Store should not offer incompatible updates.  I presume this is a BT or Google oversight.

 

The reason the app worked and then didn't is now explained by my having made an upgrade of the app in good faith

but not tested it.  Are old versions of the app available somewhere? The 1.23.6-HA version really is antique!  Otherwise I shall have to try and get a copy of my wife's version to get reasonably current.

0 Ratings