cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
AliCharles
Beginner
9,114 Views
Message 11 of 31

Re: BT infinity with a Cisco router

Go to solution

Hi,  I know this is old but I have some (possibly similar) issues that I have for the life of me been unable to resolve after a good week of reading and testing.

 

I have the following config and once connected directly to (no modem/homehub) BT infinity VDSL I get the external BT WAN IP adddress given to me. But no internet connection. I can not ping the DNS servers or any internet address while on the router console.

 

Cisco 887VA - c880data-universalk9-mz.154-3.M.bin

 

Any help would be very greatly appreciated. Many Thanks in advance. AC

 

i
ip cef
no ipv6 cef
!
username *-* privilege 15 password 0 *-*
!
controller VDSL 0
no cdp run
!
interface Ethernet0
no ip address
ip virtual-reassembly in
no ip route-cache
!
interface Ethernet0.101
description Tagging for PPPoE (VDSL 0)
encapsulation dot1Q 101
ip nat outside
ip virtual-reassembly in
no ip route-cache
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
!
interface FastEthernet0
no ip address

shutdown
no cdp enable
!
interface FastEthernet1
no ip address
shutdown
no cdp enable
!
interface FastEthernet2
no ip address
shutdown
no cdp enable
!
interface FastEthernet3
no ip address
no cdp enable
!
interface Vlan1
ip address 10.80.2.252 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip nat inside
ip virtual-reassembly in
ip route-cache policy
!
interface Dialer1
description **BT INFINITY**
ip address negotiated
ip access-group 101 in
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1492
ip nbar protocol-discovery
ip flow ingress
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
ppp authentication pap chap ms-chap callin
ppp chap hostname *-*
ppp chap password 0 password
ppp ipcp dns request accept
ppp ipcp route default
ppp ipcp address accept
no cdp enable
!
ip forward-protocol nd
no ip http server
no ip http authentication local
no ip http secure-server
!
ip nat inside source list 1 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
dialer-list 1 protocol ip permit
!
access-list 1 permit any
!
control-plane
!
line con 0
no modem enable
line aux 0
line vty 0 4
privilege level 15
password *-*
login local
transport input telnet ssh
!
end

0 Ratings
licquorice
Distinguished Sage
Distinguished Sage
9,112 Views
Message 12 of 31

Re: BT infinity with a Cisco router

Go to solution

Couple of things, CHAP username should be anything@btbroadband.com, VLAN id should be 101

Edit: Set PPP authentication to CHAP rather than auto

0 Ratings
AliCharles
Beginner
9,100 Views
Message 13 of 31

Re: BT infinity with a Cisco router

Go to solution
Thanks for the reply
chap hostname was set to bthomehub@btinternet.com for some reason I blanked it out in the post
Where are you looking for point two isn't this already set to chap here?
ppp authentication pap chap ms-chap callin
0 Ratings
licquorice
Distinguished Sage
Distinguished Sage
9,098 Views
Message 14 of 31

Re: BT infinity with a Cisco router

Go to solution

'ppp authentication pap chap ms-chap callin'

 

Just seems to imply an auto setting rather than specifically CHAP to me.

 

Did you set VLAN to 101?

 

Edit: bthomehub@btinternet.com should be  bthomehub@btbroadband.com

0 Ratings
AliCharles
Beginner
9,021 Views
Message 15 of 31

Re: BT infinity with a Cisco router

Go to solution

Thanks licquorice, very helpful 

 

Vlan set to 101 and that bleedin BTinternet updated to btbroadband and away we go.

0 Ratings
licquorice
Distinguished Sage
Distinguished Sage
9,019 Views
Message 16 of 31

Re: BT infinity with a Cisco router

Go to solution

Result!

0 Ratings
pippincp
Sage
8,985 Views
Message 17 of 31

Re: BT infinity with a Cisco router

Go to solution

@AliCharles wrote:

Thanks licquorice, very helpful 

 

Vlan set to 101 and that bleedin BTinternet updated to btbroadband and away we go.


It would be useful to mrk the thread as solved.

0 Ratings
ray_dorset
Distinguished Guru
8,974 Views
Message 18 of 31

Re: BT infinity with a Cisco router

Go to solution
Only the OP can do that
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _
If you found this post helpful, please click on the star on the left
If not, I'll try again 🙂
0 Ratings
imjolly
Distinguished Sage
Distinguished Sage
8,967 Views
Message 19 of 31

Re: BT infinity with a Cisco router

Go to solution

Originator wAs last signed in 2/2012



If you like a post, or want to say thanks for a helpful answer, please click on the Ratings 'Thumbs up' on left hand side.
If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.
0 Ratings
pippincp
Sage
8,961 Views
Message 20 of 31

Re: BT infinity with a Cisco router

Go to solution

Of course. I forgot about that.

0 Ratings