cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Nailzy
Aspiring Contributor
4,972 Views
Message 21 of 31

Re: BT infinity with a Cisco router

Go to solution

Where exactly does the vlan change to 101 happen because I can see 101 all over the config?

 

I've tried that config and I can't get my 887va working to the point where it's about ready to go for a swim.

0 Ratings
Supplanter
Aspiring Contributor
4,945 Views
Message 22 of 31

Re: BT infinity with a Cisco router

Go to solution
Here is where it takes place mate, it's a virtual interface.. You create a sub interface off this and enable encapsulation on the sub interface.. That then tags all outgoing frames in VLAN101

interface Ethernet0
no ip address
ip virtual-reassembly in
no ip route-cache
!
interface Ethernet0.101
description Tagging for PPPoE (VDSL 0)
encapsulation dot1Q 101
ip nat outside
ip virtual-reassembly in
no ip route-cache
pppoe enable group global
pppoe-client dial-pool-number 1
0 Ratings
Supplanter
Aspiring Contributor
4,942 Views
Message 23 of 31

Re: BT infinity with a Cisco router

Go to solution
Sorry put your ip nat outside on your dialer not on the et0.101 interface 🙂
0 Ratings
AliCharles
Beginner
4,877 Views
Message 24 of 31

Re: BT infinity with a Cisco router

Go to solution

Sorry to slightly hijack this particular threat again but the advice and participants here are excellent.

I have posted my working config for a cisco cinnected to BT Infinity for reference

I have the following config with BT Infinity connected to a cisco 887va. All connectivity on 10.80.2.0 network is fine going out to the BT network

My 2 questions are should the Gateway of last resort is be as such

217.32.145.4 to network 0.0.0.0

which is an IP address in the BT network is that correct?

And also any connected clients on 172.16.0.0 have no internet access (I will understand if you direct this question the cisco routing forums but any help here greatly appreciated. Also I can not ping or access anything from 172.16.1.1 from 10.80.0.0 network or vice versa

Thanks in advance - A networking leaner.

Ali


wowsville-cisco#sh ip route

Gateway of last resort is 217.32.145.4 to network 0.0.0.0

S* 0.0.0.0/0 is directly connected
is directly connected, Dialer1
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.80.2.0/24 is directly connected, Vlan101
L 10.80.2.252/32 is directly connected, Vlan101
86.0.0.0/32 is subnetted, 1 subnets
C 86.***.***.* is directly connected, Dialer1
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.1.0/24 is directly connected, Vlan102
L 172.16.1.1/32 is directly connected, Vlan102
217.32.145.0/32 is subnetted, 1 subnets
C 217.32.145.4 is directly connected, Dialer1


ip dhcp pool 0
import all
network 10.80.2.0 255.255.255.0
default-router 10.80.2.252
dns-server 194.72.0.98 62.6.40.178

!
!
!
ip domain name
ip name-server 194.72.0.98
ip name-server 62.6.40.178
ip name-server 10.80.2.252
ip cef
no ipv6 cef


controller VDSL 0
no cdp run

interface Ethernet0
no ip address
ip virtual-reassembly in
no ip route-cache
!
interface Ethernet0.101
description Tagging for PPPoE (VDSL 0)
encapsulation dot1Q 101
ip virtual-reassembly in
no ip route-cache
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
!
interface FastEthernet0
no ip address
shutdown
no cdp enable
!
interface FastEthernet1
no ip address
shutdown
no cdp enable
!
interface FastEthernet2
switchport access vlan 102
no ip address
no cdp enable
!
interface FastEthernet3
switchport access vlan 101
no ip address
no cdp enable
!
interface Vlan1
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
shutdown
!
interface Vlan101
ip address 10.80.2.252 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip nat inside
ip virtual-reassembly in
ip route-cache policy
!
interface Vlan102
ip address 172.16.1.1 255.255.255.0
ip access-group 102 in
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip nat inside
ip virtual-reassembly in
ip route-cache policy
!
interface Dialer1
description **BT INFINITY**
ip address negotiated
ip access-group 101 in
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1492
ip nbar protocol-discovery
ip flow ingress
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
ppp authentication pap chap ms-chap callin
ppp chap hostname bthomehub@btbroadband.com
ppp chap password 0 password
ppp ipcp dns request accept
ppp ipcp route default
ppp ipcp address accept
no cdp enable
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list 1 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
dialer-list 1 protocol ip permit
!
access-list 1 permit any
access-list 101 permit icmp any any net-unreachable
access-list 101 permit icmp any any host-unreachable
access-list 101 permit icmp any any port-unreachable
access-list 101 permit icmp any any packet-too-big
access-list 101 permit icmp any any administratively-prohibited
access-list 101 permit icmp any any source-quench
access-list 101 permit icmp any any ttl-exceeded
access-list 101 permit icmp any any echo-reply
access-list 101 deny icmp any any
access-list 101 permit tcp any any established
access-list 101 permit udp any any
access-list 101 permit tcp any any eq SSH
access-list 101 permit tcp any eq SSH any eq SSH
access-list 101 permit tcp any any eq SSLVPN
access-list 101 permit tcp any eq SSLVPN any eq SSLVPN
access-list 101 permit tcp any eq 1723 any eq 1723
access-list 101 permit udp any eq 1723 any eq 1723
access-list 101 permit gre any any
access-list 101 permit tcp any eq 10000 any eq 10000
access-list 101 permit udp any eq isakmp any eq isakmp
access-list 101 permit udp any eq non500-isakmp any eq non500-isakmp
access-list 102 permit ip any any

0 Ratings
Supplanter
Aspiring Contributor
4,802 Views
Message 25 of 31

Re: BT infinity with a Cisco router

Go to solution
Ok, I've looked at this with tired eyes so forgive me 😃 hopefully I can help if you haven't fixed. Gateway of last resort is fine. Basically next hop in the network.. So, if I don't know how to get to a network because I don't know about it... Then send it here. Know networks are shown in the routing table.

Next issue, are you using static IP address for your 172 network? Are you trying to ping via hostname or IP? You have no dhcp server or DNS server setup for network 172. So... When you plug in to Fa2 are you getting a 169 address?
0 Ratings
Supplanter
Aspiring Contributor
4,800 Views
Message 26 of 31

Re: BT infinity with a Cisco router

Go to solution
So:

ip dhcp pool vlan_102
network 172.16.1.0 255.255.255.0
default-router 172.16.1.1
dns-server 172.16.1.1
!
ip name-server 172.16.1.1
!
end

This will give you local DNS basic functions.. You will need to setup DNS forwarding for name lookups outside your domain.

Hope that helps.
0 Ratings
mike887
Beginner
4,757 Views
Message 27 of 31

Re: BT infinity with a Cisco router

Go to solution

Hi i have followed the instruction however it doesn't seem to work for me. I'm a bit new to this. 

 

Current configuration : 2323 bytes
!
! Last configuration change at 05:34:52 UTC Wed Mar 4 2015
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
memory-size iomem 10
!
!
!
!
!
ip dhcp excluded-address 192.168.1.1 192.168.1.10
!
ip dhcp pool lan
network 192.168.1.0 255.255.255.0
dns-server 4.2.2.2 4.2.2.3 8.8.8.8
default-router 192.168.1.1
!
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
!
license udi pid CI**** sn FC*****
!
!
!
!
!
!
!
controller VDSL 0
!
!
!
!
!
!
!
!
!
!
interface Ethernet0
description BT_INFINITY_VDSL0
no ip address
no ip route-cache
shutdown
!
interface Ethernet0.101
description 802.1Q_TAGGING_FOR_PPPOE_VDSL0
encapsulation dot1Q 101
ip nat outside
ip virtual-reassembly in
no ip route-cache
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
!
interface FastEthernet0
switchport access vlan 101
no ip address
no cdp enable
!
interface FastEthernet1
no ip address
shutdown
no cdp enable
!
interface FastEthernet2
no ip address
shutdown
no cdp enable
!
interface FastEthernet3
no ip address
shutdown
no cdp enable
!
interface Vlan1
no ip address
!
interface Vlan101
description FA_0_0
ip address 192.168.1.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip nat inside
ip virtual-reassembly in
ip route-cache policy
!
interface Dialer1
description 020*****
mtu 1492
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip nbar protocol-discovery
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer idle-timeout 0
dialer-group 1
keepalive 30
ppp authentication chap
ppp chap hostname firstname.lastname@btbroadband.com
ppp chap password 0 *bt-password* (i have also tried it without any username and password and just username(bthub@btbroadband.com) and no password)
no cdp enable
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip nat inside source list 1 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 1 permit any
dialer-list 1 protocol ip permit
no cdp run
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
no modem enable
line aux 0
line vty 0 4
login
transport input all
!
!
end

 

any help would be greatly appreciated 

0 Ratings
mike887
Beginner
4,735 Views
Message 28 of 31

BT infinity with a Cisco router 887VA

Go to solution

Hi i'm trying to connected with my Cisco 887 instead of the BT hub. I have followed some of the instruction i have seen online however it doesn't seem to work for me. I would really appreciate if anyone could help me out with this. I have inlcuded my config below. Thanks

 

Current configuration : 2323 bytes
!
! Last configuration change at 05:34:52 UTC Wed Mar 4 2015
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
memory-size iomem 10
!
!
!
!
!
ip dhcp excluded-address 192.168.1.1 192.168.1.10
!
ip dhcp pool lan
network 192.168.1.0 255.255.255.0
dns-server 4.2.2.2 4.2.2.3 8.8.8.8
default-router 192.168.1.1
!
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
!
license udi pid CI**** sn FC*****
!
!
!
!
!
!
!
controller VDSL 0
!
!
!
!
!
!
!
!
!
!
interface Ethernet0
description BT_INFINITY_VDSL0
no ip address
no ip route-cache
shutdown
!
interface Ethernet0.101
description 802.1Q_TAGGING_FOR_PPPOE_VDSL0
encapsulation dot1Q 101
ip nat outside
ip virtual-reassembly in
no ip route-cache
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
!
interface FastEthernet0
switchport access vlan 101
no ip address
no cdp enable
!
interface FastEthernet1
no ip address
shutdown
no cdp enable
!
interface FastEthernet2
no ip address
shutdown
no cdp enable
!
interface FastEthernet3
no ip address
shutdown
no cdp enable
!
interface Vlan1
no ip address
!
interface Vlan101
description FA_0_0
ip address 192.168.1.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip nat inside
ip virtual-reassembly in
ip route-cache policy
!
interface Dialer1
description 020*****
mtu 1492
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip nbar protocol-discovery
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer idle-timeout 0
dialer-group 1
keepalive 30
ppp authentication chap
ppp chap hostname firstname.lastname@btbroadband.com
ppp chap password 0 *bt-password* (i have also tried it without any username and password and just username(bthub@btbroadband.com) and no password)
no cdp enable
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip nat inside source list 1 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 1 permit any
dialer-list 1 protocol ip permit
no cdp run
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
no modem enable
line aux 0
line vty 0 4
login
transport input all
!
!
end

 

 

0 Ratings
martin1234321
Beginner
4,686 Views
Message 29 of 31

Re: BT infinity with a Cisco router 887VA

Go to solution

Dont know if you have resolved this but you have ethernet 0 shutdown. This means the subinterface o.101 is also down. Hope this helps. Please post as I am looking to do the same thing.

0 Ratings
blingo
Beginner
3,499 Views
Message 30 of 31

Re: BT infinity with a Cisco router

Go to solution

Hello I'm new here and wanted to ask a question regarding the a Cisco887VA I have connected to an infinity (business) line.

 

The line comes with a singular static IP address which is present when using the original BT moden (white huawesy box), however I cannot get the Cisco to pick up the static address. The static IP address returning whenever I plug the original huawey moden in,  the Cisco works like a dream in every way.

 

Any ideas ?

 

here is the cut down sh run

 


version 15.3
!
!
!
!
 

!
!
!
!
ip domain lookup source-interface Dialer1
ip domain name yourdomain.com
ip inspect name myfw ftp timeout 3600
ip inspect name myfw rcmd timeout 3600
ip inspect name myfw realaudio timeout 3600
ip inspect name myfw tftp timeout 30
ip inspect name myfw udp timeout 15
ip inspect name myfw tcp timeout 3600
ip inspect name myfw h323 timeout 3600
ip cef
no ipv6 cef
!
!
multilink bundle-name authenticated
 
!
!
!
controller VDSL 0
!
!
!
!
!
!
!
!
!
bba-group pppoe global
!
!
interface Ethernet0
 no ip address
!
interface Ethernet0.1
!
interface Ethernet0.101
 encapsulation dot1Q 101
 ip nat outside
 ip virtual-reassembly in
 pppoe enable group global
 pppoe-client dial-pool-number 1
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
interface FastEthernet0
 no ip address
!
interface FastEthernet1
 no ip address
!
interface FastEthernet2
 switchport access vlan 2
 no ip address
!
interface FastEthernet3
 no ip address
!
interface Vlan1
 ip address 192.168.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 ip tcp adjust-mss 1452
!
interface Vlan2
 ip address 192.168.1.1 255.255.255.0
!
interface Dialer1
 description vDSL
 mtu 1492
 ip address negotiated
 ip access-group 111 in
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nbar protocol-discovery
 ip nat outside
 ip inspect myfw out
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 1
 dialer idle-timeout 0
 dialer-group 1
 ppp authentication chap pap callin
 ppp chap hostname xxxxxxxxxx@hg.xxxxxxx
 ppp chap password xxx
 ppp pap sent-username xxx@hgxx.btclick.com password
 ppp ipcp header-compression ack
 ppp ipcp dns request accept
 ppp ipcp route default
 ppp ipcp address accept
 no cdp enable
!
no ip forward-protocol nd
no ip http server
 
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
no ip nat service sip udp port 5060
ip nat inside source list 102 interface Dialer1 overload
ip default-network 0.0.0.0
!
dialer-list 1 protocol ip permit
no cdp run
!
 
access-list 102 remark - Nat Inside Source List
access-list 102 permit ip host xxxxx any
access-list 102 permit ip xxx.xxx.xxx.1 0.0.0.255 any
access-list 111 remark - dialer 1 In
access-list 111 permit icmp any any administratively-prohibited
access-list 111 permit icmp any any echo-reply
access-list 111 permit icmp any any packet-too-big
access-list 111 permit icmp any any time-exceeded
access-list 111 permit icmp any any unreachable
access-list 111 permit udp any eq bootps any eq bootpc
access-list 111 permit udp any eq bootps any eq bootps
access-list 111 permit udp any eq domain any
access-list 111 permit esp any any
access-list 111 permit udp any any eq isakmp
access-list 111 permit udp any any eq 10000
access-list 111 permit tcp any any eq 1723
access-list 111 permit gre any any
access-list 111 deny   ip any any
!
!
!
 
!
!
end
 
BT_#

 

 

0 Ratings