cancel
Showing results for 
Search instead for 
Did you mean: 
NotAGreatStart
Aspiring Contributor
588 Views
Message 1 of 12

Bad Start - Failed activation/installation/engineer visit

Hey there,

Ordered my Total Broadband package a few weeks ago and have been eagerly awaiting the 21st of July. I got all my equipment on schedule and stayed at home all day for the engineer visit.

But they never turned up, according to an email, I should have phone service by 8pm on the 21st of July and Broadband before midnight 21st July. I've plugged everything in, unplugged it, power cycled, tested different sockets searched the BT help pages. What I'm looking at is a complete fail at activating my account, a wasted day waiting for an engineer to turn up whom by the looks of things was probably needed as nothing works. And if they send the engineer out to do what they should've done in the first place I'm probably going to get the dreaded £130 charge. All day my BT handset has read 'No Line'.

This doesn't feel like a good beginning to a relationship, having looked through these forums I'm starting to get a sinking feeling in my gut I picked an awful company to provide me with Internet.

Does anyone have any suggestions on what I could/should be doing? Thank you in advance.
0 Ratings
11 REPLIES 11
Distinguished Sage
568 Views
Message 2 of 12

Re: Bad Start - Failed activation/installation/engineer visit

Hi you need to phone BT sales and find out what has happened you will not get the 130 charge as that applies to faults with your internal wiring afterthe master socket did you have an existing phone socket in your home if you did it is possible that anengineer visit is not nessasary only work at the exchange / local street cabinet
raymie67
Expert
568 Views
Message 3 of 12

Re: Bad Start - Failed activation/installation/engineer visit

One thing to rememeber is that nooen comes to this forum to say everything is working, it is a forum for people that have or have had issues and so will always show BT in a negative light.

 

sadly however engineers not turning up is not that uncommon, had quite a few of these myself in the last year or two.

 

I would not imagine that you would get charged for another visiit, if the line is showing as not being active then it is clearly BT's fault (assuming that you have actually plugged in the phone 😉 )

 

You just need to call them and complain, I also thing you will be due some compensation for the missed appointment but it is a pretty low amount.

 

---------------------------------------------------------------------------------------
If my post was helpful then please click on the Ratings star on the left-hand side If the the reply answers your question fully then please select ’Mark as Accepted Solution’
Highlighted
Goelsewhere
Newbie
557 Views
Message 4 of 12

Re: Bad Start - Failed activation/installation/engineer visit

Exactly the same as what happened to me. Just rang and was told that there was a delay in the 'processing side of things' and that I would get a phone call updating me on the 26th, 'or maybe the 27th'.

 

Awful, awful service. I'm going to see if I can terminate the contract and get a refund on my line rental, as I'm not putting up with this.

Tags (1)
0 Ratings
NotAGreatStart
Aspiring Contributor
535 Views
Message 5 of 12

Re: Bad Start - Failed activation/installation/engineer visit

Thank you John and Raymie, your comments were helpful and reassuring, I'm reluctant to Mark this as resolved yet as it isn't. I did ring them up, I was never offered an explanation as to why they failed to come, I set up an appointment with an engineer for 1pm - 6pm this evening, it's now 6:15pm.

I'm rapidly feeling resentment towards BT, I'm curious to know when my service actually first starts, because if that specifically means the time I'm actually connected rather than the date I was supposed to be connected, I will cancel my contract.
0 Ratings
Distinguished Sage
529 Views
Message 6 of 12

Re: Bad Start - Failed activation/installation/engineer visit

if no engineer shows i suggest you contact the forum mods they will certainly resolve your problems they are a small UK based specialist team who will reply to you directly by either email or phone they normally reply within 72 hours they have an excellent record of getting problems resolved quickly
NotAGreatStart
Aspiring Contributor
525 Views
Message 7 of 12

Re: Bad Start - Failed activation/installation/engineer visit

How do I contact the forum mods please? Is there anything I need to know or do regarding this?

Thank you for your prompt response, my partner just went to a friends to use their phone to call BT while I waited in in case the engineer was late. The lady she spoke to said she couldn't understand why an engineer needed to come out! and I booked this appointment, they think it's all working their end. I now have to wait until Monday to ring them up and find out whats going on as they hung up on her and now the office is closed.
0 Ratings
Distinguished Guru
520 Views
Message 8 of 12

Re: Bad Start - Failed activation/installation/engineer visit

Just fill in the form here;

 

http://bt.custhelp.com/app/contact_email/c/4951 you can include a link back to your post. It might take a couple of days before the mods pick up on your message + its also the weekend, so might be relaxing by the pool.

toekneem

(EASBF)

NotAGreatStart
Aspiring Contributor
500 Views
Message 9 of 12

Re: Bad Start - Failed activation/installation/engineer visit

Received a text this morning saying my engineer decided to rearrange for two weeks time...

I couldn't be less impressed with this company. I regret the moment I even considered signing up to them. This service is utter rubbish.
0 Ratings
Distinguished Sage
496 Views
Message 10 of 12

Re: Bad Start - Failed activation/installation/engineer visit

as we have said contact the forum mods at this link http://bt.custhelp.com/app/contact_email/c/4951
they will get your problem sorted they reply to you directly by email or phone they are a small UK based specialist team with a great record of getting problems solved