Showing results for 
Show  only  | Search instead for 
Did you mean: 
Message 1 of 2

C610A Gigaset triple trouble

We have ascertained that the BT line is not at fault - by using a corded phone that is at least 30 years old and worked fine...


The Gigaset: Inputting a number into any Gigaset handset will give no dial tone and no bleeps as you key in the number. However, after a few seconds the screen will show as connected to the called number, but doesn't ring on the called phone (tested by calling a mobile).


We have tried rebooting the base unit by disconnecting from both mains and phone line but it didn't help. We also tried plugging it into the main phone socket and had no change


Calling the landline (Gigaset) from the mobile gets an engaged signal.


Plugging the corded phone into the main socket - the first one in the house - it works for both incoming and outgoing. Plugging it into the secondary socket, the one usually used for the Gigaset base, we can make calls out but it doesn't ring for incoming, though the caller gets the ring signal. Removing the cover reveals two unconnected wires, which we guess are for the ringer and were considered redundant by whoever fitted it. So that's not a problem. The Gigaset base unit has been plugged into that socket for well over a year and has worked perfectly. Now, for some reason, it doesn't work at all.


Question is - is there some way of resetting the Gigaset phone base unit, or has it died?


0 Ratings
Message 2 of 2

Re: C610A Gigaset triple trouble

Just to add... we tried a factory reset of the base unit without success.
0 Ratings