cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Beginner
735 Views
Message 1 of 5

Connection fine, Wifi terrible

Hi all,

 

I have recently signed up to BT ADSL broadband and am having an issue with Wifi. Has anyone had a similar issue?

 

My connection itself is fine. When I connect my laptop up to the homehub via the ethernet cable, I can browse the internet with no problem at all and get speeds of between 8-10 Mbps, which is fine for my needs. However, when I connect my ipad and smartphone to the homehub wirelessly then the speeds are laughably bad - somewhere between 0.2-0.5 Mbps.

 

I have tried all the generic solutions - homehub is connected to the master socket, no microwaves or any other potentially interfering devices nearby. I have tried splitting the 2.4GHz and 5GHz frequencies to see if there was a synching error, all to no effect. 5GHz is very marginally quicker but still only around 0.5 Mbps. The wireless connection speed remains the same whether I am standing next to the hub or in another room, so I don't think it is a range issue.

 

Has anyone else had this issue and can offer any advice? I have been reading about the BT mini-hub, but as far as I can tell this only increases the range of a wifi signal and does not improve the quality of the wifi itself, is that correct?

 

Any help would be greatly appreciated!

 

Thanks,

James

0 Ratings
4 REPLIES 4
Highlighted
Distinguished Sage
Distinguished Sage
724 Views
Message 2 of 5

Re: Connection fine, Wifi terrible

Welcome to this user forum.

 

Which BT home hub do you have?

 

0 Ratings
Highlighted
Beginner
714 Views
Message 3 of 5

Re: Connection fine, Wifi terrible

Hi Keith,

 

Thanks for the quick reply. It is the home hub 4.

 

Thanks,

James

0 Ratings
Highlighted
Distinguished Sage
Distinguished Sage
708 Views
Message 4 of 5

Re: Connection fine, Wifi terrible

Have you tried all 13 wireless channels? You have to disable smart wireless to do that, as it only allows access to three channels which are usually very congested. Try channel 13 on 2.4GHz.

 

As far as the iPad is concerned, you need to make sure thar the 2.4 and 5GHz SSIDS are different, and that the iPad only connect to one or the other, usually the 2.4GHz band is best, as it gives better range.

 

Wireless does suffer interference. Video senders are usually the worst offenders, as they occupy a number of channels.

 

0 Ratings
Highlighted
Beginner
701 Views
Message 5 of 5

Re: Connection fine, Wifi terrible

Hi Keith, thanks for your suggestions. I have not tried any of what you suggest. I shall do so and let you know how I get on.

 

Thanks,

James

0 Ratings