Showing results for 
Show  only  | Search instead for 
Did you mean: 
Message 1 of 1

Disc not connection to FTTP hub

Hi there,

On Monday 23rd March I had Halo2 Fibre installed. Engineer fitted new fibre box inside the property and connected the new hub. He said everything was working fine and left.

When I then tried to connect the BT Black Wi-Fi discs (2 of) there was a problem, one disc showed a solid red light and the other a flashing red light. I have reset to factory settings on both the hub and the discs but always with the same result. I have tried connecting by Ethernet cable and WPS button.

I can connect a computer by Ethernet and all is fine there.

I ran the BT broadband speed test but got an error message which said “we can’t see your hub online”

I checked the status of the order through MYBT and found the engineer visit was completed but it said it had failed.

I rang BT on 5 separate occasions and was told there was a fault at their end and they would fix it. They also said that instead of upgrading my broadband they had downgraded it.

The fault was marked as fixed on Thursday 2nd April, and when I run a speed test (not BT) I see the speed is upgraded.

Unfortunately, I still cannot connect the Black BT hubs. The red lights are still showing.

When I use the BT app (version 8.9.3) on my iPhone to set up the hub I get as far as scan the QR code and it fails to connect.

I see on various forums that this disc problem has been about for a long time so I hope someone can help me.

0 Ratings