Showing results for 
Show  only  | Search instead for 
Did you mean: 
Message 1 of 3

Draytek Vigor 2750n just stopped working again!

Hi Everyone,


I've had the 2750n for several months and it's been working great after I followed the install instuctions I found on here. Then last Saturday (9th June 2012) it stopped working. I called BT abd they said that there was some work going on in Woking on the line and it should be back in an hour.


Waited an hour and tried again but nothing so I tried the old HH3 and it worked fine so I then tried upgrading the firmware on the 2750n to see if that would help. The didn't make a difference but when I installed the 1.5.2 beta firmware it started working again.


Then today (11th June 2012) it stopped working again. I plugged in the HH3 and it's working again. I've submitted a support call into Draytek and I'm waiting for a reply bu I thought I'd post here and see if anyone else is having similar problems. Anyone know if BT are doing somehting funny with the fibre lines? I'm more a software person than a hardware person so apologie if I'm sounding like an idiot 🙂




Tags (1)
0 Ratings
Recognised Expert
Message 2 of 3

Re: Draytek Vigor 2750n just stopped working again!

Everything seems ok with my 2750n at the moment [using 1.5.2 beta ].


Have your tried a factory reset.?

And some of your settings might have been corrupted during the firmware update,so a check of all of the needed settings in the config screens might help.

And sometimes it helps to go to the PPPoE section or VDSL page and redo the settings,forcing it to connect to the BT servers again to activate the connection.

Hope you get it working again,as it ain`t a cheap modem/router.

 One important setting [I think it`s on the same page that you put your connection details in] is a setting that should be set to always on or always connected,because if not it will go offline after a certain time.


Message 3 of 3

Re: Draytek Vigor 2750n just stopped working again!

Thanks for the advice. I'll try the factory reset when I get back tonight. I didn't think it was a config corruption problem as it was Saturday when I did the firmware update and it was Monday before it stopped working. It's one of the only things I haven't tried yet so definitely worth a punt 🙂




0 Ratings