Showing results for 
Show  only  | Search instead for 
Did you mean: 
Message 1 of 7

Email access

Recently started having access problems, in trying to log into my emails. Message keeps coming back, 'cant reach this page'. Have tried changing my password, as suggested, this did work ok for a few days, but now back to square one, same message appearing.

This is becoming very frustrating, obviously something has happened to the system to cause these problems, after many years of no problems.  

Can anyone help here? 

0 Ratings
Message 2 of 7

Re: Email access

Are you a BT Broadband customer or are you paying for your email through a BT Premium Email account?

Do you know if you are on the BTYahoo email system or BTMail system. 

Have you tried clearing your browser's history and cookies? If not try doing that and if the browser has the option, clear it from all time.

0 Ratings
Message 3 of 7

Re: Email access

I am a BT broadband customer, and think use BT Mail system, not Yahoo.

Have clear browser history as recommended, still no luck in logging onto emails.

0 Ratings
Message 4 of 7

Re: Email access

A couple of things to try. Try another browser and if that doesn't work try turning off your Homehub for about 15 minutes. When you turn it back on hopefully you will be connected to a different email server and this may allow access to your account. 

0 Ratings
Message 5 of 7

Re: Email access

have tried disconnecting Hub, no help. Not sure about trying another browser, why should I, when it has worked fine for a number of yrs. My problem I feel lies with BT, i have done nothing to effect the process, so must be a problem at BT end, just not sure how you contact them.

0 Ratings
Message 6 of 7

Re: Email access

You don't have to try a different browser if you don't want to. It was suggested as a bit of diagnostics to try and establish where the fault might lie.

Phone 0800.800.150

0 Ratings
Message 7 of 7

Re: Email access

sorry if my comment came over as a criticism, i do appreciate your suggestions, just getting a little frustrated. Interestingly, have tried another few times to log on, and eventually it has worked. Does not make sense.



0 Ratings