cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
1,996 Views
Message 1 of 7

Fibre 500 installed - every device in the house has a different speed?!?!?!? What's Up?

Hello;

I am really struggling to understand what's happened since we installed BT Fibre 500.

New fibre installed, old hub removed and we are now left with a new shiny BT Smart hub 2.  So, we go through the pain of connecting each device in the house to the new Hub.  For me, a non technical person, this was mildly rewarding.

Now the real issues.  I have 10 devices in the house,  5 wired to the device and 5 using wifi.  All the wired devices show a network speed close to the 500Mbps.  This suggests to me that BT is delivering what I paid for.   However, every other device in the house is well below this amount.

My new Apple MacBook Pro (2019) can't get more than 80Mbps.  My iPhone is 30Mbps.  My Son's Windows PC started at 20Mbps and after buying a TP-LINK antenna (capable of 600Mbps), he is getting 60-70.  My iPadPro is getting anything from 280Mbps to 18Mbps.

Every once in a while I am taunted by the BT equipment and I get a 250+Mbps on one of these devices, but it never lasts. 

All my testing is in line-of sight of the Hub - usually about 10-12 feet away (what ever that is in metric, I have no idea). My experiments include resetting devices, reloading Operating Systems, resetting SMC, PRAM, changing the channels for the 2.4 versus 5.0 Ghz setting in the BT Hub.  Turning WIFI on, off on again.

I am pretty close to sacrificing some sheep and building a clay "BT" idol to pray to - if it would help.

Where to next?  what do I need to do to determine where the issue is?

Am I needing to buy a 3rd Party HUB?

Help!!

0 Ratings
6 REPLIES 6
1,987 Views
Message 2 of 7

Re: Fibre 500 installed - every device in the house has a different speed?!?!?!? What's Up?

0 Ratings
1,959 Views
Message 3 of 7

Re: Fibre 500 installed - every device in the house has a different speed?!?!?!? What's Up?

Yes, I turned it off - I found an article on reddit that mentioned this.

It did not help - or more accurately, I did not see any notable change.

 

0 Ratings
1,954 Views
Message 4 of 7

Re: Fibre 500 installed - every device in the house has a different speed?!?!?!? What's Up?

@AndrewUK 

Am I needing to buy a 3rd Party HUB?

_______________________________________________________________________________

In a word yes.

The supplied HH2 is not WiFi 6 enabled and has limitations.

Reading other posts on this board will tell you a "decent WiFi 6 router" WILL make all the difference. 🙂

___________________________________________________________________________________________
Say thanks by clicking the Thumbs Up icon. Have I resolved your issue? Click "Mark As Accepted Solution"
0 Ratings
1,923 Views
Message 5 of 7

Re: Fibre 500 installed - every device in the house has a different speed?!?!?!? What's Up?

OK.

But I am finding stuff i do not understand.  what is a "mesh" in relation to a HUB?

Most HUBS are hundreds of pounds?  Is there an optimum choice?

Does everyone else that get BT 500+ Fibre face the same issues??  Can this be fixed by BT?

0 Ratings
1,912 Views
Message 6 of 7

Re: Fibre 500 installed - every device in the house has a different speed?!?!?!? What's Up?

I have the same plan. 

Wired, I easily get 550Mbps. 

Wireless, I can get 340Mbps on my iPhone when tested about 10 feet from the SH2. I can never get anything faster than this. 

If I move another 10-20 feet then this speed drops to around 200Mbps but I have 3 of the ‘complete wifi’ discs dotted around the house to boost the 2.4ghz channel. One in the kitchen and 2 upstairs. 

If I was to turn those discs off then my speed would be around 40Mbps in pretty much every room in the house  

I am happy enough with this setup currently, but I will be upgrading to a router with wifi 6 eventually. 

0 Ratings
1,880 Views
Message 7 of 7

Re: Fibre 500 installed - every device in the house has a different speed?!?!?!? What's Up?

With the correct hardware it can be done.

Have a look here. 😃

___________________________________________________________________________________________
Say thanks by clicking the Thumbs Up icon. Have I resolved your issue? Click "Mark As Accepted Solution"
0 Ratings