cancel
Showing results for 
Search instead for 
Did you mean: 
hownewsday
Beginner
23,653 Views
Message 1 of 12

Home Hub 3 UPnP issue

Go to solution

Hi, I am after a bit of help if possible.

I have a PS3 and 2 AC Ryan mini media players using media on a NAS, a Synology DS410j on my home network.

They worked using UPnP with my previous router, a Netgear DG834G v2.

Since having the Home Hub 3 installed as part of the Infinity package I cannot connect to them using UPnP.

UPnP is turned on at the router and NAS.

The AC Ryans can access the NAS using a browser and NFS shares and the PS3 can access the internet with no problems.

I have tried resetting the router and all equipment and turning UPnP off and on which hasn't resolved the issue.

Anyone had this issue and resolved it?

Thanks in advance.

0 Ratings
11 REPLIES 11
Moderator
Moderator
23,566 Views
Message 2 of 12

Re: Home Hub 3 UPnP issue

Go to solution

Hi Hownewsday,

 

Thanks for posting. Have you tried this as a fix? Let me know if it helps.

 

Cheers

 

David

0 Ratings
fishyuk
Aspiring Contributor
23,426 Views
Message 3 of 12

Re: Home Hub 3 UPnP issue

Go to solution

Hi David, I'm also getting UPnP issues on my HH 3.0. I can't get remote connectivity to my Windows Home Server or access Games for Windows Live despite having tried setting manual port forwarding, trying virtually every combination of settings including all firewalls off, dmz, lower UPnP security, UPnP on/off, the strict NAT fix etc.

I'd really like to get UPnP working as I'd hoped that one of the main benefits of a 3.0 upgrade from my ancient white HH would be full UPnP compliance.

Running : http://www.microsoft.com/windows/using/tools/igd/results.mspx fails every time on UPnP, all other tests pass.

The test does appear to pass on XP SP3 32bit. I’ve tried to search for solutions to the 80070057 issue but most of the solutions for other routers appear to be firmware updates.

Error (Windows 7 x64 SP1)

The operating system is Windows Vista
get_FirewallEnabled() failed=80070057
IsUPnPDiscoveryEnabled() failed=80070057
Failed to get the
UPnP Discovery Settings

Error (Windows Home Server V1 – Windows 2003 32bit)

The operating system is Windows XP
UPnP is enabled by the firewall
UPnP
services are running
UPnP Discovery is enabled
Detecting Internet Gateway
Devices on the network
1 IGD(s) found
IGD Device
Information:
Manufacturer Name : BT
Model Name : Windows Media Connect
Compatible (Home Hub 3.0 Multi Mode)
Model Number :
4.7.5.1.83.8.57
get_StaticPortMappingCollection() returned NULL
IStaticPortMappingCollection
get_StaticPortMappingCollection() returned NULL
IStaticPortMappingCollection
get_StaticPortMappingCollection() returned NULL
IStaticPortMappingCollection
Failed to get port mapping from the IGD

Pass – XP Pro 32bit SP3

The operating system is Windows XP
UPnP is enabled by the firewall
UPnP services are running
UPnP Discovery is enabled
Detecting Internet Gateway Devices on the network
1 IGD(s) found
IGD Device Information:
Manufacturer Name : BT
Model Name : Windows Media Connect Compatible (Home Hub 3.0 Multi Mode)
Model Number : 4.7.5.1.83.8.57
135 existing port mappings were found:

0 Ratings
Highlighted
fishyuk
Aspiring Contributor
23,340 Views
Message 4 of 12

Re: Home Hub 3 UPnP issue

Go to solution

Hmmm, any thoughts anyone? Really need to get this working.  I'll try mailing support too...

0 Ratings
fishyuk
Aspiring Contributor
23,282 Views
Message 5 of 12

Re: Home Hub 3 UPnP issue

Go to solution

Right,

 

after having no joy for years on upnp, and having no decent way to convey issues via out sourced telephone call centres....

 

can

 

a) somebody recommend a decent, upnp compatible router that works with Windows 7 x64

b) witness that I'm not going to touch BT products again after this contract.

 

Thanks,

 

Cheesed off with totally, and utterly **bleep** service and no way to actually remedy it....

0 Ratings
fishyuk
Aspiring Contributor
23,251 Views
Message 6 of 12

Re: Home Hub 3 UPnP issue

Go to solution

Was a slightly (OK overly Smiley Happy ) emotive last post but just hope someone from BT is looking at HH3 firmware/upnp etc. Spent yet another morning of DMZing, port forarding, enabling, disabling firewalls etc but still no joy.

 

Reverted to old HH1 and can now access homeserver (Application Sharing ports set) and all Games For Windows Stuff (with no need to add any other settings).

 

Anyone looking to get the HH3 as I did for the much better wifi and nicer form factor beware that it might not be production ready yet, at least in my experience.

0 Ratings
justdavid
Newbie
22,550 Views
Message 7 of 12

Re: Home Hub 3 UPnP issue

Go to solution

fishyuk (if you're still around)

 

Have you got more than 1 network setup?

 

I found that I could not get the IGD test to run the uPNP phase while I had more than one network.

I had a second network that was setup by (and  for) Oracle Virtual box. Once removed then there was no more problem for IGD test. After that I manually set up the Hub for my Win Home Server 2011.

 

Hope this might help - either you or others who follow. 

 

 

0 Ratings
fishyuk
Aspiring Contributor
21,583 Views
Message 8 of 12

Re: Home Hub 3 UPnP issue

Go to solution

Ah, Cheers David.  Just uninstaled Virtual Box and now the UPNP test succeeds with a single network card.

 

Unfortunately it doesn't cure my inability to sign in to Games For Windows Live on HH3 though :-(.  I changed all the ports to the correct ones for GFL (meaning I had to take them away from Home Server....) and checked they are open with PFPortChecker but still no luck. Really weird, it says the ports are open. Even odder that I can fix the issue by switching back to my HH1.5!

0 Ratings
fishyuk
Aspiring Contributor
21,553 Views
Message 9 of 12

Re: Home Hub 3 UPnP issue

Go to solution

All, sorted. Had previously reset the ip stack but doing it again fixed it.  Would like to have Virtual Box back on but at least know how to work round it. Thanks!

0 Ratings
justdavid
Newbie
21,479 Views
Message 10 of 12

Re: Home Hub 3 UPnP issue

Go to solution

Good news!

 

As an aside I am happy to report full satisfaction with this Hub.  I have just returned from holiday and had shut down everything before leaving (home network, PCs, HH3 and Openreach Modem). On return everything has started up perfectly and i have had no problems since installation back in May.

 

0 Ratings