cancel
Showing results for 
Search instead for 
Did you mean: 
gman99
Contributor
9,151 Views
Message 1 of 190

HomeHub 3 LAN speeds only 10Mb?

Software version 4.7.5.1.83.8.57.1.3 (Type A)

 

Has anyone noticed issues with LAN connection speeds on the HH3? I've noticed sometimes my laptop, homeplugs + other devices only show as connected at 10Mbps on the HH3 device list and throughput tests show they really are only connecting at 10Mbps.

 

The 1Gbps port never suffers this problem just the 10/100 ports. A hard reboot sorts it and they connect at 100Mbps, is this a known issue (its not my clients)

 

TIA

0 Ratings
189 REPLIES 189
Chris-Sharpe
Contributor
9,128 Views
Message 2 of 190

Re: HomeHub 3 LAN speeds only 10Mb?

This could be an issue with your ethernet drivers.  Have a look in device manager and see if there is any problems with it. Have you tried it on another PC, to rule out this possibility?

I've not had any problems with the LAN speeds myself, but dont totally rule out the HH, it could be faulty.

0 Ratings
gman99
Contributor
9,119 Views
Message 3 of 190

Re: HomeHub 3 LAN speeds only 10Mb?

Hi,

No issues with my Ethernet drivers, I get this issue on two different laptops and my comtrend power lines so I've already ruled out different devices

Thanks
0 Ratings
golfer110
Newbie
9,108 Views
Message 4 of 190

Re: HomeHub 3 LAN speeds only 10Mb?

I have seen the same problem on my new HH 3. Only got it last week. Life is too short to have to reboot regularly. I had another cable router at home so have replaced the HH3.

0 Ratings
Distinguished Sage
Distinguished Sage
9,098 Views
Message 5 of 190

Re: HomeHub 3 LAN speeds only 10Mb?

Most devices have an option to force 100mb full duplex.

Auto-negotiation (default settings) can cause problems with some new equipment.

Try setting your network cards to 100mb full duplex. There may also be an option within the Comtrend web configuration menu.
0 Ratings
gman99
Contributor
9,093 Views
Message 6 of 190

Re: HomeHub 3 LAN speeds only 10Mb?

Hi,

I've looked at the comtrend config (its the comtrend where I first noticed this because it shows as a massive reduction in throughput) and there is no option to nail it up to 100Mb

This hasn't been a problem on my previous routers, Dlink DSL2640 DSL2740 etc etc

Totally understand that auto-neg can be an issue sometimes but as all of my equipment auto-neg'd fine before on other kit it would point towards an issue on the hub?
0 Ratings
Distinguished Sage
Distinguished Sage
9,090 Views
Message 7 of 190

Re: HomeHub 3 LAN speeds only 10Mb?

It would be interesting to see what effect an Ethernet switch would have, if connected between the HH3 and your other network devices.

They are quite cheap, and may solve the problem.

 

I do remember, when I used to repair LAN extension equipment, that it was a requirement that the tester and the users network equipment, was not set to auto-negotiate.

0 Ratings
9,081 Views
Message 8 of 190

Re: HomeHub 3 LAN speeds only 10Mb?

Hello,

 

I've had a look and all my devices have negotiated with my HH3 to 100Mb Full duplex (Network, Printer, Comtrend 9020 and Linux PC).

 

I would Factory Reset your Homehub 3, just in case there was a Firmware upgrade with a tweak for Auto-Negotiation which has got itself in trouble:

 

http://btybb.custhelp.com/app/answers/detail/a_id/11386/~/how-do-i-reset-my-bt-home-hub-to-its-facto...

 

I can find no evidence in the kernel logs that my HH3 running 4.7.5.1.83.8.57.1.3 (Type A) is having any problems with 10/100 Autonegotiation.

 

If you don't manage to get your devices negotiating correctly with the HH3, then test them connected to another switch/router. If they negotiate to 100M Full duplex plugged into something else and not the HH3, then contact BT for a replacement.

0 Ratings
gman99
Contributor
9,078 Views
Message 9 of 190

Re: HomeHub 3 LAN speeds only 10Mb?

I have an Ethernet switch out of the back of it as well, some devices are on that - a laptop with a 1Gig card and NAS with a 1Gig card, no issues with those to date. Its just devices connected direct to the HH3 ports itself that show this issue
0 Ratings
golfer110
Newbie
9,068 Views
Message 10 of 190

Re: HomeHub 3 LAN speeds only 10Mb?

I would say that if the HH3 can't cope with auto negotiate then it isn't fit for purpose. The operative word is HOME joe average user would never get this sorted on their own.

 

All my kit auto negotiates and has done successfully with every bit of router/switch technology I have had before.

 

0 Ratings