cancel
Showing results for 
Search instead for 
Did you mean: 
LeeP
Aspiring Contributor
19,598 Views
Message 1 of 19

Infinity on Cisco Router

Go to solution

Hi everyone

 

A very strange problem indeed ... !!

This morning I had Infinity installed. I've been blessed with the full 40MB/10MB connection speeds and through the homehub, life is a dream 🙂


However, my network is pretty complex in that I have dedicated Call managers, GRE tunnels from my house to friends houses for training purposes, multiple access-points etc etc - so integrating Infinity with my present network is absolutely key.

 

So, I ran a CAT5 connection from the LAN1 port on the Modem to a spare interface on one of my routers.

Configured the interface as a PPPOE client, sorted out the dialer interface, advertised the new default route into my network and life seemed good. Until I tried to access my bank account online!

 

https://ibank.barclays.co.uk would just hang and then time out. Strange. Access to webmail, google BBC news etc all seemed fine. So I started googling and found multiple sites were failing, but no particular trend to it!

Also failing was GRE tunnels over Infinity and other NAT'd apps (i.e. iTunes store would connect, yet I couldn't view my account, PS3 could update from the internet but not connect to Live etc). So very strange indeed!


So I patched the modem into a swith, created a new L2 vlan, ran another cable in the same VLAN to my router and then span'd the port to a sniffer capture machine. I could see TCP RST's, frames in the wrong order [TCP-OUT-OF-ORDER] followed finally by the router sending a reset out to the webserver.

 

I'm a cisco engineer by trade but for the life of me I cannot sort figure this one out 🙂 I've changed MTU settings right down, restored back at 1492. I can access the speedchecker and instantly see a problem: 14MB down and 2MB up, yet I go into the homehub and bang, full speed again.


I've confirmed I'm connecting at 100/Full and no errors seen. Totally confused by it ... !!

 

Anyway, here's my config:

 

vpdn enable
!
vpdn-group 1

!

interface FastEthernet0/0.4
 encapsulation dot1Q 4
 ip address 192.168.2.253 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 no snmp trap link-status
!

interface FastEthernet0/1
 description WAN-INTERFACE
 ip address dhcp
 ip mtu 1442
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
 pppoe enable
 pppoe-client dial-pool-number 1
 no routing dynamic
!

interface Dialer1
 ip address negotiated
 no ip unreachables
 ip mtu 1442
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap pap callin
 ppp chap hostname bthomehub@btbroadband.com
 ppp chap password 0 cisco
 ppp pap sent-username bthomehub@btbroadband.com password 0 cisco
!        

ip route 0.0.0.0 0.0.0.0 Dialer1
!        
!        

ip nat inside source list 1 interface Dialer1 overload
!        

access-list 1 permit any

 

Any help would be amazing! I have the sniffer file if anyone wants it ... !


LeeP

Statics FTW
Tags (4)
0 Ratings
18 REPLIES 18
Panman1964
Contributor
19,591 Views
Message 2 of 19

Re: Infinity on Cisco Router

Go to solution

probably no help at all but:

 

How far down did you take the MTU?

 

BTW & FWIW when I do an MTU determination test it works out at 1472 (1464 +8 for TCP overheads)

 

Doh, looking at your config you've tried 1442 , ah well.

 

 

Do you get the same problem if you connect the Cisco to the HomeHub ??

 

Also probs not much help but as a tech orientated chappy you may find the following interesting light reading

 

http://www.sinet.bt.com/495v1p0.pdf

http://www.sinet.bt.com/498v3p2.pdf

 

 

Possibly a little more helpful is http://www.dslreports.com/forum/r24720497-Config-PPPoE-sample-config-segment which I stumbled across the other dauy. I haven't actually compared it toyours but.....

 

 

Oh something else I read somewhere is that apparently you can use your @btinternet.com UN & PW for the CHAP authetication, may be worth a shot.

 

F:\Users\Mike>ping www.google.co.uk -f -l 1465

Pinging www.l.google.com [74.125.230.114] with 1465 bytes of data:
Packet needs to be fragmented but DF set.
Packet needs to be fragmented but DF set.
Packet needs to be fragmented but DF set.
Packet needs to be fragmented but DF set.

Ping statistics for 74.125.230.114:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

F:\Users\Mike>ping www.google.co.uk -f -l 1464

Pinging www.l.google.com [74.125.230.114] with 1464 bytes of data:
Reply from 74.125.230.114: bytes=1464 time=16ms TTL=52
Reply from 74.125.230.114: bytes=1464 time=15ms TTL=52
Reply from 74.125.230.114: bytes=1464 time=15ms TTL=52
Reply from 74.125.230.114: bytes=1464 time=15ms TTL=52

Ping statistics for 74.125.230.114:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 15ms, Maximum = 16ms, Average = 15ms

DISCLAIMER: although I work in the industry I do not work for BT and any opinions given are purely my own.
0 Ratings
LeeP
Aspiring Contributor
19,577 Views
Message 3 of 19

Re: Infinity on Cisco Router

Go to solution

 Thanks for your response.

 

The link you provided with the config was great - it was everything I had configured except :

 

 ip tcp adjust-mss 1452

 

..under the interface to the WAN. Going to give this a try later.

 

Such a strange fault!

Statics FTW
0 Ratings
LeeP
Aspiring Contributor
19,573 Views
Message 4 of 19

Re: Infinity on Cisco Router

Go to solution

The above didn't work - so back to the drawing board with this one!

Statics FTW
0 Ratings
LeeP
Aspiring Contributor
19,557 Views
Message 5 of 19

Re: Infinity on Cisco Router

Go to solution

OK - I've fixed this now 🙂

 

MTU on the LAN interfaces needs to be set to 1350.

 

interface FastEthernet0/0.1
 encapsulation dot1Q 1 native
 ip address 172.30.1.10 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1350
!
interface FastEthernet0/0.4
 encapsulation dot1Q 4
 ip address 192.168.2.253 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1350
!
interface FastEthernet0/1
 description WAN-INTERFACE
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
 ip tcp adjust-mss 1452
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 1
 no routing dynamic
!
interface Dialer1
 ip address negotiated
 no ip unreachables
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap pap callin
 ppp chap hostname bthomehub@btbroadband.com
 ppp chap password 0 bthomehub@btbroadband.com
 ppp pap sent-username bthomehub@btbroadband.com password 0 bthomehub@btbroadband.com
 ppp ipcp dns request

Statics FTW
0 Ratings
Panman1964
Contributor
19,533 Views
Message 6 of 19

Re: Infinity on Cisco Router

Go to solution

Glad to be of some indirect  assistance 🙂

DISCLAIMER: although I work in the industry I do not work for BT and any opinions given are purely my own.
0 Ratings
LeeP
Aspiring Contributor
19,514 Views
Message 7 of 19

Re: Infinity on Cisco Router

Go to solution

🙂


Also worth noting that by enabling CEF on both my switches and router, my throughput increased by approx 10%. Now achieving the full 40MB and almost 10MB up.

Statics FTW
0 Ratings
Panman1964
Contributor
19,507 Views
Message 8 of 19

Re: Infinity on Cisco Router

Go to solution
w00t w00t !!
DISCLAIMER: although I work in the industry I do not work for BT and any opinions given are purely my own.
0 Ratings
rlk
Newbie
18,895 Views
Message 9 of 19

Re: Infinity on Cisco Router

Go to solution

Hi,

 

Can anyone advise if this configuration would also work with a Cisco 877-K9 modem/router?

 

Regards,

Richard.

0 Ratings
Highlighted
Jamesy281
Newbie
18,876 Views
Message 10 of 19

Re: Infinity on Cisco Router

Go to solution

Hi Leep,

 

Can you tell me if the Chap host name and user name are the same or is this just how tou have posted it?

 

Thanks.

0 Ratings