cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Expert
973 Views
Message 1 of 14

MTU used by ECI modem/HH3

For whatever reason my MTU value seems to be set at 1452 from the ECI modem/HH3, any idea why this would be the case rather than 1492?

 

More importantly is there any way to change this as I'm convinced this is too low and would like to try the default of 1492 for PPPoE as my downloads seem to be quite erratic?

0 Ratings
13 REPLIES 13
Guru
972 Views
Message 2 of 14

Re: MTU used by ECI modem/HH3

Source?

If this helped you please click the Star beside my name.

If this answered your question please click "Mark as Accepted Solution" below.
0 Ratings
Expert
957 Views
Message 3 of 14

Re: MTU used by ECI modem/HH3

the MTU for BT router will be set automatically at 1500 on the computer side for FTTC (WAN socket I am sure you know there is software that can adjust these settings Smiley Wink

MTU adjustments where needed sometimes on the old ADSL routers, not needed for Fibre these days !

 

you can change the windows side of the MTU back to 1500 using this , open up the comman prompt as administrator

 

netsh interface ipv4 set subinterface "Local Area Connection" mtu=1500  store=persistent

0 Ratings
Expert
939 Views
Message 4 of 14

Re: MTU used by ECI modem/HH3

Thanks but already checked it was set at 1500 on windows, just wondering why 1452 rather than 1492 on the router side.

As for source the easiest is probably from a myspeed quality test.
0 Ratings
Expert
934 Views
Message 5 of 14

Re: MTU used by ECI modem/HH3

The HH3 is set by default 1500 MTU unless you hack it, you must be using some other router ?

0 Ratings
Expert
901 Views
Message 6 of 14

Re: MTU used by ECI modem/HH3

It is because it is a PPPoE connection where there is an 8 byte overhead for the protocol.

0 Ratings
Guru
896 Views
Message 7 of 14

Re: MTU used by ECI modem/HH3


@anthonyUK wrote:

It is because it is a PPPoE connection where there is an 8 byte overhead for the protocol.


He mentioned that, he believe it's set to 1452 instead of being at 1500 (1492).

If this helped you please click the Star beside my name.

If this answered your question please click "Mark as Accepted Solution" below.
0 Ratings
Expert
883 Views
Message 8 of 14

Re: MTU used by ECI modem/HH3

1492 is the max but anything below that should work as long as everything else downstream is configured to use the lower value.

@Storm - If win7 I wouldn't worry too much as it should autotune but no idea why 1452.
0 Ratings
Expert
850 Views
Message 9 of 14

Re: MTU used by ECI modem/HH3

From MySpeed quality Test:

 

MySpeed.jpg

 

As you can see this is reporting an MTU of 1452, the windows side as stated is 1500. I'm getting massive amounts of TCP idle time, this is actually lower than usual. Any ideas why it is not defaulted to 1492?

0 Ratings
Guru
848 Views
Message 10 of 14

Re: MTU used by ECI modem/HH3

Not a clue, changing the win7 MTU to match might help you a little.

 

You could try a hard reset, holding the reset button for 10+ seconds.

If this helped you please click the Star beside my name.

If this answered your question please click "Mark as Accepted Solution" below.
0 Ratings