cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Ringoko
Contributor
1,248 Views
Message 1 of 4

Netgear D7000 PS4 problem - "The router in use might not support IP packet fragmentation"

Router: Netgear D7000
ISP: BT Infinity 2

 

In the PS4 network settings when testing my connection, the test takes quite a while to decide my Nat type, and gives the message "The router in use might not support IP packet fragmentation, and some network features of the PS4 might be restricted".

 

I've given my PS4 a static IP and put that in DMZ. Its connected to my router via two ethernet cables and a gigabit switch, but the fragmentation message shows up again when the PS4 is directly connected to the router and also on wifi connection.

 

I followed this guide to determine my optimal MTU size was 1460+28=1488. I changed the MTU to 1488 on the router and PS4. Also I enabled QOS and gave highest priority to the PS4. My router and PS4 firmware is up to date.

 

The speed and nat type on my PS4 seem fine, in online P2P shooters sometimes I feel like I've been shot out of nowhere or that my shots dont register, but often it seems fine, so I'd just like to fix this issue to be sure.

 

I've read that that this issue can be caused by double natting. I've no idea what that is, but this page says one indicator of double-nat is a WAN IP in my router settings of 192.168.x.x, but under Home > Internet in my router config page, my internet IP starts with 31.x.x.x. Maybe it is something to do with the D7000 is an all-in-one VDSL modem/router like the BT Home Hub modem/router.

 

Also I've read up on other forums through google, some say its because the MTU is too high, some say its because I have the PS4 in DMZ, QOS and on the DHCP list. What is a good low setting for MTU? Maybe 1400?

 

Here is an image dump of my PS4 and router settings, hopefully it helps someone spot the problem! (If it includes settings etc that should be private, please let me know so I can edit)

0 Ratings
3 REPLIES 3
SimonN
Contributor
1,235 Views
Message 2 of 4

Re: Netgear D7000 PS4 problem - "The router in use might not support IP packet fragmentation&qu

I have the modem and r7000 and see no issues. I know that doesn't help you though.

 

I have 1492 set for MTU as that's what the router defaulted to and, after doing the same test as you, was what my mtu test suggested. What was the default MTU the router picked up on set up? Have you tried that?

 

I have UPnP on. Nothing in the DMZ (netgear's UPnP actually works - open NAT on CoD/Destiny and no voice chat issues in party or game) - Assigned IP to PS4.

 

I have disabled SIP ALG as I don't use VOIP or similar but you may - looking at your images - but I'd try it anyway. (Maybe worth removing the Mac addresses by the way - but I'm paranoid about such things)

 

Everything I've read regarding QoS is bad so I've turned that off (or rather never enabled it)

 

I've also disabled traffic meter in netgear genie.

 

Also - last stupid question: You have rebooted after each change?

I was advised to factry reset after firmware update. It's a pain I know but, as I barely have to change much from the defaults it's not too bad.

 

I'd suggest:

disable QoS.

disable traffic meter.

disable SIP ALG

Remove the PS4 from DMZ

Enable UPnP

keep the fixed IP for the PS4

Reboot router.

 

 

 

Ringoko
Contributor
1,211 Views
Message 3 of 4

Re: Netgear D7000 PS4 problem - "The router in use might not support IP packet fragmentation&am

Hi, thanks for the reply. I tried everything you suggested, also following advice on Netgears forum I changed the DHCP range so the PS4 static IP wasnt in it, and changed the MTU to automatic. Unfortunately still getting the error.

 

I'm sure I read somewhere on here before that its the modem in the D7000 thats at fault, similar to the same problem happening with the Home Hub 5a.

0 Ratings
soupladel
Contributor
1,195 Views
Message 4 of 4

Re: Netgear D7000 PS4 problem - "The router in use might not support IP packet fragmentation&qu

@Ringoko

 

I had the D700 but it was faulty and have opted to get an asus instead (getting picked up later today)

 

However, when i did have it, I found that if i set the MTU on the router to 1492 and have automatic MTU set on the PS4, then the message went away.

 

What version of the firmware are you running? as @_Simon_ says, its good practice to do a factory reset after a firmware update and when making any changes such as MTU, I would suggest switching your PS4 off before making the change - actually power it down entirely, not just into the power save mode, then make the changes on the router, then once the router has restarted, power on the PS4.

0 Ratings