cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Griggsy2005
Beginner
881 Views
Message 1 of 9

No broadband after activation date, very poor service

Once again I've been let down by BT!

I moved into my house Dec '15 and ordered fibre broadband, phone & tv two weeks prior to my move in date.

After numerous failed attempts to connect, BT finally conceded after 2 months of trying that there was not actually enough room in the cabinet for me to get fibre broadband at that time, why this couldn't be identified immediately, I don't know! However they assured me that as soon as there was room in the cabinet I would be informed so that I could continue my fibre order. In the meantime I had been set up with a regular broadband connection (500kbps-1mbps). There were several issues with this issue, the router wasn't sent out the first time, no microfilters etc, so numerous time and effort was taken in getting them to sort their act out.

Months and months passed without a word from BT. I then found out from a neighbor that a number of residents already had fibre broadband. I thought this odd as BT were supposed to contact me when it was available, another failed promise.

So I hastily picked up the phone and contacted BT and they confirmed that there was space in the cabinetand that I can place an order for fibre.

I was given an activation date of 5 December, that date has now been and gone and I have not had an email confirming activation of the broadband actually working. I was sent a new hub and you-view box on the 2nd, but when installed these do not work. All the correct instructions have been followed and the hub has been installed correctly, however the hub is constantly flashing purple. According to the guide this indicates that there is a lead not connected, but all leads have been correctly installed. So once again I've been let down by BT.

If this is not rectified immediately after all the issuesI've had with BT, I think im going to have to look elsewhere for an Internet and TV provider

My order number is ***EDITED***

Thereis also another order number on my emails which is as follows;
***EDITED***

0 Ratings
8 REPLIES 8
cyuan1214
Beginner
841 Views
Message 2 of 9

Re: No broadband after activation date, very poor service

Same problem here, got delay almost 7 days and need to wait anpther 5 days

0 Ratings
throwaway_hero
Beginner
836 Views
Message 3 of 9

Re: No broadband after activation date, very poor service

The same happened to me when I first joined BT 2 years ago, it took 4 engineer visits and about 1 month after the 'activation date' before it was finally sorted. Absolutely ridiculous, caused so much stress and had to spend a fortune on mobile data to tether. Do BT think we can just crack on with our lives when our jobs etc depend on the internet?
0 Ratings
YourEIN
Aspiring Contributor
815 Views
Message 4 of 9

Re: No broadband after activation date, very poor service

Hi,

 

I assume you have called the Connections / Faults department, had them carry out some fault tests and they are sending an enignerr?

 

If not, please do that.  Connections will get an engineer out to you within a couple of days if it is a line fault.

 

Does your phone work?  Dial tone?  Make and receive calls?

 

===========================================

1. Is hub in the right 'hole'? If you have a '2-hole' socket, put the ADSL cable into the small square hole...
2. Make sure you are connecting to the correct 'SSID' e.g. BTHub6-1234
3. If you 'work from home', use a business line, not a residential line.
0 Ratings
Griggsy2005
Beginner
811 Views
Message 5 of 9

Re: No broadband after activation date, very poor service

Standard BT response!
0 Ratings
john46
Distinguished Sage
805 Views
Message 6 of 9

Re: No broadband after activation date, very poor service

This is a customer to customer self help forum posts made here do not go to BT although the forum is moderated by BT not every post is read

0 Ratings
Griggsy2005
Beginner
799 Views
Message 7 of 9

Re: No broadband after activation date, very poor service

Yes I've called them and they've identified a fault and an engineer is coming out apparently!

I don't use the landline so I've got no way of knowing.

What is strange is that the line worked fine the day before the fibre activation, since then, it doesn't even work with the old router! My point being, why, if it was fine before, is there now an issue?!?

Apparently if the problem is within the boundary of my property then I'll have to pay £129 for the call out! Even though it's a brand new build. Strange?!?
0 Ratings
john46
Distinguished Sage
794 Views
Message 8 of 9

Re: No broadband after activation date, very poor service

I suggest that you connect a basic corded phone to the master socket and check for any noise and that you also have a dial tone as this will avoid the chances of a charge you can buy a basic phone for around £5 from a well known catalogue store regular checks of the phone line will avoid possible line faults and is also useful in an emergency
0 Ratings
john46
Distinguished Sage
792 Views
Message 9 of 9

Re: No broadband after activation date, very poor service

your old router will only work on an infinity connection if it is fibre enabled
0 Ratings