cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
mb199143
Beginner
472 Views
Message 1 of 18

Poor Wireless Speed

Hi, We have recently had BT infinity installed with Home Hub 3.0. Prior to BT we were with SKY and with the wireless service I was receiving around 5mbps  in my living room (next to room with home hub) and bedroom (above room with home hub). Having changed to BT infinity I notice that my speed in the same locations is the same or slower (averaging around 4.5mbps wirelessly. Having such a poor speed, I was suprised and so checked the wired speed with our desktop pc, which I was impressed to see was at 66mbps. Therefore I am wonderfing what I can do to improve the wireless signal because surely the router cant be that bad to be providing only the same wireless service as the SKY broadband we had before? I have looked at previous messages regarding similar problems and have tried changing the settings/channel etc for my router, none of which have had an impact on performance. Home plugs are an option though not ideal as they can be expensive and also it is easier and more practical to use wireless. Is there anything that you can suggest I do to improve the signal as I am currently very disappointed with the wireless service. 

 

Also if it is worth mentioning, my laptop is fairly new and has 'n' capability.

0 Ratings
17 REPLIES 17
Words
Contributor
465 Views
Message 2 of 18

Re: Poor Wireless Speed

The last point was worth mentioning.

 

I found I had better throughput by set the hub to the 40 Mhz option in the advanced settings, and security to 'WPA2 only'. If you post your settings (but not the security code) we may get a better idea of what to suggest. 

 

 

0 Ratings
jamjar62
Expert
460 Views
Message 3 of 18

Re: Poor Wireless Speed

So do you think its better to be on WPA2 ONLY  than WPA & WPA2 ? 

JamJar62
0 Ratings
Words
Contributor
443 Views
Message 4 of 18

Re: Poor Wireless Speed

Yes absolutely, unless you really have to have a mixed system. My speeds went up 50% by switching to WPA2 only.

0 Ratings
jamjar62
Expert
440 Views
Message 5 of 18

Re: Poor Wireless Speed

oh ok i,ll give that a try 🙂 but why do they recommend the WPA & WPA2 setting in the hub Manager page ?

JamJar62
0 Ratings
mb199143
Beginner
435 Views
Message 6 of 18

Re: Poor Wireless Speed

Just made the changes you suggested and havent seen a change in results really. Settings are: 

 

Channel type-Automatic (I have tried on other channels but made no difference)

Interface type- 802.11 b/g/n 40mhz

security- WPA2

Actual data transfer speed- 11mbps

 

Slow speed is really annoying me as I was expecting so much from infinity....

 

On a seperate note to the slow wireless speed I have had issues connecting wirlessly with my PS3 and my Smart TV (wireless enabled) any idea on settings that can be changed to improve connectivity with these?

0 Ratings
Words
Contributor
430 Views
Message 7 of 18

Re: Poor Wireless Speed

Can you set it to 802.11 n only? The b/g protocols are much slower and this could be the problem. 

0 Ratings
mb199143
Beginner
428 Views
Message 8 of 18

Re: Poor Wireless Speed

I cant, I have the option of b/g/n recommended, b/g or b/g/n 40 mhz

0 Ratings
Words
Contributor
423 Views
Message 9 of 18

Re: Poor Wireless Speed

Ugh! Have you tried rebooting the hub and maybe the PC as well. 11Mbps is the b protocol which is why things are so slow.

0 Ratings
mb199143
Beginner
421 Views
Message 10 of 18

Re: Poor Wireless Speed

Yeah, the pc and hub have been restarted a few times, no luck.

0 Ratings