cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
snowjoke
Aspiring Contributor
12,809 Views
Message 1 of 13

Powerline adapter intermittent Home Hub connection issues

We recently got Infinity FTTC, and installed powerline adapters in order to get decent speeds throughout the house. It works perfectly 99% of the time, but...

 

On one powerline adapter (as far as I've noticed) I'm experiencing loss of connection with the Home Hub for periods of up to around 5 minutes (average 2 minutes), about 5 times per day. It seems to happen at random times. There are no corresponding events in the Home Hub's Event Log. Why might this be and how can I fix it?

 

Detailed info:

 

Equipment: we needed 3 extenders so bought the following...
[0] BT Home Hub 5 (Type B) | Software version v0.07.03.0814-BT 

BT Wi-Fi Home Hotspot 500 Kit (= [1] Broadband Extender Flex + [2] WiFi Home Hotspot)

BT Mini Home Hotspot 500 Multi Kit (= [3] Broadband Extender + [4, 5] 2 x Mini WiFi Home Hotspot)

 

Setup:

Kitchen:      Home Hub [0] connected to powerline adapter [1]. SSID "Home"

Study:        Broadband Extender [3] (works the same as the Hotspots except no WiFi)

Lounge:      WiFi Hotspot [2]. SSID "Home-Lounge"

Bedroom 1: Mini WiFi Hotspot [4]. SSID "Home"

Bedroom 2: Mini WiFi Hotspot [5]. SSID "Home"

 

We changed the SSIDs to be recognizable, and used the "clone" feature on the Mini Hotspots, so that they have the same SSID as the kitchen and signal strength is maintained when moving from one room to another, without having to manually switch connections. The non-Mini one [2] doesn't have a "clone" feature... I suspect we could just change the SSID and password manually to be the same, but for now it's different.

 

The problem is in Bedroom 1, where a PC is connected via Ethernet cable to the extender [4] most of the day, and is where I've noticed the issues. (It's possible they occur on the other extenders at different times, but I haven't noticed.)

 

When there is an disconnect, internet stops, and it's not possible to connect to the Home Hub via "bthomehub.home", either via Ethernet or WiFi, on the PC or my phone. The WiFi signal remains strong. So the issue is connecting to the Home Hub, not the internet connection. However the connection to the Home Hub and internet is fine if during a disconnect I connect via another extender [2], using the "Home-Lounge" SSID (albeit slower speeds, since it's further away). So it appears to be a problem with just one extender [4], rather than the Home Hub, since other extenders remain connected.

 

During an outage, the three lights on the extender remain green, as normal.

 

And that is as much as I know. Like I said, it's perfect 99% of the time. I just have no idea why there are these random and annoying intermittent connection issues. Should I send the Mini extenders back to Amazon and ask for a replacement kit? Thanks for any ideas!

0 Ratings
12 REPLIES 12
snowjoke
Aspiring Contributor
12,764 Views
Message 2 of 13

Re: Powerline adapter intermittent Home Hub connection issues

Bump.

 

Oddly, didn't disconnect at all yesterday while I was monitoring. But it's happened 8 times today. I've reset the extetender using its Reset button, but still got a disconnect afterwards.

0 Ratings
snowjoke
Aspiring Contributor
12,756 Views
Message 3 of 13

Re: Powerline adapter intermittent Home Hub connection issues

Have just had another thought: it can't be 2 minutes of interference on the electrical wiring, because the extender is communicating successfully with other extenders.

 

That would imply some sort of glitch in the connection between the extender ("Mini Wifi Home Hotspot" [4]) and the "Broadband Extender Flex" [1] (attached by Ethernet to the Home Hub).

 

Can anyone confirm that the "Mini Home Hotspot 500" hotspots are supposed to be 100% compatible with the extender from the "Wi-Fi Home Hotspot 500" kit?

 

0 Ratings
DavidM
Moderator
Moderator
12,740 Views
Message 4 of 13

Re: Powerline adapter intermittent Home Hub connection issues

Hi snowjoke,

 

Thanks for posting. Sorry for the delay in getting back to you. I’ve contacted the product support team for the wi-fi extender and they’ve confirmed that the Mini Home Hotspot 500 and the Wi-Fi Home Hotspot 500 are fully compatible. You’ll find help with those products at Wi-Fi Home Hotspot 500.

 

Cheers

 

David

 

0 Ratings
snowjoke
Aspiring Contributor
12,732 Views
Message 5 of 13

Re: Powerline adapter intermittent Home Hub connection issues

> I’ve contacted the product support team for the wi-fi extender and they’ve confirmed that the Mini Home Hotspot 500 and the Wi-Fi Home Hotspot 500 are fully compatible.



Thanks. I'm beginning to think it's a bug with the Home Hub. A couple of times this morning, the disconnection seemed to occur when I tried to access the Home Hub's settings pages.

But it is very strange that it's not specifically my computer it stops communicating with, but both the Ethernet and WiFi on the Hot Spot. I can't work it out. But that's probably because I don't understand these things very well.

Like I said, when there's a disconnect, I can ping other Hot Spots on the network, so I guess this occurs directly over the power lines, and doesn't go via the Home Hub. If I try pinging a phone that was connected specifically to the Home Hub's WiFi while there was a disconnect, it is unreachable.

So why would a particular extender be periodically ignored by the Home Hub for 2-3 minutes, then start working again? What further diagnostics can I try?
0 Ratings
Oxlade1
Aspiring Expert
12,713 Views
Message 6 of 13

Re: Powerline adapter intermittent Home Hub connection issues

Hi,

 

Have you tried moving the troublesome Mini Hotspot [4] to another power socket? Is the Hotspot plugged directly into the wall socket? Are there any other electrical devices plugged into the same double socket (if it's double)?

 

It may be that the connection between the Hotspot [4] and the master Extender [1] is slightly marginal and drops out sometimes, yet the connection to other Extenders is always stable.

0 Ratings
snowjoke
Aspiring Contributor
12,708 Views
Message 7 of 13

Re: Powerline adapter intermittent Home Hub connection issues

Hi Oxlade, thanks for the comments.

I haven't done an extended test using another socket, because the one I'm using is the only one close enough to my computer, without using an extension cable.

It is plugged directly into the wall socket. There's a surge protection power strip with a digital piano and phone cradle plugged into the the other half of the socket.... I could try unplugging those.

> It may be that the connection between the Hotspot [4] and the master Extender [1] is slightly marginal and drops out sometimes, yet the connection to other Extenders is always stable.

That does appear to be the case... the question is why. My first thought was that the wiring could be the problem, but then I wouldn't expect to be able to ping other devices during the disconnections. And the rest of the time, I get full speed (about 60 Mbps), as if I'm plugged directly into the Home Hub. I'd have thought that if the connection were marginal, I'd just get reduced speeds (but maybe that's not how it works?).

Last night I tried swapping extenders around ([1] with [3], and [3] with [4]), and still had the problem, which eliminates the possibility of faulty extender units.

I'm running a programme to monitor internet connectivity, and had 22 disconnections last night between 6pm and 11pm. It's getting really annoying. I might try setting up a laptop to monitor the other extenders to see if they show a similar pattern (it might be that I just haven't noticed because they're not in constant use).

In the meantime, my workaround is to change the SSID of the bedroom Hotspot [4], enable the wireless card on my PC, and tell it to connect to the WiFi on the Home Hub [0] rather than [4]. It only uses the WiFi when it can't connect over Ethernet. This WiFi is quite weak and slower (which is why we got the powerline extenders), but it's better than complete connection loss.

0 Ratings
stuartb3502
Aspiring Contributor
12,685 Views
Message 8 of 13

Re: Powerline adapter intermittent Home Hub connection issues

I have what may be similar symptoms and would also be interested in suggestions to resolve.  My situation...

 

HH4 connected via TP-Link powerline homeplugs to my main PC.  NAS box also connected via powerline homeplug.

Wifi also in use.  No extenders however.

 

Symptoms

 

My connection from the main PC to the HH4 and on to the Internet drops intermittently for period of a few minutes and then restores itself.

When this happens:-

 

  • Wifi connected devices are all OK (can see HH4 and the Internet).
  • The PC can see the NAS box OK
  • The NAS box can see the Internet OK
  • PC (192.168.1.65) is spitting out repeated ARP broadcasts trying to find the gateway "464 114.806548000 AsustekC_f3:58:ba Broadcast ARP 42 Who has 192.168.1.254?  Tell 192.168.1.65"
  • In return the HH4, appears to send spanning tree packet "465 114.939536000 Sagemcom_a5:45:## Spanning-tree-(for-bridges)_00 STP 60 Conf. Root = 61440/4095/ff:ff:bb:a5:45:##  Cost = 0  Port = 0x8002"  (end of MAC disguised)

 

Eventually, the HH4 replies to the ARP request correctly:-

"496 117.311673000 Sagemcom_a5:45:## AsustekC_f3:58:## ARP 60 192.168.1.254 is at cc:33:bb:a5:45:##"

 

and normal service resumes.

 

Any one any ideas why there is spanning tree traffic and whether this may be the source of the problem?

 

Thanks

 

Stuart

 

 

0 Ratings
snowjoke
Aspiring Contributor
12,670 Views
Message 9 of 13

Re: Powerline adapter intermittent Home Hub connection issues

Stuart - I think we may be banging our heads against a wall by posting on this board.

 

However, I have done some further testing using my laptop to monitor internet connectivity, and found:

 

1. All the extenders, in the study, lounge, and both bedrooms have occasional disconnections

 

2. Sometimes there are periods of several hours when there are no disconnections; sometimes it happens every 10 minutes

 

3. Most disconnect durations are around 30 seconds, but have been up to 6 minutes

 

4. Plugging in an extender [4] on the same double-socket as the extender [1] attached to the homehub for a few hours saw 0 disconnections. This suggests the problem is caused / worsened by distance over the electrical wiring

 

5. Having the WiFi on my desktop turned on (in order to "fill-in" while the Ethernet connection is down) doesn't work. If I physically disconnect the Ethernet cable / "disable" Ethernet it in Windows, it recognises that the Ethernet is disconnected and seamlessly switches to WiFi. Same when I turn off the extender using the button on the front, except when I turn the extender back on I lose internet on the computer, because the computer uses Ethernet in preference to Wifi if it's available, but the extender takes 30 to 60 seconds to re-establish a connection with the Home Hub. (Failing over to WiFi wouldn't really be a totally satisfactory solution anyway, because any other devices connected to the bedroom's hotspot won't switch automatically.)

 

 

So... to sum up:

- the extenders are occasionally losing connection with each other over the powerlines

- it's taking far too long to restore that connection (not a Windows thing because it's with my Android phone too): it needs to be instant, to maintain connectivity for real-time applications (Skype, gaming etc)

 

It doesn't appear to be BT-specific because I've read lots of similar stories from people with TP-Link devices. If anyone has seen any better performance with different brands, I would like to hear about it. I can't believe this is some sort of inherent limitation of powerline networking.

 

I'm currently looking into wiring up some Ethernet cabling through the house (big hassle), as the only way of getting a fast, reliable connection in other rooms.

0 Ratings
stuartb3502
Aspiring Contributor
12,632 Views
Message 10 of 13

Re: Powerline adapter intermittent Home Hub connection issues

Snowjoke - apologies for missing your reply - was on holiday at the time and overlooked it when I got back.

 

You could be right that its just a TP-Link or Powerline thing.

 

Since the TP-Link connection from PC to my NAS works fine whne the problem occurs and the TP-Link from my NAS to the Homehub works fine too, I know the Homeplugs themselves are working and the Homehub's Ethernet port is working too.

 

So its either an issue in homeplug connectivity just between my PC and the Homehub or a "soft" networking issue on the Homehub blocking my PC.

 

I need to look into understanding spanning tree better and why there is spanning tree traffic occurring - AFAIK there's no bridge within the network so this should not be needed.

 

Thanks anyway.

 

Stuart

0 Ratings