Showing results for 
Show  only  | Search instead for 
Did you mean: 
Aspiring Contributor
Message 1 of 3

Problem playing 4k content on my smart TV since switching to BT Infinity (Fibre to Home)

I have very recently had fibre to the home installed using the latest smarthub.  I have a digihome 4k TV connected by a homeplug. Prior to installing this I was able to play 4k content from Netflix using the TV's built in app, without any stuttering or buffering apparent.  With my old copper connection and previous ISP I was getting 8-10 MBps though I never actually checked to see what speed Netlix was getting as I found the speed was usually less using home plugs due to the number connected and the electrical wiring.


When I try to play any 4k content from netflix now it stutters and breaks up - HD and SD play fine.  I checked the speed that using the built in netflix speed test and it shows a good connection with 37.5 Mbs -  much less than on my computer but as I say I expect this with homeplugs.  (my computer delivers around 180-190 Mbps on the 200 Mbps service so of course Netflix 4k content plays perfectly on my computer)


I am using the same network exactly as before the only difference is the change from my old ASUS modem/router to the Home Hub.  The same homeplugs are being used, and in any event the actual speed is faster than could possibly have been delivered previously.


The only no standard setting is that I changed to open DNS on my PC but did not change anything about the DNS at router level.


I have tried troubleshooting with netflix but they think it must be router issue and that I should try connecting to the fibe model - however the distance involves precludes this.  Does anyone know of any issues with the HomeHub that might be causing this?

Tags (3)
0 Ratings
Recognised Expert
Message 2 of 3

Re: Problem playing 4k content on my smart TV since switching to BT Infinity (Fibre to Home)


It's probably not the hub, though the Hub 6 is getting bad reports just now, seeing as your computer reports the connection is fine it looks like the mains wiring/home plugs is the problem.  Personally I wouldn't use anything other than ethernet cable for the 4K TV.  You can have up to 325 feet of ethernet cable between devices.

I have cat 7 cable from the router to the player connected to the TV,  cat 7 seeing as it's the same price as cat 5.  You can route the cable along skirting around doors etc, no need to drill holes.

0 Ratings
Message 3 of 3

Re: Problem playing 4k content on my smart TV since switching to BT Infinity (Fibre to Home)

I have FTTC with a new Smarthub and had problems with IPTV which I eventually traced to the homeplugs (I bought a long Cat 6 cable to directly connect the box to the router to check). Like you, my homeplugs worked perfectly fine with my previous set up (Homehub 3 then 5). I tried 3 different brands of homeplug and the problem persisted. Running cable was not an option. 


In desperation I installed a wireless access point, connected to the router via homeplugs and use a wired connection to that and now everything runs smoothly.

0 Ratings