Showing results for 
Show  only  | Search instead for 
Did you mean: 
Message 1 of 3

Problem with ethernet connected Xerox printer not reconnecting after BT Hub 6A reboots

Hello, strange problem with a new Xerox C235 printer.

Connected by ethernet DHCP and all was well for a few days until printer showed not connected and could not ping.

Power cycling the printer restored operation, but happened again after a few weeks. Noticed the printer was on a 169.254. IP, which implied it had failed to obtain a 192.168. IP by DHCP.

Then noticed that my issues seems to happen when the Hub is rebooted.

Tried the printer on a fixed IP of .17, but still had loss of connection if the Hub was rebooted. This was very repeatable, and found that the connection could be restored by simply removing and replacing the ethernet cable.

I then tried connecting the printer by wifi, and so far I have not noticed any further problems.

Just wondering if this is a know issue? I would have thought a static IP and ethernet should have been reliable, but looks like some issue with the printer does not like what happens when the Hub reboots.

Many thanks.

0 Ratings
Message 2 of 3

Re: Problem with ethernet connected Xerox printer not reconnecting after BT Hub 6A reboots

Just a couple of thoughts.  My apologies if you’ve already considered them.  It’s not clear how experienced you are.

169.254 is an APIPA address and suggests the printer is not even talking to DHCP.  Have you tried a different cable?  It’s not unheard of for a cable to be faulty.  I’ve even known a dirty pin in the plug to cause intermittent problems like this.

As you seem to be aware, things like printers are usually better on a static IP but .17 seems to be a funny choice.  I’m not familiar with the current Smart Hub.  Does the DHCP range starts above 17?  I take it you are aware the static address cannot be in the range DHCP is issuing, as sooner or later DCHP will give the address to something else.  This often stops one device or the other working.

In my experience problems like this are often when a device goes to sleep.  Possibly the hub can’t see it when it reboots.  It’s usually a firmware issue.  If it’s a new printer, I would make sure it has the latest firmware. 

Having a chat with Xerox’s support would probably be a good idea.

0 Ratings
Message 3 of 3

Re: Problem with ethernet connected Xerox printer not reconnecting after BT Hub 6A reboots

Thanks for your thoughts. I am familiar with ethernet connected networks, but not so much the Hub 6A or the Xerox printer. I have checked the ethernet lead is not the issue.

When set to DHCP, everything works fine until the Hub reboots. When the hub reboots, the printer says is has no connection, and no IP address, as expected. After about 90s it gives up waiting and sets the default IP As the Hub completes booting, the IP sometimes returns to the correct DHCP IP, and all is good, but sometimes it remains stuck on 169.254 ... and so no connection. At this point removing the ethernet lead for a few seconds restores normal working. It looks to me as you said that this is probably a Xerox issue, but probably a combination of how the Xerox behaves and how the Hub 6A reboots.

As I said, a fixed IP did not cure the issue. Just picked .17 as it is outwith the Hub DHCP range 64-253.

The problem occurs when the printer is in Ready mode, ie not in Sleep mode.

I did read somewhere that Xerox printers drop the LAN connection if no comms after a period of time (on fixed IP?) in case there is an IP conflict?? Spent may hours looking for answers on Xerox forums with no definate answers so far.

Agree will probably need to speak to Xerox support, just want to be sure I understand the BT Hub issues first.


0 Ratings