cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
pgregg
Aspiring Contributor
1,307 Views
Message 1 of 4

Smart Hub HH6 Port Forwarding does not work from inside.

I recently (June 1) rejoined BT, having spent a year at Plusnet (with a rebadged HH5), and prior to that with BT (with a HH5 and HH3 previously) on Infinity / FTTC service.

 

I got the Superhub configured the way I wanted* and it seemed to be working ok, with one exception:

- Connections to the DNS (external IPs) for ports were not being passed through the Port Forward to the internal machine.

 

The Port Forward was working fine from outside.

 

If it helps, I run my own SMTPS+TLS and IMAPS+SSL servers, with a custom dynamic DNS system. This worked perfectly well for a number of years with BT. Last year on Plusnet, I had a Static IP, so the dynamic dns was less important (tho I left it running anyway). Again, this worked fine.

 

The reason I need this to work from inside and outside at the same time is mobile devices. All family members have Android or iPhones that have mail setups to use the dynamic dns hostname.   Obviously they also want to access their mail while on the home WiFi network.

For fixed machines/laptops/tablets that don't leave the house - I can bypass the port forward by using the internal IP directly.

 

With the Superhub / Home Hub 6 - this just is not working at all.   Is there something obvious I am missing?

 

For now, I've went back to my old BT HH5 which has been gathering dust this past year - this works perfectly fine.

 

There certainly appears to be a technical change in the HH6 Port Forwarding capabilities.

 

*Differences to normal BT users - I run DHCP from my server, so the hub has it turned off - and I've switched the lan ip/netblock to 172.16.0.1/23

 

Thanks,

PG

0 Ratings
3 REPLIES 3
sjonez
Contributor
1,290 Views
Message 2 of 4

Re: Smart Hub HH6 Port Forwarding does not work from inside.

I've now switched to a 3rd party router but when I had my HH6 NAT loopback worked perfectly fine, so unless there's been a firmware update that has inadvertently broken it I'm not sure why it wouldn't work.

 

Based on some of the stories I've heard about the HH6 you might just be better sticking with the HH5 if it works.

0 Ratings
asif2017
Aspiring Contributor
1,224 Views
Message 3 of 4

Re: Smart Hub HH6 Port Forwarding does not work from inside.

Same issues. I joined BT yesterday.

 

I'm using the Smart Hub 6A with firmware version SG4B10002244

0 Ratings
KamikazeXeX
Beginner
926 Views
Message 4 of 4

Re: Smart Hub HH6 Port Forwarding does not work from inside.

Apologies for bumping a old post, did you ever resolve this issue? (Without getting a 3rd party hub) I've just got a SmartHub through today only to be faced with the same issue, a dynamic dns/browsing to my external ip works perfectly fine outside my home network but as soon as I try to access it from the internal network it doesn't forward me to where I want.

It'd be a shame if this is not something due to a configuration error as loosing NAT loopback is a regression over my old HH5, having to resort to different addresses internally isn't a big issue but it's something I'd rather not have to do, something like this really ruins the 'smart' feeling of the 'Smarthub'.

0 Ratings