cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
togsdragracing
Aspiring Contributor
2,360 Views
Message 1 of 13

TP-LINK Archer C9 disconnects

The last firmware update fiasco decided me to buy a third-party router. Bought a very whizzy TP-LINK Archer C9. No problem at all to set up. After about a month of superb performance it suddenly disconnected from broadband overnight. Restarted, it connected, an hour of great performance then disconnected. It will now do a maximum of one hour before disconnecting from broadband.

 

I am guessing, or given the expense hoping, this is down to some arcane setting somewhere deep in the router (although if so then surely it would have behaved this way from the start). Does anyone have any experience getting a C9 to work on Infinity? Factory reset already tried.

0 Ratings
12 REPLIES 12
gg30340
Distinguished Sage
Distinguished Sage
2,346 Views
Message 2 of 13

Re: TP-LINK Archer C9 disconnects

If you still have your Homehub have you tried to connect that to see if it is a router fault or a line fault?

0 Ratings
togsdragracing
Aspiring Contributor
2,342 Views
Message 3 of 13

Re: TP-LINK Archer C9 disconnects

Yes I am currently having to use my HH5B, 5 GHz quirks and all, and the broadband service is fine. I suspect some kind of config issue on the C9 but it must be something non-intuitive.
0 Ratings
licquorice
Distinguished Sage
Distinguished Sage
2,331 Views
Message 4 of 13

Re: TP-LINK Archer C9 disconnects

Why would it be a config issue if it has been working fine and you haven't changed anything. It's either a faulty router or faulty line.

0 Ratings
gg30340
Distinguished Sage
Distinguished Sage
2,324 Views
Message 5 of 13

Re: TP-LINK Archer C9 disconnects


@licquorice wrote:

Why would it be a config issue if it has been working fine and you haven't changed anything. It's either a faulty router or faulty line.


You beat me to it. Smiley Wink

 

Obviously not a faulty line if the HH5 works OK. Must be a faulty router.

0 Ratings
togsdragracing
Aspiring Contributor
2,316 Views
Message 6 of 13

Re: TP-LINK Archer C9 disconnects

The reason I mentioned config is that having had a trawl around the web I have seen that some other TP-LINK routers have needed config changes to work with BT Infinity. Pretty logical assumption that the C9 might be the same. Or so I thought.

0 Ratings
licquorice
Distinguished Sage
Distinguished Sage
2,309 Views
Message 7 of 13

Re: TP-LINK Archer C9 disconnects


@togsdragracing wrote:

The reason I mentioned config is that having had a trawl around the web I have seen that some other TP-LINK routers have needed config changes to work with BT Infinity. Pretty logical assumption that the C9 might be the same. Or so I thought.


Hardly,  if it's previously been working. If it's a problem with the config it would never have worked.

0 Ratings
gg30340
Distinguished Sage
Distinguished Sage
2,308 Views
Message 8 of 13

Re: TP-LINK Archer C9 disconnects

If it was working OK on Infinity for a month previously and you have not made any changes it seems unlikely that the router would have made any changes on its own unless it was a pushed update from the manufacturer.

 

I would find it strange if any pushed update did change the configuration and in any event a factory reset would have restored it to the default settings which you found previously worked. I don't know if TP-Link push updates or if you have to install them yourself.

0 Ratings
licquorice
Distinguished Sage
Distinguished Sage
2,306 Views
Message 9 of 13

Re: TP-LINK Archer C9 disconnects

TP Link don't push updates.

gg30340
Distinguished Sage
Distinguished Sage
2,303 Views
Message 10 of 13

Re: TP-LINK Archer C9 disconnects

I suspected that would be the case. Thanks for clarifying.

0 Ratings