cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
MED1975
Aspiring Contributor
3,023 Views
Message 1 of 10

TP-Link TD-W9980 - Multicast working?

Go to solution

Based on information read on these forums I have purchased a TP-Link TD-W9980 to replace my HH 5. I have set the modem/router up using the built in profile VDSL_BT and can connect to the internet etc - much more stable than the HH.

 

Now I was lead to believe (and some posts do seem to confirm this) that this modem/router combo will also work with YouView and give me access to the additional internet channels, iPlayer etc - this is currently not working! Those that do have this fully working did you have to do anything else in the configuration?

 

I am running the most recent firmware released - published on 150507. Do I need to downgrade the firmware to get this going? Is anyone on the current firmware level and got full YouView access?

 

The only thing I can note is that I don't know what the firmware level was when it was purchased - but I set it using the quick config and then did a firmware update. I guess its possible that I need to restore to factory so that it is at the most recent firmware and set up from scractch again - in case I have carried over a big somewhere along the lines.

 

The firmware published 141215 does specifically mention YouView working in its release notes so I am hoping it is possible.

 

Comments and help please people! Thanks in advance...

0 Ratings
9 REPLIES 9
Steve_M
BT TV Expert
3,017 Views
Message 2 of 10

Re: TP-Link TD-W9980 - Multicast working?

Go to solution

Have you made sure that the "Enable IGMP proxy" setting is selected?

 

Steve

MED1975
Aspiring Contributor
3,015 Views
Message 3 of 10

Re: TP-Link TD-W9980 - Multicast working?

Go to solution
Thanks for pitching in - this is definitely enabled by default when using the VDSL_BT profile.
0 Ratings
Steve_M
BT TV Expert
3,012 Views
Message 4 of 10

Re: TP-Link TD-W9980 - Multicast working?

Go to solution

Hmm, I think you're right then, try firmware version "0.6.0 1.10 v0021.0 Build 141215 Rel.41342n" like @Automan

MED1975
Aspiring Contributor
3,010 Views
Message 5 of 10

Re: TP-Link TD-W9980 - Multicast working?

Go to solution
Will give that a try tonight and feedback. Thanks.
0 Ratings
scointer
Recognised Expert
3,006 Views
Message 6 of 10

Re: TP-Link TD-W9980 - Multicast working?

Go to solution
I have this router and it works fine with BT TV. I have had both sets of Firmware and both work fine also. Using the May version (150507) at the minute without issue. I didn't need to set anything up just used the BT profile. If you are having trouble with all internet activity through the YouView box (not just multicast channels) you might need to check the internet connection in the YouView box settings and maybe the ISP configuration on the software in the YouView box.
Steve_M
BT TV Expert
3,002 Views
Message 7 of 10

Re: TP-Link TD-W9980 - Multicast working?

Go to solution

Thanks Scointer, Do you use an Openreach Modem or the inbuild VDSL modem?

 

Steve

0 Ratings
scointer
Recognised Expert
2,997 Views
Message 8 of 10

Re: TP-Link TD-W9980 - Multicast working?

Go to solution
The inbuilt VDSL modem
MED1975
Aspiring Contributor
2,994 Views
Message 9 of 10

Re: TP-Link TD-W9980 - Multicast working?

Go to solution
That is reassuring! I'm going to factory reset it tonight and see if that gets it going - the only thing I am adding to the WAN setup is the SPI firewall being enabled.
0 Ratings
MED1975
Aspiring Contributor
2,964 Views
Message 10 of 10

Re: TP-Link TD-W9980 - Multicast working?

Go to solution

I reset the router to factory last night but I was still unable to receive YouView internet channels etc. I decided to factory reset the YouView box and following that everything is working as expected - I am very happy with the router.

0 Ratings