cancel
Showing results for 
Search instead for 
Did you mean: 
nigma
Contributor
16,891 Views
Message 1 of 11

UPnP Unreliable on Home Hub 2.0

Hi,

 

I make use if the upnp feature of the modem to enable me to stream music and videos to my dlna/upnp TV and PS3. Using other routers (Thompson and Netgear), the media server is discovered right away and I can happily stream my content around the home.

However, using the BT homehub v2.0 is very unreliable 9 times out of 10 the media sever is not discovered on my players and I have to try a number of different things to be able to see my server.

  1. I have to restart the media player
  2. I have to restart the media server software
  3. I have to restart the homehub

Some times it's a some or all of the above that I need to perform to get it working.

 

It is definitely an issue with the home hub as it works fine with other routers, it has the same issue with different media server software (windows media player, twonky) and it also has the same issue with both my TV and PS3.

 

I have also searched around on the  net with this issue, and I am not the only one experiencing this. It really is a pain when I simply want to switch it on and watch something. Instead i have to run around my house switching things on and off.

 

Thanks,

Anand

0 Ratings
10 REPLIES 10
utopian
Contributor
16,880 Views
Message 2 of 11

Re: UPnP Unreliable on Home Hub 2.0

i had the same problem..with roku soundbridges being unable to see my itunes shre on my WHS.. i put everthing thru a seperate hub which hangs off the HH... the HH only has the adsl connection..everything working fine now...

0 Ratings
Goody
Aspiring Expert
16,868 Views
Message 3 of 11

Re: UPnP Unreliable on Home Hub 2.0

That is the simplest solution. Connect your hub into a switch/ router and connect everything else into that switch/ router. That still keeps everything connected to the internet but all your local equipment will not go through the HH unless it is trying to use the internet.

I have a PS3 and a couple of Kiss dvd players hooked up that way and have no issues with it.

0 Ratings
r1sh12
Expert
16,856 Views
Message 4 of 11

Re: UPnP Unreliable on Home Hub 2.0

Hi,

I had a similar problem.

So just check that the homehub hasnt put your PS3 to a strict NAT type.

If it has, the quickest way to fix this is to reset the HH to default settings.

Make all the changes to your settings so they resemble the same way they used to.

Now look under the home network find your PS3's mac code. Click it and open the

device information, look at the bottom and click the tick box Always use this IP address.

Now your HH should lock the PS3 into an open nat type, and all should be well.

I spent a solid hour with BT head of tech support about this.

It should be a permanent fix.

Although I am using windows 7 and the PS3 picks up my PC and all the media on it very easily.

Hope that helps, let me know if it does or doesnt.

0 Ratings
Highlighted
Ruthus
Beginner
16,394 Views
Message 5 of 11

Re: UPnP Unreliable on Home Hub 2.0

Having similar issues. I recently changed from a white to a black HH and this has broken my network. PS3 will no longer discover my Netgear media server using the wireless connection. If I temporarily drag a real ethernet cable across the house it comes up first time. If the media server transmits its "i'm here" signal the PS3 sees it over wireless.

 

I have uPnP box ticked but the only conclusion I can see is that the wireless bridge inside the HH is somehow filtering uPnP traffic

Tags (1)
0 Ratings
Sweeney47
Aspiring Expert
16,378 Views
Message 6 of 11

Re: UPnP Unreliable on Home Hub 2.0

I have trouble with the UPnP as well especially when it comes to games, requires me to manually do ports etc all the time...

 

Sometimes it will work with a certain game then a couple of hours later it will stop. I've got to the point where I dont rely on it anymore and automatically put ports etc in before attempting it...

0 Ratings
dersam
Contributor
16,028 Views
Message 7 of 11

Re: UPnP Unreliable on Home Hub 2.0

I'm running Twonky Media and have also been struggling with this.

 

If you restart the server you can see it on all devices on the network, but once you leave it for 5-10 mins and then search for it, not a single device can see the server!!  Very very frustrating......and very poor considering it's a "MEDIA" hub Smiley Mad

0 Ratings
jamesok
Newbie
15,729 Views
Message 8 of 11

Re: UPnP Unreliable on Home Hub 2.0

I had similar issues trying to connect my philips TV (NET TV) through my new home hub 2.0

 

Never had any issues with a netgear router and devolo dLAN duo, but having moved house it was a nightmare.

 

i'm no expert, but had to go into http://bthomehub.home/ and change advanced settings:

 

Application Sharing > UnPNP - switched off

 

then added the following under application sharing to my device (philips):

 

Direct Connect    
DirectX 7    
DirectX 8    
DirectX 9    
FTP    
HTTP Server (World Wide Web)    
HTTPS
Secure Web Server (HTTPS)            
Web Server (HTTP)

 

and... it works...

0 Ratings
judge-jules
Newbie
12,400 Views
Message 9 of 11

Re: UPnP Unreliable on Home Hub 2.0

I know this is an old post but I had been having problems streaming webcasts from work to my laptop via my home hub. I made the changes Jamesok suggested and it now works.

 

So for webcast problems just check that the advanced settings on the bthomehub are modified.

 

 

0 Ratings
canuhelpme
Beginner
11,363 Views
Message 10 of 11

Re: UpNpUnreliable on Home Hub 2.0

I've tried the solution suggested by jamesok and a good few others, none has worked to connect my Philips Sound Hub Home Theatre  to my PC via a home hub 2.  It all seems to be related to upnp. I can receive Net TV through the system from a dedicated Philips portal but cannot stream data from Media Player on the PC to the TV.  It's supposed to be very simple!!

0 Ratings