cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
the_prime
Aspiring Contributor
1,681 Views
Message 61 of 128

Re: VC017

I finally solved my VC017 problem. It is a Silverlight problem. I tried using the Silverlight uninstall Fix It, but it didn't work (although I didn't reboot after fixing it). I searched the Web and found an Apple Mac users' discussion about this. I use Windows though and I couldn't find some of the PC folders they mentioned. 

 

Basically, the solution on the Apple discussion was about completely removing Silverlight and Playready before reinstalling Silverlight.  All of the following steps might not be necessary. I don't know much about programs, I'm just saying what worked for me (since there was no solution here).

 

  1. I used the Microsoft Fix-It to remove Silverlight, but didn't click "Install" yet.
  2. I went to C:\Program Data\Microsoft\PlayReady  and deleted the file in there.
  3. I went to C:\Users\"your username"\AppData\
  4. I clicked on each folder in the Appdata one and looked for a subfolder that said Microsoft or Silverlight.
  5. I deleted ones that said Silverlight. I deleted any "PlayReady" subfolder I saw inside the Microsoft ones.
  6. I went back to the Fix It program and pressed Install.
  7. I rebooted after installation.
  8. After that, the BTSport channels worked.

The Program Data folder might be a hidden folder on your PC. If so go to Control Panel and click, or search for Folder Options. You'll be able to show or hide hidden folders.

 

---------------------------------------------------------------------------------------------------------------------------

 

I've given that a go, and unfortunately it didn't work for me.

I even went as far to search for any other silverlight files on my PC and delete them as well.

It maybe, for some people, something deeper than this.

0 Ratings
DAUDane
Aspiring Contributor
1,671 Views
Message 62 of 128

Re: VC017

The above fix didn't work for me, either. I made sure every file or directory reference to silverlight and playready were removed before two reboots and silverlight reinstallation, but still VC017.

0 Ratings
Stuartg69
Beginner
1,623 Views
Message 63 of 128

Re: VC017

I can watch on my ipod and my sons basic tablet with no problems, occasional 6010 max number of streams. Have found various menus slightly hidden on pad and tablet which eventually lead to a logout option. As soon as i do that message disappears.

 

Cannot get rid of vc017 on my pc - have tried various previous suggestions from above. Tried on my dads pc at his house and it came up 6025, refreshed the screen and tried again and it worked. We both have IE 10, latest version of silverlight and windows 7 service pack 1 - only difference is his hub is an older version. So problem is individual to specific pcs, but no one seems to know what on earth it is.

0 Ratings
CapnPatch
Beginner
1,588 Views
Message 64 of 128

Re: VC017

Still waiting for one of you clever people to come up with an answer, since BT people are all busy watching the share price.  At least I now know how everyone else knows it's a Silverlight issue - when I right-click on the Watch Button of Death, the word "Silverlight" pops up!

0 Ratings
CapnPatch
Beginner
1,540 Views
Message 65 of 128

Re: VC017

It certainly looks like somebody was redeployed too soon.  If you view page source and scroll down to line 2365 you see this:    

 

//TODO: handle error scenario

 

Are there any other clues hidden in this code?

 

0 Ratings
cjkathome
Beginner
1,391 Views
Message 66 of 128

Re: VC017 update

Hi

Just an update

I finally got through to BT technical helpline yesterday after about an hour - but as yet unfortunately they have not worked out what is causing VC017 error message. They suggested restarting my PC and hub but I knew that was not the problem - as my son can watch fine from his PC in his room - which is further from the hub than our main family PC

I have eliminated several issues

It does not appear to be a browser issue - my son can watch using both Windows Explorer and Firefox

I have the latest version of Silverlight and Flash - so that is not causing the probelm

 

Incidentally I found it very frustrating the hlepline telling me to do things I knew would not resolve the problem.

I would have preferred a little honesty and someone admitting it was a fault at their end / in the system.

I'm amazed all this was not tested out on a rnage of home PCs before the launch.

So come on BT  help us all out and find a solution soon - we are dying to watch!

 

 

0 Ratings
mollydog
Aspiring Contributor
1,385 Views
Message 67 of 128

Re: VC017

I couldn`t open "App Data" did everything else but no luck.

Do BT look at these forums I wonder?

0 Ratings
Kimbell
Beginner
1,317 Views
Message 68 of 128

Re: VC017

A few observations if I may :

Silverlight seems to be the problem and from what I can make out its to do with the DRM on B.T.s App. Silverlight appears not to be able to get the right permissions. This is a silverlight problem and not directly a B.T. one. However as B.T. insist we use Silverlight then they should be responsible for making sure they have given the right permissions.Another point is in my experience of forums this is neither run by, maintained, or moderated by real B.T. employee's.

0 Ratings
alan42
Beginner
1,300 Views
Message 69 of 128

Re: VC017

Clue?

It works for me on wireless connected pc's, but not on wired connected (to the same BT infinity connection of course)

0 Ratings
TryingNot2Swear
Beginner
1,182 Views
Message 70 of 128

Re: VC017

It seems the Silverlight error code is an important factor in solving the VC017 problem. I got 6025 on the device that I fixed. I tried another device and got 6205. So, I tried the tips that others gave on this thread. Nothing worked, so I tried my solution. It didn't work either, but I got the error code 6000.

 

I searched for a solution for the Silverlight 6000 error and saw that it's something to do with DRM (Digital Rights Management). Unfortunately, my bookmark for the solution page didn't save. Basically, it directed me to this page.

 

http://www.microsoft.com/en-gb/download/details.aspx?id=21772

 

I installed (or probably re-installed) PlayReady and that fixed the problem for me. It took a lot of searching, but eventually I found a solution that worked. I don't really know what I'm doing, I just searched for a solution to my Silverlight error code (6000 this time). It might work for other error codes related to DRM too (I don't know).

 

 

 

 

0 Ratings