cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Evil_Dan
Aspiring Contributor
536 Views
Message 1 of 2

WARNING: Smart Hub failing to allocate IP address to some devices

I'm afraid I was tricked into signing a 18 month contract to get a new Smart Hub and deeply regretting not just taking the 12 month contract and buying a separate router/modem device.

 

Despite restarting/reseting to factory and reseting network settings, on some devices (mainly my WiFi Epsom printer and iOS devices) it will connect to the WiFi (I get a tick in the device settings but nothing in the internet settings boxes) but the Smart Hub will simply not allocate it an IP address.  It doesn't matter if this is 2.4GHz or 5GHz networks (tried both split and same networks) and it will still not allocate an IP address.  This seems to be a recurring problem here.

 

I'm posting this as a warning to others who might be undecided between taking the 18m contract to get the Smart Hub and just a 12m contract.  Does anyone have a suggestion other than buy another router, which seems to be the only solution so far?

 

Think I'll be contacting BT Monday to take the Smart Hub away and drop me back to a 12m contract unless anyone can offer a solution.  Many thanks.

0 Ratings
1 REPLY 1
jparnell82
Aspiring Expert
476 Views
Message 2 of 2

Re: WARNING: Smart Hub failing to allocate IP address to some devices

As a workaround can you set a static IP address on the device?
0 Ratings