Showing results for 
Show  only  | Search instead for 
Did you mean: 
Aspiring Contributor
Message 1 of 3

Wake On Lan does not work after a while

Go to solution



I'm trying to get WOL to work on my home server, connected to the first lan port on my bt smarthub (home hub 6?)


What I have :


-> My motherboard is able to do WOL (Msi b150i pro) and is correctly set.

-> I can sniff the magic packets with a software.

-> I can wake the server from a shutdown state shortly after shutting it down, by sending a magic packet to the BT smarthub broadcast address ( So, it works.

-> If I wait too long however, the computer will NOT wake up.


But here's why I know it's the BT smarthub fault :


-> I have another router on my network, connected to the bt smarthub, for a better wifi.

-> If, when my server refuses to wake up, I unplug it and plug it to this other router, and send a magic packet to its broadcast address (, it will then turn on, yaaay.

-> But if I just unplug it from the BT smarthub, and then plug it again to the BT Smarthub, nothing.


It's like the BT smarthub does not broadcast the magic packet. I don't know why it works shortly after shutting down the server though, maybe thanks to the mac address the BT smarthub keeps in memory for a short while?


Any help is appreciated,


Thank you very much

Tags (3)
0 Ratings
Distinguished Sage
Distinguished Sage
Message 2 of 3

Re: Wake On Lan does not work after a while

Go to solution

Dump the Smart (sic) hub and get a proper router.

0 Ratings
Aspiring Contributor
Message 3 of 3

Re: Wake On Lan does not work after a while

Go to solution

Nevermind, I finally found the solution myself. (I've been searching for days, now...)


The sender of the magic packet needs to be ON THE SAME SUBNET than the server to wake up.


Seems obvious, but I was trying to wake it up from my smartphone which was connected wirelessly to this other router I talked about.


The thing is, I can ping my server's subnet from my wireless subnet, so I didn't think it was the issue.


But apparently it is :


-> As once again, my server refused to wake up, I re-enabled wifi on my BT smarthub, I connected my smartphone to it, send the magic packet to the broadcast adress and sure enough, the server woke up instantly.


It only worked shortly after because the router kept the mac address in memory.


I'm gonna try some things to keep my other wifi, but atleast now I know what caused all of this... =')


I hope it will help someone!


Have a nice day

0 Ratings