cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
BikerDon
Contributor
2,520 Views
Message 1 of 11

WebAdvisor not working any more?

Windows 7

McAfee WebAdvisor 5.0.540.0

Firefox 54.0.1 (32-bit)

Chrome 57.0.2987.133

IE 11.0.43

 

I don't get the green ticks against links on web pages any more in Firefox.

The McAfee icon top-right changes colour as I change web site as expected

It used to work fine.

Works OK in Chrome.

Doesn't appear to work in IE either - I'm not an IE user so I may have left something out but I have enabled it as instructed

 

The Add-on is enabled in Firefox

 

I searched on here before posting but the threads I found are old, 2010, 2014, 2015 etc

 

Any suggestions please?

Rgds

Don

 

0 Ratings
10 REPLIES 10
2,505 Views
Message 2 of 11

Re: WebAdvisor not working any more?


@BikerDon wrote:

Windows 7

McAfee WebAdvisor 5.0.540.0

Firefox 54.0.1 (32-bit)

Chrome 57.0.2987.133

IE 11.0.43

 

I don't get the green ticks against links on web pages any more in Firefox.

The McAfee icon top-right changes colour as I change web site as expected

It used to work fine.

Works OK in Chrome.

Doesn't appear to work in IE either - I'm not an IE user so I may have left something out but I have enabled it as instructed

 

The Add-on is enabled in Firefox

 

I searched on here before posting but the threads I found are old, 2010, 2014, 2015 etc

 

Any suggestions please?

Rgds

Don

 


This was once a common problem with McAfee after an update.....

In the Windows 7  search bar search for "services".

you may find "services.msc" or similar.

Check from the various options in that screen that Site (web) Advisor is enabled.

0 Ratings
BikerDon
Contributor
2,490 Views
Message 3 of 11

Re: WebAdvisor not working any more?

Is this what you mean?

 

 

services.msc output.jpg

0 Ratings
2,476 Views
Message 4 of 11

Re: WebAdvisor not working any more?


@BikerDon wrote:

Is this what you mean?

 

 

services.msc output.jpg


Yes, that's site adviser.

Sometimes an update can make it inactive.

You could try setting it to Automatic, without delay.

 

As alternative approach, (I use another Antivirus service - very similar) a simple refresh screen command sometimes prompts it into action.

Try the direct method first, though - auto without delay. Sometimes that change may prompt it.

0 Ratings
BikerDon
Contributor
2,458 Views
Message 5 of 11

Re: WebAdvisor not working any more?

>> You could try setting it to Automatic, without delay.

I set it to Automatic (no delay) but on restart it has been reverted back to Automatic (with delay)

I tried several times to make sure - all to no avail, the problem still exists

 

 

>> As alternative approach, (I use another Antivirus service - very similar) a simple refresh screen command sometimes prompts it into action.

To ensure the page is reloaded from the server not the cache I did several Shift-refresh and Ctrl-F5 - all to no avail, the problem still exists

 

 

0 Ratings
2,452 Views
Message 6 of 11

Re: WebAdvisor not working any more?


@BikerDon wrote:

>> You could try setting it to Automatic, without delay.

I set it to Automatic (no delay) but on restart it has been reverted back to Automatic (with delay)

I tried several times to make sure - all to no avail, the problem still exists

 

 

>> As alternative approach, (I use another Antivirus service - very similar) a simple refresh screen command sometimes prompts it into action.

To ensure the page is reloaded from the server not the cache I did several Shift-refresh and Ctrl-F5 - all to no avail, the problem still exists

 -------------------------------

I did of course mean to refresh the page in the browser search.

Sometimes this activates the Adviser icons, (in my case the N.....n safe search icons) as McAfee has more time to make the delayed action.

 

Is it the full version of McAfee or the BT web Protect version?

I haven't used McAfee for some years, but would be tempted to use the removal tool and reinstall, either the BT or full version.

 

It was the universal fix, and still  is for other internet security apps. 

0 Ratings
2,442 Views
Message 7 of 11

Re: WebAdvisor not working any more?

More information.........McAfee changed the name of site adviser to webadviser.

Do a search on the McAfee support website.

The adviser doesn't work on IE 11, but does work with Firefox and chrome.

That's as it was in 2016, ...........but things change......

 

However there's vague mention of uninstall, use McAfee removal tool, and then Firefox, chrome may work.

0 Ratings
BikerDon
Contributor
2,427 Views
Message 8 of 11

Re: WebAdvisor not working any more?


@Ribblelancs wrote:

@BikerDon wrote:

>> You could try setting it to Automatic, without delay.

I set it to Automatic (no delay) but on restart it has been reverted back to Automatic (with delay)

I tried several times to make sure - all to no avail, the problem still exists

 

 

>> As alternative approach, (I use another Antivirus service - very similar) a simple refresh screen command sometimes prompts it into action.

To ensure the page is reloaded from the server not the cache I did several Shift-refresh and Ctrl-F5 - all to no avail, the problem still exists

 -------------------------------

I did of course mean to refresh the page in the browser search.

Sometimes this activates the Adviser icons, (in my case the N.....n safe search icons) as McAfee has more time to make the delayed action.

 

Is it the full version of McAfee or the BT web Protect version?

I haven't used McAfee for some years, but would be tempted to use the removal tool and reinstall, either the BT or full version.

 

It was the universal fix, and still  is for other internet security apps. 


>> I did of course mean to refresh the page in the browser search.

What do you mean by 'browser search'? A Google search in a browser?

I refreshed the page once the Google results appeared.

 

>> (in my case the N.....n safe search icons)

I have no idea what you mean by that

 

>> as McAfee has more time to make the delayed action

What delayed action?

 

>> Is it the full version of McAfee or the BT web Protect version?

BT Web protect version. That's why I came to the BTCare Community Forums

 

>> I haven't used McAfee for some years, but would be tempted to use the removal tool and reinstall

The McAfee site says to use Windows uninstall and only use the tool if that doesn't work

 

 

0 Ratings
2,416 Views
Message 9 of 11

Re: WebAdvisor not working any more?


@BikerDon wrote:

@Ribblelancs wrote:

@BikerDon wrote:

>> You could try setting it to Automatic, without delay.

I set it to Automatic (no delay) but on restart it has been reverted back to Automatic (with delay)

I tried several times to make sure - all to no avail, the problem still exists

 

 

>> As alternative approach, (I use another Antivirus service - very similar) a simple refresh screen command sometimes prompts it into action.

To ensure the page is reloaded from the server not the cache I did several Shift-refresh and Ctrl-F5 - all to no avail, the problem still exists

 -------------------------------

I did of course mean to refresh the page in the browser search.

Sometimes this activates the Adviser icons, (in my case the N.....n safe search icons) as McAfee has more time to make the delayed action.

 

Is it the full version of McAfee or the BT web Protect version?

I haven't used McAfee for some years, but would be tempted to use the removal tool and reinstall, either the BT or full version.

 

It was the universal fix, and still  is for other internet security apps. 


>> I did of course mean to refresh the page in the browser search.

What do you mean by 'browser search'? A Google search in a browser?

I refreshed the page once the Google results appeared.

 

>> (in my case the N.....n safe search icons)

I have no idea what you mean by that

 

>> as McAfee has more time to make the delayed action

What delayed action?

 

>> Is it the full version of McAfee or the BT web Protect version?

BT Web protect version. That's why I came to the BTCare Community Forums

 

>> I haven't used McAfee for some years, but would be tempted to use the removal tool and reinstall

The McAfee site says to use Windows uninstall and only use the tool if that doesn't work

 

 


Other internet security products use Safe Web, which applies a green, red, or unknown icon against each search result in the listing.

Sometimes there's a delay in the display of these ratings, and a quick Refresh Display fixes this.

Your own Web Advisor as shown, appears to have a delayed start. Hence the suggestion to remove the delay, or alternatively to refresh the screen in a search.

 

When I was using McAfee, this feature was troublesome and no amount of system restore, uninstall reinstall from control panel would fix it.

If you uninstall from the conrol panel then McAfee Total uninstall will remove any remnants....Then reinstall.

 

McAfee / (BT McAfee) is a troublesome utility, but you appear to have had it working successfully at some time. It's worth perservering.

Is Windows 7 up to date?

0 Ratings
BikerDon
Contributor
2,404 Views
Message 10 of 11

Re: WebAdvisor not working any more?

>> Your own Web Advisor as shown, appears to have a delayed start. Hence the suggestion to remove the delay, or alternatively to refresh the screen in a search.

 

The delayed start is nothing at all to do with the appearance or not of the flags.

The delayed start means the service starts when Windows starts but is delayed until after Login is completed so as to not interfere or slow down the login process.

 

>> you appear to have had it working successfully at some time

It has worked ever since I installed it several years(?) ago until recently

 

>> Is Windows 7 up to date?

Of course, as is all my software despite updates killing things on occasion, possibly as is the case here

 

 

0 Ratings