cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
saffaripioneer
Beginner
1,663 Views
Message 1 of 9

Wifi Works ok but no ethernet connection on Home Hub 4

I have recently updated to a BT Home Hub 4 and having problems getting the internet through my ethernet network.

The wifi is working fine and after running the Network Diagnostics on my iMac it comes up saying your connection appears to be working correctly.

(All the lights on the diagnostics are coming up green. Ethernet, Network Settings , ISP , Internet , Server all green.)

 

I have used various 500 Mbps Powerline Adapters and ethernet cables but still no good when I switch WiFi off it keeps telling me that I am not connected.


I have been on to BT (my service provider) who initially got the ethernet working after about 1 hour but when switched wifi off same problem saying I am not connected even though all the lights are on green.


BT are suggesting that it is a problem with my iMac and that I should get onto Apple but I have been using it fine with the old Hub for a number of years.

Saffaripioneer
0 Ratings
8 REPLIES 8
stevebrass
Expert
1,655 Views
Message 2 of 9

Re: Wifi Works ok but no ethernet connection on Home Hub 4

if you click on the Wifi icon on yur Mac (top right) and go for networl preferences does it show ethernet on the right hand pane?

If you like a post, or want to say thanks for a helpful answer, please click on the Ratings icon. If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted solution’
0 Ratings
saffaripioneer
Beginner
1,648 Views
Message 3 of 9

Re: Wifi Works ok but no ethernet connection on Home Hub 4

Yes it shows ethernet on the right hand pane and says that it is connected ----  But it still is not.

Saffaripioneer
0 Ratings
stevebrass
Expert
1,625 Views
Message 4 of 9

Re: Wifi Works ok but no ethernet connection on Home Hub 4

And if you click on it does it at connecting through DHCP?

If you like a post, or want to say thanks for a helpful answer, please click on the Ratings icon. If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted solution’
0 Ratings
saffaripioneer
Beginner
1,596 Views
Message 5 of 9

Re: Wifi Works ok but no ethernet connection on Home Hub 4

Sorry that I have not been able to get back sooner but I was working
all day Sunday and unable to reply

 

On the left Hand Pane under Ethernet it has a green light and says it is connected

On the right Hand Box is says
Status Connected
Ethernet is currently active and has the IP address 192.168.1.201
Configure IPV4: Using DHCP with manual address (This is what BT specified to put)
IP Address 192.168.1.201
Subnet Mask 255.255.255.0

Saffaripioneer
0 Ratings
Keith_Beddoe
Distinguished Sage
Distinguished Sage
1,594 Views
Message 6 of 9

Re: Wifi Works ok but no ethernet connection on Home Hub 4

You also need default gateway 192.168.1.254     That gives access to the Internet

and DNS server 192.168.1.254

 

If all else fails, try the following IPv4  settings.

 

IP address 192.168.1.50
Subnet Mask 255.255.255.0
Default Gateway 192.168.1.254
DNS Server 192.168.1.254

0 Ratings
stevebrass
Expert
1,585 Views
Message 7 of 9

Re: Wifi Works ok but no ethernet connection on Home Hub 4

As Keith says, or change the setting to "using DHCP"

If you like a post, or want to say thanks for a helpful answer, please click on the Ratings icon. If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted solution’
0 Ratings
Dode
Expert
1,575 Views
Message 8 of 9

Re: Wifi Works ok but no ethernet connection on Home Hub 4

A small point to Keith's post above, the Mac may not say 'Default Gateway' but 'Router' instead.

0 Ratings
Dode
Expert
1,573 Views
Message 9 of 9

Re: Wifi Works ok but no ethernet connection on Home Hub 4

Something else to try. In the left hand pane where the green lights are Ethernet should be at the top. If not go to the wheel at the bottom, select (you may have to unlock with your password etc.) and select Set Service Order. In the dropdown box drag Ethernet to the top. Once that is OK try switching Wifi on and off again.

0 Ratings