cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Zantos
Aspiring Contributor
2,194 Views
Message 1 of 18

iPhone 7 to Home Hub 6

Go to solution

I can't connect my iPhone 7 at 5G to the HH6, it keeps telling me I have the wrong password when I run 2/5 as seperate channels. If I join the channels the phone connects (same password) BUT only at 2G The name for the second channel seems a little strange as "-5" perhaps this is a problem - I don't know BUT HH5 always connected with no problems, perhaps I shouldn't have bothered to uprade to HH6 and renew for 18 months!

Anyone else have this problem or a solution before I cancel my new contract.

0 Ratings
17 REPLIES 17
imjolly
Distinguished Sage
Distinguished Sage
2,184 Views
Message 2 of 18

Re: iPhone 7 to Home Hub 6

Go to solution

if you have split the networks then you need to sign the iphone into both networks separately  you don't need to do this if they are joined

 

ie  select the 5g network and connect it will ask for password and when you enter it will connect and save it

 



If you like a post, or want to say thanks for a helpful answer, please click on the Ratings 'Thumbs up' on left hand side.
If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.
0 Ratings
Zantos
Aspiring Contributor
2,162 Views
Message 3 of 18

Re: iPhone 7 to Home Hub 6

Go to solution

If only it were that simple !

Trying to log in to a seperated 5G with the name - "-5" and the same password just gets incorrect password every time. Have now tried wife's Samsung S8 and the HH6 says it has signed in (when channels are joined) to the 5G network BUT the smasung just displays "connecting" and goes no firther just showing the revolving circle!

0 Ratings
awbb92
Beginner
2,152 Views
Message 4 of 18

Re: iPhone 7 to Home Hub 6

Go to solution
Have you tried resetting the network settings on the iPhone?
0 Ratings
Zantos
Aspiring Contributor
2,141 Views
Message 5 of 18

Re: iPhone 7 to Home Hub 6

Go to solution

Tried resettin everything - interesting thing was that the button on the back of the hub had NO EFFECT when pressed - I had to do a "morse code" tap on it before it eventually did a reset and cleared all my settings. iPhone and Samsung both connect successfully to the HH5 (haven't returned it yet) but NOTHING will connect successfully on 5GHz band - Samsung says "connecting" but doesn't (although hub says 5GHz beside it's icon) iPhone repeatedly says it has wrong password.

 

0 Ratings
imjolly
Distinguished Sage
Distinguished Sage
2,122 Views
Message 6 of 18

Re: iPhone 7 to Home Hub 6

Go to solution

if both phones are having similar problems and you held reset button until light flashed then I would contact customer services and ask for replacement HH6



If you like a post, or want to say thanks for a helpful answer, please click on the Ratings 'Thumbs up' on left hand side.
If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.
0 Ratings
dgw1
Aspiring Expert
2,112 Views
Message 7 of 18

Re: iPhone 7 to Home Hub 6

Go to solution

When ever I experienced "wrong password", when it wasn't, it has been down to wifi channel interference.

0 Ratings
imjolly
Distinguished Sage
Distinguished Sage
2,109 Views
Message 8 of 18

Re: iPhone 7 to Home Hub 6

Go to solution

have you tried change the wifi mode in the HH6



If you like a post, or want to say thanks for a helpful answer, please click on the Ratings 'Thumbs up' on left hand side.
If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.
0 Ratings
Zantos
Aspiring Contributor
2,099 Views
Message 9 of 18

Re: iPhone 7 to Home Hub 6

Go to solution

Tried mode 3 - no different

 

0 Ratings
Bluebird99
Aspiring Contributor
2,079 Views
Message 10 of 18

Re: iPhone 7 to Home Hub 6

Go to solution
At last! Someone who’s had the same problem as me! I recently recontracted and got a Smart Hub thrown in as an upgrade to my (still working but aging) HH5. The Smart Hub arrived, but I couldn’t log into Wi-fi and like the OP kept getting incorrect password or unable to join network. I occasionally got connected and was able to split the SSID. The hub allowed me to connect to 2.4ghz but always got incorrect password on 5ghz. If I reset the hub, it went back to not allowing me to connect at all. Tech support was essentially useless and because I had a blue light and a line test showed no fault. No amount of resets or changing Wi-fi modes or channels is going to do anything - it didn’t do anything to help me, apart from extend the agony. Thankfully after many phone calls, eventually got through to a nice lady in Cardiff who helped me trick the line test into thinking the hub was faulty. A problem with Royal Mail meant I ended up being sent two new Smart Hubs! The first, oddly worked well for a few hours before 5ghz died (multiple devices unable to see 5ghz). 2nd replacement has, touch wood, been fairly stable, but yet to be convinced it’s better overall than my HH5. So, to the OP I would suggest not wasting anymore time trying to get it to work - it’s one of the seemingly many faulty Smart Hubs. I would suggest putting your effort into getting BT to send you a replacement Smart Hub. Btw, I too was using Apple devices, including an iPhone 7 - it’s not the devices! I think what was frustrating was the fact i’m fairly technically savvy but my first hub just would not connect through Wi-fi. It was a strange feeling to plug in the replacements and see them doing what they should do out of the box (even if the first replacement died!). Some of the various BT employees I spoke to across the globe hinted at the issues with Smart Hub. Clearly a significant number of faulty ones I think.
0 Ratings