cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
smf22
Recognised Expert
6,556 Views
Message 61 of 69

Re: "Your connection is not private NET::ERR_CERT_AUTHORITY_INVALID"

Go to solution

The problem is not only with Chrome. Users earlier in the thread have tried other browsers and have the same issue.

 

In terms of changing the DNS servers, that's not possible when using the BT Hubs unless you disable the DHCP server on the Hub and use a DHCP server in which you can decide which DNS servers to use, or statically assign the IP address and DNS servers on each device.

0 Ratings
Liam_
Recognised Expert
6,541 Views
Message 62 of 69

Re: "Your connection is not private NET::ERR_CERT_AUTHORITY_INVALID"

Go to solution

As it seems to be established now that it's the Hubs certificate not being known to any certificate authority that is the cause of the invalid certificate error.  Might this not be cured by downloading the routers unique certificate and importing it to the browsers certificate store?  Once there it could be flagged as  'trusted'.

Funny that other makes of routers don't seem to have this problem.  At least I've never had it happen.

0 Ratings
smf22
Recognised Expert
6,530 Views
Message 63 of 69

Re: "Your connection is not private NET::ERR_CERT_AUTHORITY_INVALID"

Go to solution
Two or more reasons other routers may not suffer. Users are probably configuring their routers to give an upstream public DNS server in their DHCP offers, and no Internet connection means no DNS lookup; and/or the routers don't return their own IP address in the name lookup if they're configured as DNS forwarders, but can't forward the requests as there's no Internet connection.
0 Ratings
Redlion72
Beginner
6,527 Views
Message 64 of 69

Re: "Your connection is not private NET::ERR_CERT_AUTHORITY_INVALID"

Go to solution
My problem send to be solved now, I was running a couple of old home hub 3 WiFi routers as extenders of a new Smart Hub. I have turned off Firewall, DCHP and UPnP on the HH3s. Seems stable now and doesn't throw up that error about certificates.
0 Ratings
LoggingIn
Beginner
6,497 Views
Message 65 of 69

Re: "Your connection is not private NET::ERR_CERT_AUTHORITY_INVALID"

Go to solution
@smf22 Yes, the connection does drop around the time of the issue whenever it occurs.

I personally can't confirm whether it's a Wi-Fi only issue or whether a wired connection is affected too but I'd hazard a guess to say it's both since the connection to the router doesn't drop.
A mobile/gaming device gives the warning that there may be no internet connection and our laptops show as still connected to the router though any attempt to access a webpage results in the certificate error due to the self-signed certificate.
0 Ratings
Pads89
Aspiring Contributor
6,437 Views
Message 66 of 69

Re: "Your connection is not private NET::ERR_CERT_AUTHORITY_INVALID"

Go to solution

Hi everyone,

 

I am having a very similar issue to this one. My connection keeps dropping out followed by this error message, when my connection drops it says there is no internet connection but i still have a steady blue light.

Then when my connection returns i get this message saying your connection is not private and that will last for 5 mins.

This is happening on all my devices including my PS4 which is wired by ethernet. Today is the worst it's been and my connection is dropping every 10 mins so it's pretty much useless.

 

I'm a bit stuck as to what to do, an engineer came out to fix my low speeds last week (he reset everything and my speed came back to normal) but now this. 

 

Any help would be appreciated.

0 Ratings
dgw1
Aspiring Expert
6,408 Views
Message 67 of 69

Re: "Your connection is not private NET::ERR_CERT_AUTHORITY_INVALID"

Go to solution

Have you tried turning off IPv6 on the router's LAN settings?

0 Ratings
smf22
Recognised Expert
6,391 Views
Message 68 of 69

Re: "Your connection is not private NET::ERR_CERT_AUTHORITY_INVALID"

Go to solution

@dgw1: Not sure of the relevance of IPv6 as there's no mention of it throughout this entire thread. Perhaps you posted in the wrong place? Also, for your information, there's no option for the user to disable IPv6 on the BT Hubs.

 

@Pads89: As discussed here the error is seen due to the Hubs sending their own self signed certificate when the broadband connection is down. Whilst you say the hub light remains blue what do you see from the Hub status page with respect to the VDSL uptime? If you look at the Hub log (Advanced -> Technical Log -> Event Log) and filter on WAN do you see a number of reconnections over a short period?

 

If the line is continually dropping you might want to undertake some basic tests:

- Run a quiet Line test
- Post your Home Hub router stats
- Check your home wiring by following the Home wiring and broadband set-up - a checklist and perhaps move the Hub to the test socket to see if that helps improve things.

 

It may also be better starting your own thread specifically for your problem. The subject of this thread is not related to line problems and is also shown as solved so may not get the attention required.

0 Ratings
JamieGregory
Beginner
6,350 Views
Message 69 of 69

Re: "Your connection is not private NET::ERR_CERT_AUTHORITY_INVALID"

Go to solution

Hi Everyone,

 

I'm experiencing the same issue as the op.

 

However, I believe my issue relates to my TP Link homeplug as this issue didn't exist before they were installed. That or the timing is very unfortunate. They were installed so that my BT TV box upstairs could use the player facility (as broadband is required). I notice the OP resolved his issue with a TP device. 

 

When I try to go to Google.com on the Google Chrome browser, the certificate error reads: https://i.gyazo.com/93a4bdd3c9dac0fb6804faa429213242.mp4

 

Not only does my internet drop for my laptop on Google Chrome web browser, it does the same for ALL devices including my gaming consoles, mobile and laptop. However, if I turn my wifi off on my mobile and use my mobile data, it's able to access internet pages without a problem. Similar to the OP, I have about 4 google chromecasts in the house - I don't know whether this is a possible issue.

 

smf22 - Thanks for your help thus far on this thread!

 

Not sure what more to try?

0 Ratings