cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
706 Views
Message 1 of 5

site security

Go to solution

After I've signed in and checked a few emails, the padlock symbol at the top disappears and instead says "site not secure".  Why is this the case and is it safe to continue with emails?  I've been signing out and then back in again but it always happens. This didn't happen with the previous BT email format. and is very annoying / worrying!

0 Ratings
4 REPLIES 4
701 Views
Message 2 of 5

Re: site security

Go to solution

This may help

https://community.bt.com/t5/Email/New-BT-Mail-Security/m-p/2055549



If you like a post, or want to say thanks for a helpful answer, please click on the Ratings 'Thumbs up' on left hand side.
If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.
691 Views
Message 3 of 5

Re: site security

Go to solution
Thanks . Refreshing my inbox makes no difference. Will re read the link tomorrow and try again.
0 Ratings
648 Views
Message 4 of 5

Re: site security

Go to solution

Have now read all the other related posts which were useful.  Thanks for pointing me in that direction. Tried the refresh button but that doesn't work.  But have discovered emails from known contacts are secure but anything else  eg businesses, campaign groups aren't.  Guess I'll have to live with it. 

0 Ratings
607 Views
Message 5 of 5

Re: site security

Go to solution

That is exactly what is happening to me and worrying when I could be hacked and have never experienced anything like this before with BT and not happy at all. 

0 Ratings