cancel
Showing results for 
Search instead for 
Did you mean: 
MannyD
Newbie
84 Views
Message 1 of 2

BT Flex 600 Broadband extender

I got the BT Flex 600 powerline extender today and when I first plugged it in, it was fine. I was getting my full speed of 70mbps down and 20 mbps up which is what I get when I use an ethernet directly. However, after using it for a while I'm getting the same speeds as I get wirelessly which is 7mbps down and 3mbps up. Ive tried taking the ethernet out, resetting and switching places but nothing is working. All lights on extender are static and on and my latop shows I'm on a wired connection. Any help on how I can fix this/ what is going on?

0 Ratings
1 REPLY 1
Moderator
Moderator
57 Views
Message 2 of 2

Re: BT Flex 600 Broadband extender

Hi @MannyD Welcome to the forum and sorry that you are having a problem with the Flex 600 broadband extender.

Check out the help page Broadband Extender Flex 600 and it also provides contact details for the product helpdesk who will be able to help you.

Cheers
John

Community ModeratorJohnC
Did you get the help you needed?
Help others by clicking on ‘Mark as accepted solution’
Show your appreciation!
Click on the star next to a reply to say thanks
Help guide to using the community? Click below
Kudos”
Please avoid contacting us (moderators) via private message, for account/fault issues, unless invited to do so. The community will be able to help answer your question so we encourage you to create a new thread if you can’t find the answer from existing discussions. The moderators will be around to lend a hand should the community not have the answers. Thank You
0 Ratings