cancel
Showing results for 
Search instead for 
Did you mean: 
DavidF1
Aspiring Contributor
761 Views
Message 1 of 11

BT Home Hub 6 Access Control Lists not working properly

BT Home Hub 6 Access Control Lists not working properly

 

On my new Homehub6 (which was a recent replacement for a faulty one which decided not to issue DHCP addresses any more), the Access Control Lists are not working. I have static IP addresses for all of my kids devices as I block them at night. I added an ACL for my daughters phone by IP address while she was connected and pressed Save. It then showed the MAC address rather than IP address. I added my sons laptop by IP address and pressed Save and it showed the MAC address followed by a semi colon followed by the MAC address of my own PC, which was then blocked after 9pm. Needless to say I had never entered this device into an ACL. I added my sons phone whilst he was away from the home pressed Save and the box just showed a blank. Last night the router started blocking my house alarm and my BT Whole Home Wifi devices from accessing the internet. There are no references to these devices in the ACLs. I also noticed that if you look at connected devices, some devices that have DHCP addresses show up occasionally as Static, and some devices that are online at home do not appear in the list at all. Resetting the router has no effect, nor does deleting all ACLs and starting again. A recent firmware upgrade on 6th June to version SG4B1000E016 has not fixed the problem. 

Access List.JPG

 

 

 

 

 

 

I reported this to BT and they sent me another replacement Homehub6 this week. I have configured this offline with just my laptop plugged into it. I added 3 access lists by IP address, none of which are in the MAC table, press Save and in place of the IP address it now shows 2 lines (not 3) of MAC address 00:00:00:00:00:00. If I then try to add a 3rd line and save it it just ignores it and shows 2 lines.

Is anyone else having similar problems. Is this a firmware issue?

I would be grateful if anyone could offer any advice as to how to resolve this problem. 

Thanks for your help

Dave

10 REPLIES 10
bobinson
Aspiring Contributor
438 Views
Message 2 of 11

Re: BT Home Hub 6 Access Control Lists not working properly

Hi Dave,

I'm having exactly the same problem mate

Driving me up the wall. I'm on my 3rd Hub now.......

and it still doesn't work

Did you get any joy ?

Cheers

Bob

0 Ratings
Reply
Moderator
Moderator
418 Views
Message 3 of 11

Re: BT Home Hub 6 Access Control Lists not working properly

Hi @bobinson,

Welcome to the Community and thanks for taking the time to post.

We have updated the software since the original poster made this thread.

We have a helpful "How to Guide" for switching on BT Access Controls and this can also be done from the MyBT app depending on what model of Smart Hub you have.

Let me know how you get on?

Thanks

Matt

0 Ratings
Reply
Mackey
Beginner
373 Views
Message 4 of 11

Re: BT Home Hub 6 Access Control Lists not working properly

@mod, thanks for posting the guide again, but this doesn't address the issue.

The how to guide is great in as far as it goes - it clearly shows how to set-up access control. The issue I am experiencing, similar to the above posts, is not one of the set-up which I have done multiple times in sync with the how to guide. The issue is what happens next, once it's been set up:
1. Access control set-up for iPhone1. Settings saved and tested and all working ok.
2. Shortly after (could be minutes or hours) the control set-up have no impact and another device stops working
3. Check settings, and iPhone1 is now not shown as having any controls, and has been replaced by iPad1 or AmazonFireStick or TV etc

Even when only one device has a control set, it randomly changes to another. This must be to do with how IP are allocated. I have tried setting each device IP to fixed in the Device settings menu within the router, by this doesn't help either.

0 Ratings
Reply
Highlighted
bobinson
Aspiring Contributor
353 Views
Message 5 of 11

Re: BT Home Hub 6 Access Control Lists not working properly

Hi @Mackey 

Please see my previous post on this issue :

https://community.bt.com/t5/BT-Devices/Smarthub-6a-Access-Control-issues-not-working-broken-help/m-p...

The only solution BT could offer was to send me a Homehub 5 (after having 3 SmartHubs)which allows you some control, but doesn't even work properly either, and also comes with the added bonus of less wifi coverage around your house !

You can set up separate devices on it but only for a full week, (no settings for different days of the week). 

My previous ISP was Plusnet and their Plusnet Hub One router which I believe is the same model as the Homehub 5 (please correct me if I'm wrong @Matt-S ) albeit with different firmware worked exactly as they said it would with no issues. You could alter the end and start times on the fly, i.e. after you had selected and stored the device access time on/off settings you could also change them on the fly.

The Homehub 5 only lets you change the 'access time off' and not the 'access time on' on the fly, so you have to delete that setting and create another setting if you wish to change this.

It seems there is a fundamental problem with the Smarthub which noone is willing to accept at BT. 

There are a lot of folk on here with this issue, but so far there doesn't seem to be a solution posted. Think its about time this issue was addressed properly and had its own section on the forum.

The main reason I switched to BT was because of the parental and access controls. I would like to be able to keep my kids safe online and have sensible limitations on time spent online as I'm sure many parents on here would.

Best advice I can give you is to open an official complaint mate. Because as far as I can see you wont get much joy on here, the only advice you get is how to set up Access Controls...... which is quite frankly an insult to peoples intelligence.

Please give me a shout if you get anywhere or have any questions

 

Peace Out

 

Bob 

 

 

DavidF1
Aspiring Contributor
305 Views
Message 6 of 11

Re: BT Home Hub 6 Access Control Lists not working properly

Hi Bob

Sorry for the delay in replying.

Like you I have had 3 hubs. They have all exhibited the same problems. I have never had a resolution to the problem.

I see my hub is now running an updated  firmware version to the one which I noted in my original post. It is the same version as you noted in your post of 6th Jan 2020 (ver. SG4B1000E01E). As you said your hub exhibited the same issues as I experienced on the previous firmware version it is obvious to me that this software error has not been fixed. On the last occasion I reported the problem, I did get to speak to the BT technical department and I asked them to record it as a firmware bug. I also asked them at the time whether this was a known issue but they said no. (Not sure I believe them).

For your information. BT have recently changed their product branding. I am on Halo 1 which is what I am guessing you are on. This means we only get the Home Hub we already have. However if you upgrade to Halo 2 they supply you with a new router called a Smart Hub 2. One of the big selling points is the enhanced parental control and controlling how much time the family spend on the internet. BUT, rather annoyingly,  they have only made that part accessible through the MyBT app on your smartphone. You can no longer manage settings through your browser from your PC. There are also some issues reported in this Community.

The Smart Hub 2  router costs £200, or you have to upgrade to Halo 2. If you went down the road of an official complaint then they may supply one free of charge. Other options are 1)  a 3rd party router, but you would need to check that you can do all that you want to do with the access lists as many of them don't offer the granularity that BT do (if it actually worked) OR 2) insert a dedicated firewall before the router.

Please let me know if you get a resolution.

Regards

Dave

 

 

bobinson
Aspiring Contributor
226 Views
Message 7 of 11

Re: BT Home Hub 6 Access Control Lists not working properly

Hi Dave,

Thanks for the advice, much appreciated

I've now opened a case with resolver

So will see what drops out of that tbh I'm done with BT I just want out.

Cheers

Bob 

 

0 Ratings
Reply
DavidF1
Aspiring Contributor
169 Views
Message 8 of 11

Re: BT Home Hub 6 Access Control Lists not working properly

Hi Bob

I have also made a formal complaint.

Please keep me posted and I will do likewise.

Regards

Dave

bobinson
Aspiring Contributor
157 Views
Message 9 of 11

Re: BT Home Hub 6 Access Control Lists not working properly

Hi DavidF1 ,

I've now got a Smarthub 2 (FOC) and  the Access Control works just like it says on the tin !

Good luck on your quest...

Cheers

Bob

0 Ratings
Reply
wrighar
Aspiring Contributor
126 Views
Message 10 of 11

Re: BT Home Hub 6 Access Control Lists not working properly

This is exactly the problem I have been having since last summer (and have reported here before https://community.bt.com/t5/Home-setup-Wi-Fi-network/Strange-issue-with-Smart-Hub-Access-Controls/m-...).

 

Just randomly stops working / blocking everything at the access control time, even when only 1 or 2 devices are selected for access control.

0 Ratings
Reply