cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
rafikibob
Aspiring Contributor
1,766 Views
Message 1 of 14

BT Whole Home Premium Issues

Well, setting up WHP has proven to be a pretty nasty experience but thankfully the forums have been a huge help. 

With no particular structure here's some of my experiences so you can relate or it may help others:

1.) Do not use ethernet backhaul at all. Especially not during setup. You get all sorts of funky problems including the master disk changing, spontaneous reset of all configurations across multiple discs etc. All further issues below are based on a non-wired setup.

2.) Every time I added a new disc (one at a time of course) and did the firmware update (and then factory reset), it would stall at some point in the mobile app flow. The disc would sit there flashing purple for an hour if left to. If the mobile app idles off during that time it has no idea what state the disc is in and you end up doing the WPS dance about 10 times. At one point I just plugged a non-syncing disk into the master directly (breaking my own rule) and it synced in seconds and the app recognised where it was in the flow and carried on. Bizarre.

3.) At some point in the install I would get alternating blue/red/blue/red etc. I couldn't find what this was supposed to mean. I also had a flashing purple light on one device, but when I went in and turned the brightness to medium it turned blue. Turned it to high and it went flashing purple again. I feel sure that shouldn't be happening 🙂

4.) As is already well discussed on here (but saying again in case someone finds it and helps them), do not plug it directly into a Virgin Hub 3 just yet. There is a known problem, there is a firmware fix, but getting the fix out of VM is probably more hassle than just sticking a cheap switch in between the WHP Master and the VM Hub.

Long story short it was a nightmare of inconsistent behaviours but dogged persistence, a combination of patience and the occasional application of "nah, that's stalled", and and a total avoidance of wires got me to 5 stable discs.

My two outstanding issues currently (although I expect more) are:

1.) The steering checkbox is "locked" and unselectable. I think this is a great feature for crappy IoT.

2.) The "disable 5Ghz temporarily" feature that is on the cheaper Whole Home discs seems not to exist on the WHPs. This is a great feature and sorely absent since it's present on other products in the range. Either this or some other band-locking to help with the many devices that struggle with having both bands on the same SSID.

I've been in tech, including infrastructure and networking etc for 25 years and banged my head on a few desks over that time, but setting these buggers up actually brought tears to me eyes yesterday. I was wailing "why? why would you do this?" at the screen. That's pretty impressive 🙂

 

Tags (1)
13 REPLIES 13
rafikibob
Aspiring Contributor
1,735 Views
Message 2 of 14

Re: BT Whole Home Premium Issues

Oh lord, this is the second time this has happened now.

I add a new disc, do the WPS thing, it updates it's firmware. I do the factory reset afterwards and then watch in horror as the primary disc also turns purple and restarts, then it all comes back up missing half the disks (the ones not from the 3-pack), missing the changed SSID, missing the disc names.

How on earth does doing a factory reset on a new disc also factory reset the master and tear down the entire mesh?

It also factory reset the other discs because I then had two BTWHOLEHOME SSIDs being offered, and all sign of my working 5 disc mesh had disappeared.

Is factory resetting everything some kind of failsafe?

 

0 Ratings
Reply
rafikibob
Aspiring Contributor
1,722 Views
Message 3 of 14

Re: BT Whole Home Premium Issues

6 Discs working fine for a few hours, and then spontaneously 2 remove themselves from the mesh. The two that removed themselves continued to have blue lights, they were there and then they weren't. They are both from original 3-pack along with the master, and the first 2 discs installed after the master.

Rebooted one of the discs and then they both rejoined the mesh.

Not very confidence inspiring.... 

0 Ratings
Reply
rafikibob
Aspiring Contributor
1,659 Views
Message 4 of 14

Re: BT Whole Home Premium Issues

Twice today my master disc has turned red and the whole mesh is working but unable to actually send/receive to the internet. In both cases I rebooted the disc and it didn't work. Rebooted the dumb Netgear switch it's plugged into and it fixed it.

Never in the 35 years I've been a techie have I had to hard reboot a basic dumb ethernet switch because IT wasn't working properly. They're as basic as anything. This is the BT WHP disc at fault here.

Admittedly the switch is there purely and simply to connect the WHP master disc to my Virgin Media Hub 3.0, which I know has problems, but what problem should occur when it's via a switch?

I can't compel Virgin Media to give me the firmware because I can't afford to plug it in for a week and have it fail just so VM can magically see that I have it connected.

I'm trying the latest SGAB205018 firmware and there's still no disc steering.

I watched as a device got the default gateway of the master disc, and not the actual default gateway handed out by the router. That should not have been happening on the last firmware which enabled bridging mode, let alone this latest early adopter one. It seemed to correct itself after a few seconds....but I don't want to see it do that, ever. This is a mesh device. I want it to work at the ethernet/wifi level, not much around at the IP level.

 

0 Ratings
Reply
rafikibob
Aspiring Contributor
1,654 Views
Message 5 of 14

Re: BT Whole Home Premium Issues

Ok, add a third time that it all just stopped. This time rather than reboot the switch I just replugged the WHP master from the VM Hub 3 <switch> WHP setup, and directly into the VM Hub 3. Fingers crossed it stays stable for a bit but I've raised the Amazon return for all 6 discs and giving up.

It seems clear to me that these could be good devices but they are nowhere near as stable or as production ready as their "junior" cousins in their product range.

It's simply not reasonable to ask customer to spend £500+, as I have, and then to hang on past any return window, in the hope that a year or so of firmware updates eventually solve all the obvious issues, intermittent issues.

The forums are awash with people who have been struggling with this product for months and months, and I've had people walk me through other products that work fine.

What happened? How did this particular product get released when it's so flakey for so many people? Masters going down, STILL acting like routers when they're supposed to be APs, spontaneous mesh collapses during setup, no band steering (no setting), no AP steering (a setting but it's locked out), unstable ethernet backhaul, unstable WPS setup for new discs (which perversely does require a wired ethernet connection), firmware updates that sit there for hours and don't finish, the app saying "you're not connected", when you are...or that everything's fine, when it's not.

Do not buy BT Whole Home Premium until they've finished making it a stable product.

Dan-O
BT Devices Expert
BT Devices Expert
1,626 Views
Message 6 of 14

Re: BT Whole Home Premium Issues

Hi @rafikibob 

Have you checked the information in the sticky post: https://community.bt.com/t5/BT-Devices/27-07-20-LATEST-Virgin-Smart-Hub-3-with-Premium-Whole-Home-Wi...

There are stability issues with an old version of Virgin Hub 3 software and Virgin released a firmware to address these problems. Can you confirm your Hub has 9.1.1910.200 or later? This explains the primary disc periodically going red and needing to be reconnected.

Dan-O

 

0 Ratings
Reply
Sircoynie
Aspiring Expert
1,616 Views
Message 7 of 14

Re: BT Whole Home Premium Issues

Unfortunately all of the issues you list are known and many users on here have been suffering with for a long time now as sadly the support for this product has been shocking.

If you can afford it and still have the ability to return I would look elsewhere. Sorry for being so negative.
0 Ratings
Reply
rafikibob
Aspiring Contributor
1,602 Views
Message 8 of 14

Re: BT Whole Home Premium Issues

Thanks Dan-O,

Yep, I've kept up to date on that thread.

It wasn't plugged directly into the Hub 3.0, they were both the only devices plugged into a dedicated switch. I've seen the question asked before whether it only occurs if directly plugged in or not, and I'm afraid I never saw an answer.

In my case plugging it directly into the hub stopped that particular instability. I don't have that firmware or later, no, but by plugging the WHP back into the hub it should give VM the opportunity to identify it and update it.

Sorry to sound snarky, but a VM patch isn't going to fix the multitude of other problems with this product. These discs are going back and 6 non-premium discs coming tomorrow.

0 Ratings
Reply
rafikibob
Aspiring Contributor
1,600 Views
Message 9 of 14

Re: BT Whole Home Premium Issues

Thanks Sircoynie. Yes, indeed, i'd reached the same conclusion. This will be a fine product some months from now. People have been struggling with it since release, so I can't roll the dice on "some months". 

0 Ratings
Reply
rafikibob
Aspiring Contributor
1,551 Views
Message 10 of 14

Re: BT Whole Home Premium Issues

Early update:

6 new BT Whole Home Wifi discs arrived today.

Total install time about 45 minutes, for 6 discs! No firmware updates required during install but did it after and it took 3 minutes and was seamless. Two discs are via ethernet backhaul which was also seamless.

The web interface has more detail on the network map. The Premium didn’t draw properly and had lines missing. This one actually shows more info.

One thing I am very happy to see are two important features missing from the WHPs. 1) The ability to steer devices to discs. This is “present” on the WHPs but disabled. 2.) The ability to pause 5GHz for 30 minutes while you add devices that don’t work great with dual-radio-single-SSID.

 

And the fact that Ethernet Backhaul just works...and it doesn’t mess with DHCP and Default Gateways. And it plays nicely with Virgin Media Superhubs. And I haven’t had to factory reset them all carefully, or be subjected to them all randomly crapping themselves.

 

The whole setup process felt like a premium experience, and not the combination bomb defusal/building a house of cards of the actual “premium” product.

 

Speeds seem broadly comparable. I did put these discs in the same spot as the premiums and some of the locations that were excellent went to good and a good went to poor. This could be because the WHPs genuinely have better range, or it could be just the usual variance in wifi at different times of day. Not in any way a scientific comparison.

I did notice that the first disc (office), plugged directly into the Netgear R8000 router, isn’t the master anymore. The master is now the second disc installed, lounge. The new master, the second disc, is disc - lounge switch - office switch - R8000 router - VM hub 3 in modem mode. No idea why the topology algorithm (or diagram algo?, who knows) decided to swap them and why disc - switch - switch - router is better than disc - router. All cable are Cat 5E and on gigabit ports so....

 

0 Ratings
Reply