cancel
Showing results for 
Search instead for 
Did you mean: 
greatdane
Beginner
289 Views
Message 1 of 7

BT whole home not connecting to Huawei router

I purchased the BT Whole Home Wi-Fi, Quad pack Bundle (Twin + 2 additional) for use in our holiday home.
I was assured the disks would work with any UK router, so it now comes as surprice to me that I cannot get the disks to connect.
My router is a Huawei B525 unlocked 4G 300Mbps mobile Wi-Fi Router. I have connected the disk (from pack one) with the supplied ethernet cable to the router, and the disk start flashing blue, but then go solid red.
I cannot use the “my BT” app, as I am already using the for my home setup, and cannot use it with a second router.
I have tried the set-up several times, and each time end up with a solid red light on both the disks from box one.
Is there a special way to connect the disks to a non BT router?
Please help me

PS. I have the BT Smarhub 2 with extra disks at home, and that system works ok

0 Ratings
6 REPLIES 6
Distinguished Sage
Distinguished Sage
285 Views
Message 2 of 7

Re: BT whole home not connecting to Huawei router

Welcome to this user forum @greatdane 

I am not sure if it will work on just a 4G mobile network, as I think that what BT may be referring to, is a normal broadband connection.

I will ask for advice on this.

I have asked a moderator to provide assistance, they will post an invite on this thread.
They are the only BT employees on this forum, and are based in the UK.

Moderator
Moderator
256 Views
Message 3 of 7

Re: BT whole home not connecting to Huawei router

Hi @greatdane 

Have you tried to download the BTWholeHome app which will allow you to manage this separate to your home network.

Thanks

Stuart

Community ModeratorStuartH
Did you get the help you needed?
Help others by clicking on ‘Mark as accepted solution’
Show your appreciation!
Click on the star next to a reply to say thanks
Help guide to using the community? Click below
Kudos”
Please avoid contacting us (moderators) via private message, for account/fault issues, unless invited to do so. The community will be able to help answer your question so we encourage you to create a new thread if you can’t find the answer from existing discussions. The moderators will be around to lend a hand should the community not have the answers. Thank You
Highlighted
greatdane
Beginner
242 Views
Message 4 of 7

Re: BT whole home not connecting to Huawei router

Hi Stuart,

Yes, I have the my BT app on my phone, but as mentioned in my original post, I cannot use it as it is "occupied" by my home network router, and I cannot load another router on the app.

0 Ratings
Moderator
Moderator
235 Views
Message 5 of 7

Re: BT whole home not connecting to Huawei router

Hi @greatdane 

There is another app for BTWholeHome if you search in the app store or google play store you should be able to find it.

Thanks

Stuart

Community ModeratorStuartH
Did you get the help you needed?
Help others by clicking on ‘Mark as accepted solution’
Show your appreciation!
Click on the star next to a reply to say thanks
Help guide to using the community? Click below
Kudos”
Please avoid contacting us (moderators) via private message, for account/fault issues, unless invited to do so. The community will be able to help answer your question so we encourage you to create a new thread if you can’t find the answer from existing discussions. The moderators will be around to lend a hand should the community not have the answers. Thank You
Distinguished Sage
Distinguished Sage
234 Views
Message 6 of 7

Re: BT whole home not connecting to Huawei router

just a thought what if you disconnect from home network and connect to the 4g mobile network can you then use app?



If you like a post, or want to say thanks for a helpful answer, please click on the Ratings 'Thumbs up' on left hand side.
If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.
0 Ratings
greatdane
Beginner
208 Views
Message 7 of 7

Re: BT whole home not connecting to Huawei router

Dear friends,
Thank you for all your advice. I think I have finally solved the problem.
I unplugged all ethernet devices from the router, and only connected the first whole home disk. That enabled me to connect the disk (solid blue light).
Thanks to StuartH for pointing out there are two apps for the two different whole home systems
Also - contrary to my home smarthub 2 setup, the first dish here needs to remain plugged in to the router via the ethernet cable (not needed with the smarthub 2), so in theory you “loose” one disk with this BT whole home system.
However, after approx seven hours trial and error, I think I have managed to get it up and running with the Huawei router.
Thanks a million for your support.

0 Ratings