cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
spinecho
Contributor
3,342 Views
Message 1 of 17

HH 6 Gigabit ports...how to view what speed connected?

Go to solution

Hi

On my old HH 5 hub it showed at what speed (100Mbps etc.) each LAN port was connected.

I cannot find this setting on the HH6, just that a device is connected.

Is there any way in HH6 settings that I can view this as I am having troubles with LAN speed.

0 Ratings
Reply
16 REPLIES 16
Keith_Beddoe
Distinguished Sage
Distinguished Sage
3,323 Views
Message 2 of 17

Re: HH 6 Gigabit ports...how to view what speed connected?

Go to solution

@spinecho 

I do not use a BT home hub, however there have been a number of posts regarding LAN speed issues, where a device, or another Ethernet switch, cannot negotiate the correct speed due to hardware tolerances.

This is called duplex mismatch https://en.wikipedia.org/wiki/Duplex_mismatch

I wonder if that is the problem you are having with the LAN ports on the HH6?

A similar thread here.

https://community.bt.com/t5/BT-Devices/BT-Smarthub/m-p/1890186#M6372

Does that describe the problem you are having?

spinecho
Contributor
3,311 Views
Message 3 of 17

Re: HH 6 Gigabit ports...how to view what speed connected?

Go to solution

@Keith_Beddoe 

Hi Keith, thanks for your reply

The link you provided seems exactly my issue.

To clarify: I have a self-built Raspberry Pi 4 NASw gigabit Ethernet. The RP4 is connected to USB3 HDD which contains all my media (4k UHD, Blu-ray & DVD rips).

This is connected to 2 Kodi boxes in different rooms through the gigabit ethernet port via the ethernet ports in the HH6. So the RP4 is connected to HH6 and the the 2 Kodi boxes are connected also connected to HH6. All have cat6a cables.

The issue of buffering media on the remote Kodi box in another room presented itself when I added a TP-Link 5 port gigabit switch in the other room to connect Moore devices to my home network.

I checked the ethernet speed on the RP4 using ethtool and it is reporting that is only connected to 100MBps to the HH6 and not 1000MBps as expected.

All my cables are fine and I've tried changing ports and cables, but I can only connect with 100MBps.

If I'm reading the link you sent correctly, I presume I should add a gigabit network switch directly to the RP4 and then the switch to the HH6?

0 Ratings
Reply
Keith_Beddoe
Distinguished Sage
Distinguished Sage
3,302 Views
Message 4 of 17

Re: HH 6 Gigabit ports...how to view what speed connected?

Go to solution

Its more likely that the TP Link switch cannot negotiate the correct rate with the HH6, and may actually be flipping between different rates and duplex modes.

The problem is that at 1Gb Ethernet, the link pulse that determines the correct mode is very short, and it only takes a small amount of timing error, for this to be a problem, especially if there is a long length of cable between the home hub LAN port, and the Ethernet switch.

The answer may be to use a better quality Ethernet switch than the TP Link one.

I use Netgear managed switches in my network, as you can do extensive monitoring and  control the throughput to devices.

I have two switches. One is an 8 port Netgear GS108Ev3 and the other is a 5 port Netgear GS105Ev2.

These are more expensive that the TP Link ones, as they are designed to handle SOHO and business use.

My router is a TP Link W9970 which only has 100Mb ports, so I just connect one port of that router, to my 8 port switch, as I just have a 10Mb ADSL connection, which is plenty fast enough for what I need.

All local Ethernet traffic is handled by the Netgear switches, so none of that is passed via the TP Link router.

If you can afford it, then I would substitute the TP Link switch, for a Netgear GS105Ev2. You will be able to see all the connection speeds via the Netgear web management port, which allows you to do lots of other things.

If you do not want to do that, then connecting your existing TP Link switch, directly to the home hub LAN port, although I still think you may get timing issues.

Auto negotiation causes lots of issues, but very few devices allow you to lock the connection speed to a specific rate. Most computer LAN cards have this feature, and can be locked to 1Gb full duplex.

spinecho
Contributor
3,269 Views
Message 5 of 17

Re: HH 6 Gigabit ports...how to view what speed connected?

Go to solution

@Keith_Beddoe 

Again, thanks for taking the time to reply.

I feel like I'm really going down the rabbit hole now!

I'm reasonably experienced with building PC's and I've happily built a raspberry pi 4 NAS, but I'm afraid all the network talk has left me baffled!

Back to basics: my raspberry pi 4 NAS (running headless Raspbian Buster with my media files shared by SMB) is connected directly to my BT HH6 via cat6a ethernet.

I'm using the HH6 as both a router and switch as I have connected my 2 Kodi boxes to the HH6 again with cat6a ethernet cable.

If I unplug everything except the raspberry pi NAS and query the NAS with ethtool, I get the result that the raspberry pi 4 can achieve gigabit connection, but the active link is only 100Mbps. I'm stumped, hence my original question.

There seems to be no way to check via the HH6 manager (192.168.1.254) that the port is actually gigabit (the HH5 chows the connection speed).

Does this mean the HH6 ports are faulty, or it is a protocol negotiation error?

I'd rather not spend lots of money on this, but many people on these forums have stated they have exchanged their HH6 for another router. Would this be a better route?

By the way, the switch I was using is a TL-SG105 gigabit switch. 

Getting back to your answer, how do achieve your setup? How do you have internet if your LAN is not connected to router?

0 Ratings
Reply
Keith_Beddoe
Distinguished Sage
Distinguished Sage
3,264 Views
Message 6 of 17

Re: HH 6 Gigabit ports...how to view what speed connected?

Go to solution

If the NAS is directly to the HH6 and showing the wrong speed, then the network interface on the NAS cannot negotiate the correct speed.

Connect your TP Link switch directly to the home hub port, then connect your NAS to the TP Link switch, and see what speed it reports.

My router is connected to one port of my eight port Netgear switch, so it distributes the Internet to anything connected to that switch. That is how an Ethernet switch works.

licquorice
Distinguished Sage
Distinguished Sage
3,260 Views
Message 7 of 17

Re: HH 6 Gigabit ports...how to view what speed connected?

Go to solution

Silly question, are your Ethernet leads and plugs fully wired? They will work with only 4 wires but not at Gbe speed.

spinecho
Contributor
3,249 Views
Message 8 of 17

Re: HH 6 Gigabit ports...how to view what speed connected?

Go to solution

@licquorice funnily enough I was just reading about that! My cables state cat6a printed on them so I really don't know!

 

@Keith_Beddoe I'm beginning to think that it must be the auto negotiation with RP4 NAS. I tried connecting via the switch (RP4->switch->HH6) and the RP4 states via ethtool that it's connected at 100Mbps. However it also states that it is capable of 1000Mbps and that what it's linked to is only capable of 100Mbps, hence wondering if the ports on HH6 were faulty.

Guessing I'll have to go down the new router, erm, route!

0 Ratings
Reply
Keith_Beddoe
Distinguished Sage
Distinguished Sage
3,243 Views
Message 9 of 17

Re: HH 6 Gigabit ports...how to view what speed connected?

Go to solution

No need for a new router, just connect the Ethernet switch directly to the home hub, and connect the NAS to that, as I suggested on my last post.

See what speed it reports then.

spinecho
Contributor
3,240 Views
Message 10 of 17

Re: HH 6 Gigabit ports...how to view what speed connected?

Go to solution

@Keith_Beddoe , sorry... Thought I'd said I'd done that in my last post.

Yeah, tried RP4 -> switch -> HH6 and ethtool on RP4 throws back that connected at 100Mbps.

0 Ratings
Reply