cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Andy23
Beginner
64 Views
Message 1 of 4

Home hotspot 600 power light

Home hotspot 600 extender plug has no power light whatever I try. I suspect it is broken but am open to other suggestions.

0 Ratings
Reply
3 REPLIES 3
NeilO
Moderator
Moderator
49 Views
Message 2 of 4

Re: Home hotspot 600 power light

Hi @Andy23 welcome to the community and thanks for posting. I'm sorry to see you're having problems with your Home hotspot 600. Have you tried a factory reset?

1 Make sure the extender or the hotspot is plugged in and the power socket’s switched on.
2 Press the Link button on the extender for more than 15 seconds or
the Reset button on the hotspot for 1 second to restore factory default settings. Give it
a couple of minutes. If everything’s okay, the Power indicator on both will light up.

If these steps don't help I'd recommend getting in touch with us on: 0808 100 6116

Monday to Friday 9.00am to 5.30pm, Saturday 9.00am to 2.00pm

By email: btconnectedhome@bt.com

Thanks

Neil

0 Ratings
Reply
Andy23
Beginner
35 Views
Message 3 of 4

Re: Home hotspot 600 power light

Tried both and get power indicator on the hotspot but still not on the extender.

0 Ratings
Reply
NeilO
Moderator
Moderator
33 Views
Message 4 of 4

Re: Home hotspot 600 power light

@Andy23 Thanks for trying that, I'm sorry it didn't help. It does sound faulty but I'd recommend contacting the helpdesk to be sure.

Thanks

Neil

0 Ratings
Reply