cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
951 Views
Message 1 of 5

Mini Connectors not connecting

Just got a new BT Home Hub 2, I have some mini connectors but they're not working. I get the ethernet light but no data light. Tried resetting over and over but no joy. Wondering if it's the modem, do I need to change some settings?

 

0 Ratings
Reply
4 REPLIES 4
921 Views
Message 2 of 5

Re: Mini Connectors not connecting

@Macca101 

You can easily check if they are actually working by plugging them into the same double socket as a test. The data light on both should come on. Don't worry about the ethernet cables for this test.

What circuits are you connecting them to , like upstairs main & downstairs main?

If you have a split load consumer unit & the circuits you're connecting to are on different halves of the CU then that could be the problem as the connecting circuits should be on the same half of the CU.

 

0 Ratings
Reply
910 Views
Message 3 of 5

Re: Mini Connectors not connecting

Thanks for the reply. Tried that, nothing. literally have them side-by-side on the same double socket ☹️

0 Ratings
Reply
900 Views
Message 4 of 5

Re: Mini Connectors not connecting

@Macca101 

Then it would seem that they are faulty. 
Before I replied above I tried my mini connectors and I had a steady blue light for the data indicator. 

0 Ratings
Reply
890 Views
Message 5 of 5

Re: Mini Connectors not connecting

I've left them on for a while and they are now the power light is flashing continually on both, which I think means they are resetting, but they've been like that for over an hour

0 Ratings
Reply