cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Contributor
749 Views
Message 1 of 7

New Firmware for SH2 and Black Discs

Has anyone else noticed the Smart Hub 2 and Black discs have updated firmware.  My Hub is now on v0.21.03.07094-BT and Black Discs are have version 0.20.00.06221. The update was applied at 09:32 on 16 October. Its a shame BT don't issue a change log as it would be useful to know whats been updated.

0 Ratings
Reply
6 REPLIES 6
Highlighted
Beginner
575 Views
Message 2 of 7

Re: New Firmware for SH2 and Black Discs

Yeah mine updated last night on both, unfortunately it appears my upload speed has been halved because of it though and my USB drive connected to the router is no longer available! Used to get 100+ upload now only getting 50. Will do a full reboot of everything and if still the same will be phoning them up.

0 Ratings
Reply
Highlighted
Aspiring Contributor
520 Views
Message 3 of 7

Re: New Firmware for SH2 and Black Discs

I also have the same upgrades applied last night (to the SH2 and black wifi disc). I'm on the FTTP 900 and can't upload more than 50Mbps at the moment, any speed tests I've tested that's what it tops out at. Downloads seem fine so far.

0 Ratings
Reply
Highlighted
Aspiring Contributor
481 Views
Message 4 of 7

Re: New Firmware for SH2 and Black Discs

This might be worth trying, i've just done a full factory reset on my SH2 and I'm now getting speeds I was previously. So for the moment, my upload cap seems to be gone and things are back to normal.

Highlighted
Beginner
468 Views
Message 5 of 7

Re: New Firmware for SH2 and Black Discs

Thanks, did it keep the same firmware or revert to a previous one?

0 Ratings
Reply
Highlighted
Aspiring Contributor
463 Views
Message 6 of 7

Re: New Firmware for SH2 and Black Discs

It kept the same firmware, had to re-register the digital voice handsets and that was it 👍

Highlighted
Aspiring Contributor
338 Views
Message 7 of 7

Re: New Firmware for SH2 and Black Discs

I noticed today that my firmware updated yesterday but only as my speeds were diabolical and also one of my black discs had dropped off the network. Initially I tried to recover the disc by connecting directly to the router with ethernet. This worked when connected but would not work when I took it away from the router and put it back in its usual place. Internet speeds were still very poor. Having had a similar issue with the disc some weeks ago I defaulted my SH2, reconfigured and speeds were back to normal and suprisingly the disc automatically connected. Its either very coincidental or the update caused problems.

0 Ratings
Reply