cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
panman1300
Aspiring Contributor
1,557 Views
Message 1 of 7

Port Forwarding on Smart Hub 2

Go to solution

Over the years I have progressed from a HH2 right up to yesterday when I received and installed a new BT Plus Smart Hub 2 and a Disc.  The hub had its firmware updated overnight and is now on v0.11.00.09070-BT

Over the years I have built my own VPN on a Raspberry Pi (RPi).  From about the HH5 and certainly the HH6/Smart Business Hub 1 I have successfully forwarded port 1192 to the RPi, and have made extensive use of it whilst on an extended holiday.

That is until this new Smart Hub 2.  There is only one place to set-up the Port Forward (it was a two step process on previous hubs).  But as far as I can see I have correctly configured the hub, yet I cannot connect to the VPN.

The VPN client behaves in exactly the same way, whether the port forward is set up or deleted.

It gets to

Sat Dec 08 14:07:06 2018 MANAGEMENT: >STATE:1544278026,WAIT,,,,,,

and just waits.

It is reporting the correct external IP address and port for the hub (the IP address is dynamically  monitored and maintained every 15 minutes).

An open port tester shows that 1192 is closed.  I never checked this on the previous hubs, because the VPN worked!  But should the port be reported as open so that the forwarding rule will direct traffic to the RPi?

The RPi has not changed.  It was last built in April this year and has been working until yesterday.  I have checked the server status and it's sitting listening to the correct port - and there is no reason why not as nothing has changed on it.

I am reluctant to swap the previous hub back in, having now got everything else working and the Disc set-up.  On the previous set-up I had some of the older hubs acting as remote access points.

Have I missed a step in the setting up of the Port Forwarding?  Or does the Smart Hub 2 have something against port 1194?

Untitled-2.png

0 Ratings
Reply
6 REPLIES 6
panman1300
Aspiring Contributor
1,535 Views
Message 2 of 7

Re: Port Forwarding on Smart Hub 2

Go to solution

It seems I can half answer my own question.

I was trying to connect to the VPN from within my home network, as I always have done, for testing.  But this doesn't work with the Smart Hub 2.

But when I had a flash of inspiration to turn off wifi on my mobile phone and try to access the VPN over the mobile network it worked!

I don't know why it is behaving differently with the new hub, but at least when I really need it when away from home, it looks like it will work.

0 Ratings
Reply
Distinguished Sage
Distinguished Sage
1,518 Views
Message 3 of 7

Re: Port Forwarding on Smart Hub 2

Go to solution

Possibly the Smart Hub 2, does not support NAT Loopback?

panman1300
Aspiring Contributor
1,508 Views
Message 4 of 7

Re: Port Forwarding on Smart Hub 2

Go to solution

Reading up on the subject, I believe you are 100% correct. I probably had a HH5 when I started with the VPN and then the HH6/Smart Hub 1 and they both must have had NAT loopback without me even needing to know!

At least I can now move on and find an alternative solution, possible a DNS on one of my other RPis.

The downside is that I must remember to turn off/on the VPN on my phone when entering/leaving the house, which I didn't have to do before. My RPis do a lot of home automation, hence the VPN to access them without exposing them to the web directly.

Thanks again for your prompt and helpful response.

 

0 Ratings
Reply
MrAshieB
Contributor
1,268 Views
Message 5 of 7

Re: Port Forwarding on Smart Hub 2

Go to solution

Apologies for ressurecting this thread.

 

However, I have noticed on my Smart Hub 2 that there was a firmware update on 22-01-2019 with a version number of v0.12.02.11078-B.

 

After checking my local network again, I am once again able to do what I could on the original Smart Hub with regards to my VPN etc.

 

It's good to know that they've worked on it & resolved my main gripe with Smart Hub 2.

panman1300
Aspiring Contributor
1,214 Views
Message 6 of 7

Re: Port Forwarding on Smart Hub 2

Go to solution
Well spotted. Yep, it's working again.
0 Ratings
Reply
MrAshieB
Contributor
1,198 Views
Message 7 of 7

Re: Port Forwarding on Smart Hub 2

Go to solution

Glad to hear it 😄

0 Ratings
Reply