cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
pmilham
Aspiring Contributor
2,181 Views
Message 181 of 189

Re: Smart Hub 2 and USB

Thank you for your suggestions, especially as now my USB drive is working at long last.

I'm not entirely happy, as I am unable to do a repeat of my actions to check that I properly understand what is happening!

However this is what I did, it may not be the most straightforward approach!

Beforehand:

1. Checked my Kodak USB drive was formatted as NTFS.

2. Inserted the Kodak USB drive into the BT Smart Hub 2. Checked whether I could map the drive as suggested by Tallmat and fawr88 - Not possible, as the "map" option was not showing the Smart Hub or the drive.

2. Checked my PC's network and sharing settings - All OK

Approach:

3. Reformatted my Kodak USB drive with an MBR as suggested by robmcc83. For USB drives this doesn't seem to be supported as a straightforward option in Windows "format" or "compmgmt.msc". So I downloaded Rufus at pmilham_0-1602264640683.png. This gives me the following options:

pmilham_2-1602265660237.png

I formatted the Kodak USB drive as FreeDOS (which gave the USB drive an MBR and avoided anything that would give a UEFI GPT), and then used Windows Format to reformat the USB Drive as NTFS.

4. I plugged the Kodak USB drive into the BT Smart Hub. The USB drive did not show up in "My Computer" (for me that is called "This PC") within "Windows Explorer". I highlighted "This PC" and tried the map option and was pleased to see that the Smart Hub and the USB drive appeared in the list and allowed me to map to the USB drive, see below.

pmilham_4-1602266672822.png

5. Hurrah! All working.

Things that still confuse me:

6. I then tried a Toshiba USB drive (which I had not done anything to other than format as NTFS) in the BT Smart Hub. That worked too. So has the steps taken changed the behaviour of the Smart Hub? So I removed the Toshiba USB drive and inserted the Kodak USB drive. I was intrigued when looking at the hub management that the listing for the USB listed both USB drives as shown below. Not sure how that "feature" could be used, as there is only one USB socket!

pmilham_5-1602267244664.png

7. Windows 10 "Map" lists the Smart Hub as (picture above) lists the Smart Hub 2 as "BTHUB6DX" (presumably an internal device name selected by BT), and refers to the drive as "usb1" (presumably an internal fixed name for the USB socket on the back of the Smart Hub).

 

 

 

0 Ratings
Reply
fawr88
Aspiring Contributor
2,160 Views
Message 182 of 189

Re: Smart Hub 2 and USB

Glad it worked for you.
Tags (1)
0 Ratings
Reply
robmcc83
Beginner
2,155 Views
Message 183 of 189

Re: Smart Hub 2 and USB

Firstly it is very easy to create a mbr partition table in windows by running disk management. 

Secondly I can tell you exactly how the feature of more than one drive showing in your works. 

The way I always use mine!

I have a powered 4 port USB hub plugged into my smart hub. 

I then have 2x 1tb Western digital drives plugged into the USB hub and a 2tb Western digital drive (4tb in total). 

They are all mapped to my win10 computer for access. 

And the shares are also mounted to my raspberry pi which works as a plex server to share all my content to all our smart TV using the plex app. 

Like I said in earlier post been doing the since the hh5 days and never had a problem except I know some devices don't read gpt partition tables so I always use mbr for external drives. 

 

0 Ratings
Reply
sammy4703
Contributor
2,126 Views
Message 184 of 189

Re: Smart Hub 2 and USB

The Toshiba is greyed-out which means it's no longer connected. 

 

0 Ratings
Reply
Sstray
Beginner
2,034 Views
Message 185 of 189

Re: Smart Hub 2 and USB

I had the same problem as everyone else. I could see the drive in windows explorer but not access it.

I tried the suggested fixes i found with no success.

I typed \\192.168.1.254\usb1 into a browser window which brought up the root of my drive.

I removed the non working entry from windows explorer and remapped the network share to

\\ 192.168.1.254\usb1.

It worked!

ND.png

0 Ratings
Reply
SteveRaher
Beginner
1,769 Views
Message 186 of 189

Re: Smart Hub 2 and USB

Hi all

Anyone who is having issue with seeing devices on the USB port on a Smart Hub 2 and maybe older

Microsoft have stopped Windows 10 and 7 working with any device that needs SMB1 function this is USB drives and printers shared from other devices like router hubs or network devices that are not SMB2 compatible.

Smart Hub 2 and maybe older are SMB1

To get around this issue go into windows control panel  then Programs and Features and click the link "Turn Windows features on or off"

Scroll down to SMB 1.0/CFIS File Sharing Support it will not be ticked "ON"

Tick it on it will install and require a PC reboot

You should find after the reboot that when you \\router ip or name the device you wish to share is listed

I have just had BT install Fibre with a Smart Hub 2 and had to deploy this "fix" to get my shared USB drive not seen issue sorted.

Last note if you are on Windows 10 any future updates to Windows may turn off the SMB1 just go back and turn back on again.

Hope this helps

dplayfair
Aspiring Contributor
673 Views
Message 187 of 189

Re: Smart Hub 2 and USB

Not sure if this still an ongoing problem but I managed to get a new 512GB flash Drive to install as a NAS drive on my BT Smart Hub 2 by formatting it as FAT32.
I couldn't do it on any of my Win 10 PCs but succeeded in formatting it FAT32 on a Linux laptop.
Plugged the USB flash drive back into the hub and it was picked up by Windows straight away.
Hope that helps.

0 Ratings
Reply
licquorice
Distinguished Sage
Distinguished Sage
662 Views
Message 188 of 189

Re: Smart Hub 2 and USB

NTFS works just fine, no need to format as FAT32

0 Ratings
Reply
mike8
Contributor
657 Views
Message 189 of 189

Re: Smart Hub 2 and USB

As a matter of interest their is a free downloadable hp exe prog (doesnt install) that formats Fat 32 large drives on windows.

 

0 Ratings
Reply