cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
obsidian76
Aspiring Contributor
146 Views
Message 1 of 9

Smart Hub 2 backup not working

Hi,

I have just been sent a replacement Smart Hub 2 as BT suggested my current smart hub 2 might be behind recent line drops.

So I backup the settings using the router interface thinking that I can restore them to the replacement router.

Silly me new router won't accept the backup file.

So now I have hours of fun and games reconfiguring the new router to match my network settings.

But why oh why can simple tasks such as transferring settings between identical routers be seamless, what's the point of having a backup function if it doesn't work

 

0 Ratings
Reply
8 REPLIES 8
Keith_Beddoe
Distinguished Sage
Distinguished Sage
137 Views
Message 2 of 9

Re: Smart Hub 2 backup not working

The backup would be specific to the hub serial number, as its only intended to backup the settings of that hub, just in case you have to factory reset it. You can use that backup to recover the user specific settings.

0 Ratings
Reply
obsidian76
Aspiring Contributor
124 Views
Message 3 of 9

Re: Smart Hub 2 backup not working

Well that is incredibly irritating and restrictive, that will be an additional 20+ devices that need reconfiguration, oh joy.

Now where is my nearest brick wall /s

 

0 Ratings
Reply
Keith_Beddoe
Distinguished Sage
Distinguished Sage
115 Views
Message 4 of 9

Re: Smart Hub 2 backup not working


@obsidian76 wrote:

Well that is incredibly irritating and restrictive, that will be an additional 20+ devices that need reconfiguration, oh joy.

Now where is my nearest brick wall /s

 


Its always been the same for all the home hubs, even the original home hub 1. The user config file holds some settings which are specific to the hardware/firmware build, as well as the settings you have created, and these may make a different hub unusable. I have not used a BT home hub since the home hub 1, as they have too many limitations.

0 Ratings
Reply
licquorice
Distinguished Sage
Distinguished Sage
115 Views
Message 5 of 9

Re: Smart Hub 2 backup not working

Why have you got to reconfigure multiple devices? If it is to change WiFi  SSID, simply change the new hub SSID to that of the old.

 

obsidian76
Aspiring Contributor
108 Views
Message 6 of 9

Re: Smart Hub 2 backup not working

If it was just changing the WIFI SSID it wouldn't be an issue, it's changing mac address entries on some devices, reconfiguring DNS and DHCP and then going around and checking that each device has actually reconnected then the WiFi discs, it's just time consuming, thankfully almost all the light bulbs are on zigbee coz there is almost 20 of them.

Oh and my 'New' router does not have either a new line cable or network cable so I can't follow the openreach engineers suggestion to swap those out along with the 'new' router.

But it least it's not as bad as when I had (for a brief time) the hybrid connect. 

Well it will be something to do this weekend lol

 

 

0 Ratings
Reply
licquorice
Distinguished Sage
Distinguished Sage
95 Views
Message 7 of 9

Re: Smart Hub 2 backup not working

I'm obviously missing something here, I can't see how any of that information is held on the hub config file.

0 Ratings
Reply
obsidian76
Aspiring Contributor
78 Views
Message 8 of 9

Re: Smart Hub 2 backup not working

It's not but many of the devices connecting to the hub via wireless expect the hub to have the current configuration that I was trying to transfer to the new hub.

The smart hub is acting as a gateway and WiFi access point, DNS and DHCP (ipv4 and v6) are provided by 2012r2 Domain controllers, sure many devices will probably be fine, but they will still need checking

I thought I could save some time by effectively cloning the hub, I'll just have to screen grab each settings page on the old hub for reference.

 

0 Ratings
Reply
licquorice
Distinguished Sage
Distinguished Sage
58 Views
Message 9 of 9

Re: Smart Hub 2 backup not working


@obsidian76 wrote:

It's not but many of the devices connecting to the hub via wireless expect the hub to have the current configuration that I was trying to transfer to the new hub.


There are extremely few configuration changes you can make to the hub from factory defaults so I still don't understand  what you were expecting to clone and what configuration your devices were expecting the hub to have.

The only configuration changes you can make are basic firewall rules, port forwarding rules, SSID, and IP addressing range.

0 Ratings
Reply